WYZE Video Doorbell connectivity issues

Hello everyone,

I recently purchased a WYZE video doorbell. Installation was easy did not have any issues. It connected to my network with no problem and everything seems to work fine for maybe the first hour of having the camera on. All of a sudden I cannot live view at all, goes through step 1 then 2 and then just stays on step 3. Sometimes it goes through all the steps and I get a black screen with a time stamp. The doorbell functions and detects motion like it is supposed to, BUT I go to view the motion videos and those do not work either. I get error codes 5 and 6. I have 3 other WYZE Cam outdoors and those have worked fine without any issues. I have reset the doorbell, hard reset it by taking it off the mount, I updated everything, restarted the app and my phone, I logged in and logged out, cleared the Cache, I logged into my router, found the doorbell’s IP address and made it a top priority on my network. NOTHING HAS WORKED. Has anyone had any luck fixing this thing?

1 Like

I loss door bell internet connection when it is exposed to direct sunlight. The components fail due to high temperatures. I put a shade above the doorbell and it resolved the connection problem, but the shade blocks half of the camera view. WYZE has to harden the components for outdoor environments.


I’ve had this same issue. WYZE keeps telling me it’s my network and that I have so many entities on the network. However, very few things I’ve done have changed anything about the doorbell experience.

It is NOT your network! It is Wyze Firmware. HUNDREDS of posts! Been going on for months.

Current Firmware fix is anticipated:

Go to these threads and link thru to the Popular Links… Readings for days. Very well documented problem.

Was it Wyze support that told you it was your network, and if so did they give you a ticket number so I can follow up on what info they are passing along. This is a well documented issue and a fix is in the works. I am sorry you are experiencing this issue like many others are.


Yes, they did give me a ticker number: 2198942. They finally offered to replace it under warranty or a gift card this morning

There is an on-going connection issue (stuck at Step 3 usually) with the Video Doorbell that believed to have appeared with a recent (not so recent now) firmware update.

Like posted by @SlabSlayer above, this has been pending for few months now and most of us are unable to fully exploit our product. This situation is totally absurd.

I posted recently about the issue appearing to be resolved in my case. I was too optimist as it lasted only few days, where connection was instantaneous.

Now, it’s back to the post firmware update snafu. The Video Doorbell gets stuck during connection, making it unusable.

And no, my networking environment is not at play here. Signal is strong and ultra stable.
As for the comment about heat, it could be an explanation but, unfortunately, even without sun or during the night, the issue occurs - nice try.

Considering this problem has been plaguing Wyze customers for few months now, I wonder how anyone considering to buy the Video Doorbell and that spent only few minutes reading the community comments could buy this product.

Wyze really is dragging its feet here…

Never mind, only got offered $20 in a gift card.

Been having the same issue for months on firmware 60 and not solution in sight.

I have several Wyze products and all of them have been pretty much great quality except for the video doorbell after the firmware update.

I tried something a few moments ago after waiting 15 minutes for the live feed to start playing and switched it to 480P, the issue came back immediately.

Now I’ll get a few frames of live video and then 0.0KB/s and then back to trying to connect.

The app, regardless on Wifi, LAN connection, or 4G/5G continues to report the same issue.

Firmware Version - Not sure what the actual fix was that this firmware was supposed to resolve. So far, it was only working as marketed before firmware 43/60

Wife is starting to doubt having the entire ecosystem over the device she depends on the most.


I hear you.

It’s surprising to see Wyze “apparently” doing nothing - or at least in total silence - when there are that many devastating reports on this product since the faulty firmware.

Jason has provided updates on this issue weekly. It was confirmed some time ago and several attempts to fix the firmware have been tested internally but have not passed internal QA. Would you rather they release more Firmware that is just as buggy?

Jason posted above just 7 hours ago.

The surprising thing to me is… why not just roll back the firmware update? Is the firmware soooo important (assuming it’s security) that it can’t be rolled back? At the cost of users?

1 Like

Thanks for pointing.

Having a cyber security background, I can say that about 3/4 of a firmware updates are to address security issues along with functionality. It would make sense for the company to remain quite if it does have something to do with a potential zero-day that no one wants to divulge.

However, there are clear ways to communicate that and would probably be enough for most community members to have some hope that this is always for our benefit, rather than the potential that the hardware moving forward was not going to be sufficient for the use case that was initially marketed for.

The Wyze Doorbell Cam Pro seemed to be the direct successor to this and so far I don’t know if it affects that model, but it was released shortly after the original, almost giving me instant buyer’s remorse the same way smartphones and apple devices get tossed up with their current and then overshadowed a few months later by their “Pro” counterpart after the initial adoption.

I’m rooting for Wyze, my entire eco-system for home monitoring is Wyze and I am destined to move into a new house. However, the wife has recently started to talk about transferring the current eco-system over to the new house and has doubts now, only about the video doorbell.

I guess if I want to avoid more issues in the future, it is the eventual upgrade to the “Pro” version, hoping that another firmware snafu doesn’t occur again, or change out the system for a more consistent experience, albeit more expensive, to fulfill my need to automate, and my wife’s need for convenience.

It’s also, somewhat difficult to find all these threads for the latest information instead of a sub-board that handles only outstanding known issues at first glance. Not going to lie, spent about 45 minutes combing the board only to realize post had been running back for years on something similar and the latest post I’m looking for is categorized somewhere only veterans have picked up along the way. It’s my first day on here, be gentle, I’m just a man. :smile:

The forum threads can be a bit difficult to navigate, especially if you aren’t familiar with the Discourse tagging format. If you drop down the nav menu (three bars) and select tags, every Wyze product is categorized as a tag. If you select the Video Doorbell Tag you will be shown posts only for that product ranked by latest post date. You can also reorder the list by the most posts.

Wyze posts these in their Knowledge Articles, although it is not complete:

The best way to get directions is to ask for them. There are so many helpful users in here who will link you thru to what you need.

and Welcome to the User Community Forum!

1 Like

Yes this is sadly outdated, this will be getting caught up soon. I just need to finish getting the proper people involved so it can be maintained in a timely manner.


In the meantime while we wait for a fix, here is the workaround that I found and let Wyze know about:
When your LIVE feed gets to “Step3: Getting video data” and gets stuck, press the gear to go to ‘settings’, select ‘Advanced Settings’, select Night Vision ‘On’ and then ‘Off’, then press the ‘<’ key to go back to LIVE feed and it will connect.
It took me a long time to find this workaround. I expect that it will work for everyone having this issue since it seems to unstick it by going thru night vision mode. Sorry, but if you use Night Vision, you will have to turn it back on. But, at least it is a reliable way to temporarily conquer this bug.
Your welcome. I hope it works for you too.

Wow, glad to see it is not just me. My doorbell video works well enough, when it can stay connected. I have to go down to the utility room and turn off the breaker for the circuit that my Wyze doorbell is on so that it will reconnect. The doorbell should be able to reconnect itself without needing a power failure to kick it into reconnect mode.

Seems like the list of posts about doorbell connection issues is extensive. A quick search shows far too many:

1 Like


The latest Video Doorbell (V1 wired) firmware is out of Beta and looks VERY promising at fixing this issue!

Here are the feedback posts that came in from the Beta Test:

1 Like