Wyze doorbell (March 30 2022) - unusable/slow connection & streaming

Since updating my firmware to the one mentioned in the comments, it takes about a minute to authenticate with my doorbell (sits on step 3 of 3 a long time) and then once it does start streaming my door bell video is playing back at 1.2KB/s

  • I’ve reset the doorbell, no change.
  • I moved my router closer and reset again, no change.
  • my other wyze cams (2 x v2s) work fine, they authenticate quickly and stream at 70-100KB/s and are located further from my router.

Anyone else having issues? is this a firmware issue?


I have the same issue, although for me it seems stuck at step 3/3 (maybe I didn’t wait long enough)

I have noticed if I have motion while it is stuck at step 3/3 it will immediately connect.

Looks to me like they either have

  1. an issue with task scheduling, causing the a authenticator task to be not run
  2. they are not sending keep-alive packets frequently enough and a stateful firewall closes the active connection.

The issue seem to have started with the lates firmware update


Thanks for sharing your feedback.

Yeah I’m having mixed luck with getting into the doorbell. Earlier it would eventually load albeit with 1K/sec bitrate (after hanging on step 3/3). However, now it’s staying on 3/3 and eventually asking for me to power cycle which I’ve done a couple times.

I did open a ticket as well and referenced this post.

Thanks again.


After the update on my VDBv1, the load time does not appear to be affected but the stream speed is incredibly slow. This leads to image skipping and object blur lines. A good majority of the time it bogs to 0.0 K\sec and locks up.

1 Like

+1. After the latest firmware update, Video Doorbell sits on step 3 for about 30 seconds and it may or may not connect. I have no issues with speed though, once it connects then HD works fine. Totally useless if someone rings the bell and I can’t get the video feed.


I’ve had similar issues as well and when the video loads the screen flips to portrait very large and grainy and then flips to landscape then to normal portrait clear. And very loong load times on the one camera, the other camera is about the same as before the firmware update except for video flipping from portrait to landscape and back.

1 Like

Having the same issue. Since I applied the firmware update today trying to view the camera hangs at step 3 of 3 authenticating but never does. Videos are not being recorded consistently. My setting were all set back to factory default. One of the things in this update was integration with Google assistant. That still doesn’t work.

After finding all of the above I powered it down, left it for a minute, then powered it back on. No change. Pressed the reset button on the back of the VDB and went through the steps of adding back into the app. Still no change.

I was very excited to get the Google assistant integration, but very disappointed in the results of applying this firmware update. Looks like they didn’t do any regression testing on this update.

1 Like


I too am experiencing stuck at step 3 of 3 authenticating. Weird part is I have two of these. One at front door and one at the back. The front door has been fine it’s only the back having the issue. Both are relatively close to router. Did all the normal troubleshooting no resolution. It gets stuck about half the time.

So. Someone on Reddit mentioned waving your hand in front of the doorbell camera and then trying to access it and it may work. Not a solution but an interesting behavior. I haven’t had a chance to try but i did notice the 1-2 times I was able to login it was raining so perhaps the drops ‘woke’ it up… odd

Yeah, looks like mine is restarting if motion is detected and it’s in the limbo state as blue and yellow lights start to blink.

Same here. New update for wired doorbell has me constantly stuck at step 3 or 3: authenticating. :frowning:


I have this problem too wit my video doorbell. Grainy, flips 90 degrees and then flip back 90 degrees

1 Like

The flipping issue continues. But the grainy video is probably because the video quality was reset to 480p like mine was. You should be able to reset that to HD in the upper right. My guess is that Wyze set that as the default after reset to save on cloud video storage space hoping no one would notice.

I found that when I’m able to connect to the doorbell the speed is really slow and it is grainy. If I leave it for a bit the speed increases and then I get HD again. The recordings have still been in HD.

Anyone heard anything back from support other than “we forward the information to developers”?

Not since I shared 3 sets of log files. I assume they got them? I dunno.

Can the firmware be rolled back to an earlier version until this connection error is addressed?

Welcome to the user forum @dbooth!

The doorbell has no SD card capability so it cannot be manually flashed to an older FW version like the cams w\ SD Cards.

The only way to do that is if Wyze posts a new FW update that has the old coding.

Began seeing longer live view times, or timeouts repeatedly, very slow playback that is inconsistent. While the V3 Cam is ok, though it has also experienced recent similar issues. WiFi strength is fine and even a closer AP does not help.
The issue seems worse in the afternoon, even though internet throughput and response time are good.