WYZE doorbell won’t connect

Do you have your 2.4ghz and 5ghz WiFi bands separated on diffrent ssids?

Also, are you aware of the max devuce limit of your router?

Did this start recently, or as soon as you got it.

Contact support or return it to where you bought it for a replacement if the above doesn’t work.

I am sorry you are having this experience. We are currently looking into an issue where the Wyze Video Doorbell will get stuck on step 3/3 when connecting. Does this sound like what you are experiencing or is yours something different?


Yes, MANY of us are experiencing this issue and have been promised a resolution for well over a month! Wyze still has not corrected the issue with the doorbell camera and Alexa not connecting with it, and that issue is even older! I realize that fixing these issues does not generate income, but come on!

1 Like

Theyre too busy working on the pro version.

Wyze jason himself posted in the megathread a few min ago something about beta being postponed 7/1

By postpone he means freely available and ready to destroy new devices

Id reply there but apparently i cant post anymore :rofl:

1 Like

Yes. That’s exactly what’s happening

1 Like

Welcome to the User Community Forum @nhawkins1123!

Unfortunately I am also waiting out the fix for this… But I am hopeful and confident that Wyze will figure it out.

Also, I have some reading for you:

1 Like

Just tested the Fix-it Friday thread where Jason posted that. Still open for posts. :man_shrugging:

According to Firmware info Version (April 27, 2022) Fixed a bug that caused the live stream to get stuck at 3/3.
My Video Doorbell is running this version and I am still having this issue! I bought a new Wyze Video Doorbell - updated firmware and the same dang issue!! Doorbell will be returned.
Am on iPhone 13 Pro - iOS 15.6

All 6 of my Wyze cameras V3 connect great! This bug needs to be fixed ASAP.

Shortly after it was released in April it was found it did not fix it. There should be a beta resuning soon that hopefully fixes it.


Wyze needs to look a little harder. I’ve been a Wyze fan for many years now. But it’s getting tiresome to have to go through the reconnection troubleshooting sequence over and over again. I’ve even monitored the doorbell power supply to eliminate a possibility it was a power problem. A Cam v3 on the porch next to the doorbell performs flawlessly as does a v2 that is farther away and a Pan Cam with a motion sensor and two contact sensors. Comes down to two things, the doorbell hardware or its firmware. Operating temperature related stress on the circuit board? Firmware can’t get past step 3?
As an aside I just discovered that the doorbell, unlike all the other cams is not compatible with Alexa. What’s up with that?

The doorbell did at one time work with Alexa, but the image displayed sideways. Wyze said they were going to fix it, so now we can’t get it to display an image at all with Alexa. Great job!

What I can’t understand is why the firmware for the doorbell is different from other cameras. Admittedly the doorbell has some functions that other cameras don’t have, but they are separate from the camera functions.

Because it’s not the same camera. If it were, the field aspect ratio would be the same size as other cams. It is not. It is much larger vertically.

1 Like

When I mentioned different firmware it was in relation to the connection sequence. I don’t see how aspect ratio would affect that. But then again I’ve tried everything recommended to no avail, so who knows?

1 Like

Yeah, I understand. Personally I think it may have something to do with the changes they made in .042:

Fixed a bug that prevented night vision changes

Since many are realizing login\image load fixes by locking the cam in IR NV. But that’s just my theory. Could be multiple issues.

Wow! Unbelievable. I have been working with Wyze about this problem and am also convinced that they broke it with the last firmware update. AND… I just tested the comment that if you wave at it while it is in “Step3: Getting video data” and sure enough, the LIVE View came right up. So it gets stuck in Step3 just like everyone says.

This Step3: Getting video data issue is very frustrating & hopefully Wyze will get this corrected soon! Other than this, my doorbell works fine - I prefer the 3 x 4 aspect ratio over the fish eye on other video doorbells, including Ring & Wyze Video Doorbell Pro.
Some days I have no issues connecting - other days it is almost impossible to connect - go figure!!

Have you tried to put it into IR Night Vision Mode ON permanently and run it through the wash that way? Many have found that it stops the loading issues if you can live with the Black and White video until it gets fixed.

Thanks for the tip - so far this has helped with loading issue. No worries on B & W

1 Like

Just after I replied to you, video doorbell starting acting up and not connecting even with IR Night Vision Mode On! Wonder if Android users have as much problem as iPhone users?

1 Like