Hello Wyze; please fix connection problems with hard-wired video doorbell

There are many, many people on these forums expressing frustration that their video doorbells (hardwired) are not “connecting” to their Wyze app, rendering them useless. I am creating this separate thread to specifically implore Wyze to please fix this issue; from the perspective of a top 1% of Wyze user.

I have purchased more than 50 wyze items. This includes two headphones, a scale, three outdoor cams, three solar panels, 5 panning cameras, 4 original wyze cameras, 12 V3 cameras, 3 sets of door sensors, three lamp socket adapters, and a bunch of other stuff I’ve forgotten (I operate a dog kennel on my property so a bunch of the cameras are for that). I cleary am invested in Wyze being a successful company and have evangelized their products to my friends and family.

But like many others, My video doorbells simply are not working. Because of my unique situation (I have TWO video doorbells operating on different doors) I can say that it is almost certainly a software issue.

Of all my wyze products, the video doorbell on the front of my kennel is definitely my most important. But it simply will not connect. Here’s the brief rundown of what is happening with it and my other doorbell.

When opening the app and clicking on the doorbell, it gets stuck on authenticating. Sometimes it’s “step 1 of 3” but more often its at “step 3 of 3.” I have called Wyze support and they stepped me through all of the things I have tried multiple times. I have reset the doorbells mulitple times; which works for a few minutes. Just this morning I reset my front doorbell; worked great for 10 minutes. Now stuck at “step 1 of 3”.

I actually bought a THIRD doorbell a few weeks ago and decided to replace the wzye doorbell at my kennel yesterday. Worked great! for 15 minutes. Then nothing; stopped working for the rest of the day. Sometime in the middle of the night it started working again; and right now it’s still working. EDIT: spoke too soon. Just checked and it’s showing “Step 3 of 3: authenticating” again.

Yesterday when I talked with wyze support, they clearly were unaware that multiple people were having this same issue. Ultimately they decided to send me out two new doorbells.

This, of course. will likely solve nothing consider I just went ahead and replaced one of them yesterday with a brand new doorbell and it still had identical issues.

So I have a request of wzye: PLEASE MAKE FIXING THIS A PRIORTY. PLEASE!!!

And instead of sending me two brand new hard wired doorbells, maybe allow me and others to simply get the doorbell pro (happy to pay the difference in price). I’ve already paid 150 bucks or so for three non-functioning doorbells. Doesn’t seem right I should have to pay another 200 dollars for two more that likely will work.

If others would like to encourage Wyze to focus on this issue immediately, give me a hell yeah in the comments.



Not just this issue , all of the others too

Hello @lazespud

Sorry to hear of your issue. I can empathize. I had a similar situation in the past.

I myself am well invested in the Wyze Ecosystem having nearly if not now over 200 Wyze connectable devices in my home. Which includes every product offered by Wyze.

My story was with the Wyze Switches and the Wyze Robot Vacuum . All of my Wyze devices connected without issue from day 1, except the Wyze Switches, I could set them up without a problem, then after setup they refused to stay connected. They would connect and disconnect within a matter of 30 seconds. Over and Over. For the Wyze Robot Vacuum once a month it would disconnect and the only way to get it to reconnect would be to reboot my IoT wireless router.

Not a lot of focus on the WRV, but I spent countless hours troubleshooting the switches (on my own accord and desire, which I know most do not want to do), digging into my router logs making configuration changes to the point where my communications and updates in the beta thread got attention from the Wyze Dev team and they assisted me in troubleshooting, all with no resolution.

I have a separate network for my IoT devices, and what it turned out to be was my Spectrum Wireless router just would not accept the Wyze Switches, I still don’t know exactly why, because, I ended up replacing the Wireless router to a newer device and both of the troubles above went away and I now have no issues with any my connectable Wyze devices.

Would be curious if you had the ability to setup the Doorbells on a different router/access point and if you would have a different experience as I did.

I don’t make this suggestion as to say there is not an issue that Wyze couldn’t/shouldn’t look into, and I am sure if the incident tickets are staring to get some volume, Wyze will or is. I just know there are a massive amounts of Operational Technology Devices on the market, and having to account for all nuances from an IoT standpoint has it’s own challenges. Something that may help Wyze is if there is a common denominator in the Operational Technology that can be identified related to the Doorbells not connecting properly.

Have a great day!


Just FYI for anyone wondering about this issue and wanting to know where Wyze’s responses and updates will be posted, follow along with the #fix-it-friday updates for more information on the progress of this issue. Most recent update posted today, Aug 25th in the thread that started for the Aug 5th Fix it Friday event:


In the meantime while we wait for a fix, here is the workaround that I found and let Wyze know about:
When your LIVE feed gets to “Step3: Getting video data” and gets stuck, press the gear to go to ‘settings’, select ‘Advanced Settings’, select Night Vision ‘On’ and then ‘Off’, then press the ‘<’ key to go back to LIVE feed and it will connect.
It took me a long time to find this workaround. I expect that it will work for everyone having this issue since it seems to unstick it by going thru night vision mode. Sorry, but if you use Night Vision, you will have to turn it back on. But, at least it is a reliable way to temporarily conquer this bug.
Your welcome. I hope it works for you too.

Same here. I’ve been a loyal Wyze customer for many years so am extremely unhappy with the lack of response on the VD issues.

I have 2 of them installed for almost 6 months now and they are totally useless to me.

If I have notifications turned on I get a rash of alerts every time a branch moves but no notification if a person arrives . Zones do not work, person detection does not work, and even if I did get notified, by the time I can see the live feed the person would have left.

If Wyze isn’t embarrassed by this terrible product they certainly should be.

1 Like

I’m personally not sure it’s software. I’ve had THREE Wyze Video Doorbells. The first bought in early 2021, right on the release…

It lasted three weeks.

The replacement Wyze sent worked for about a year, then stopped connecting to WiFi. It would still power on, still connect to the chime, but no video.

They sent a THIRD doorbell that worked for the last couple of months, but now seems to be dead. Like I can’t even get it to power on and stay on.

I begin to suspect: this is just kind of bad hardware. :frowning: Like others, I own a lot of Wyze products, most work well. The Doorbell is a pain.

1 Like

We got back from doing groceries today and both of our doorbells are offline and will not reconnect.

I echo the frustration that everyone has with the video doorbell. I have intermittent connection problems where it retries the connection multiple times and then fails. This has been going on since I installed it. Some days it works fine and other days it won’t connect at all. My latest problem is with the detection zone. I get notifications many times each day that it has detected a vehicle. However, the detection zone is set to only monitor the steps at my front door. There is no way a vehicle could be in the detection zone.

Hey, Wyze is currently trying to fix the detection zone issue. Can you elaborate a bit more and submit a log for the doorbell in the devices settings > Wyze support > submit a log. Please post the log number in this linked thread:

The detection issue seems to have resolved itself. No more false alerts for vehicles. The detection zone seems to be functioning correctly. If you did something to correct it, thanks.

1 Like

I’ve encountered same connection issues and the only way to configure the router and set up the firewall correctly would be to obtain and set port forwarding on router.

What are the ports used by the door bell cam?

I’ve sent the logs but doubt that anyone analysed the logs without me having to call in and tell a person what the logs are for and that takes 1.5 hours based on my previous and only time I’ve contacted support.

With all the issues listed here being true, in comparison to my previous vivint cam experience, I absolutely appreciate the wyze cam trying it’s best and sufficiently alerting me of activities.

Port forwarding is not needed for this device, and won’t do anything.

You have to post the log number here or in a fix it Friday thread. Wyze doesn’t look at them unless asked to.

Welcome to the Wyze User Community Forum @d8f93d74b9295392448f.

Have you reviewed all the topics related to the problems that many users have experienced on the Video Doorbell V1 and some of the workarounds they have found useful? There are documented connectivity issues related to recent Firmware updates. Your issues are most likely similar to those in other posts.

@SunSparc has put a reading list together and you will find useful links to other topics and posts within each of those listed.

I recieved a firmware update yesterday It finally solved the stuck on 3of3 loading issue. Now I have to decide if I want to try cam plus again and see if the videos load or I get the same 09 error code.

I have also been running the Beta only FW .314 with success.

Still waiting for the Beta Announcement Thread to appear so we can start posting feedback.

Be sure to thoroughly test this version and put the screws to it to make sure it will hold up. The Detection Zone and AI accuracy were the two other areas that were reported to have been major issues in the last version.

Once the new Beta thread is announced, we can report findings there.

I’m just happy that it loads. I still get an error 09 and can’t play video however.