Video Doorbell ongoign problems - will not stay connected

Has anyone received any help from Wyze for the doorbell cam problems? This is the second one I’ve had and the first one I sent back thinking the camera was the problem but this doorbell camera is doing the same thing, not staying connected to the Wifi. My old RING doorbell was always on, a little slow but at least it worked. This is a total disaster. The only way I get it to work for a few hours is to take the doorbell off the wall, disconnect and reconnect one wire then go through the entire installation process again, and again, and again. This is the worst product Wyze has sold to date. I don’t recommend it. The only thi8ng Wyse has said is to reboot my router. That didn’t do anything either.


Welcome to the forums! Can you tell us a little more about your wifi system? Does the doorbell stay powered when it has a connection issue or do you know if the camera is resetting or rebooting? How is the doorbell powered, and with what type of transformer? Can you measure the power output at the wires of the doorbell?

1 Like

In the last 5 days, I had to flip circuit breaker (did nothing) and reset router to reconnect doorbell. Hadn’t had the problem since installed in May. Keep getting error code 90. Outdoor and indoor cameras still working as is door lock. That would indicate not a problem with internet. Any fixes for this?

Update the firmware to the most recent version.

I wouldn’t say the internet would be the issue, I would say the wifi signal between your doorbell and the wifi source may be of issue. Where are your outdoor cameras in relation to the doorbell? What is in between your doorbell and the wifi source? How many walls? What are the walls, and especially the exterior walls made of? How is the doorbell powered? Have you tested the power output at the doorbell location? Looking at all the possible issues, thanks in advance!

1 Like

Did you open up a ticket with Wyze? I had the same problem with my doorbell; after a few hours it would either disconnect or get stuck at “Step 3- authorizing” and not reconnect until I powercycled. It did take multiple back and forths with the tech support to troubleshoot (reboot the router, check software and firmware versions, check the wifi connection by installing the RouteThis app on your phone and sending log files to Wyze, check voltage at doorbell to make sure transformer is capable of servicing the doorbell, powercycle again, etc.).

But after all of those steps, they agreed the doorbell was faulty and sent me a free replacement. The replacement has been working flawlessly since I installed it, so clearly there is a batch there with faulty wifi chips (or something like that).

You just need to patiently let them go through the steps…

I have the latest firmware. Why would there be a problem with wifi interference after 4 months of working? Yesterday the image was all pink. I had to restart the camera to restore the image. We are now experiencing lower temps at night and had 2 days of rain last week. Is there any documentation of weather affecting the performance?

I have the same issue. I have the latest firmware. I’ve switched to my 2.4GHz network (3-4 bars when it IS connected) as well. Nothing works. Sometimes it will stay connected for a week, sometimes hours. Then it’ll just disconnect until I flip the breaker. Actually, I got sick of flipping the breaker and let it sit with the blue flashing light for about a week, because I’m tired of this nonsense, and it reconnected by itself at some point. You’d think when the doorbell loses connection it would just retry connecting every few seconds.

I’d actually venture to say that when I installed the thing in April it worked great for like 3-4 weeks until the May firmware dropped. That’s when all of my issues started.

I want to like this thing, but I don’t.

I’m using an Amplifi HD mesh system with a node sitting about 10 feet above the doorbell broadcasting a fantastic 2.4GHz signal to it.

@sobomp3 , can you tell if the doorbell is connected to that close node? Or a different one?

@dcloz242 , how low of temps? unless you’re getting really low out of the operating temperatures I think it should be fine. The doorbell is IP65 weather-resistant so it should be able to handle some weather.

last week we were down in the 40’s overnight with rain. This week 50’s with highs in 70’s no rain. Had the connectivity problem at the beginning of this week. Must be a glitch in software??

Perfect temp for me! The doorbell should be fine still. Software glitch, I don’t know, the pink seems mechanical proboly due to the ir filter being temporarily stuck in place. To me I’d say that’s a different issue than the connectivity whatever that’s going on. Still waiting in some answers to questions from above to help understand your use case.

In addition to that how’s the Wi-Fi congestion in your area? How many total other devices do you have on the same network?

It has gone offline two more times. I have deleted it and re installed twice. The router is at the ceiling of the lower level 15 feet from doorbell. Door lock, outside camera, one inside camera and several window sensors. Worked fine since installing in May and now won’t stay connected.

What version are the inside and outside cameras? The lock connects to the gateway, which is it’s communication source, where is the gateway located?
The door sensors connect through the hub or bridge. Are they v1 or v2 sensors? Where is their hub/bridge located?

What type of router? How many total wifi clients are connected to it?

Same here, mine connects for a few hours then goes off. I have unplugged the doorbell cam and reinstalled it multiple times. All Wyze can offer is to restart your router which I’ve done multiple times to no avail. I’ve even bought a range extender and put it 5’ from the doorbell with no difference in connectivity. To me this doorbell is pretty much junk. The Ring doorbell I had never had any problems connecting or staying connected. I am at a loss and am ready to look for a different brand doorbell camera.

1 Like

Wyze cam 2 version 4.9.71068
Wyze cam outdoor version
Outside base connected via Ethernet next to router
Sensors via bridge to Wyze cam 2 in lower level where sensors are located. Device info does not state V1 or 2
Lock gateway in hall near door lock. Full wifi strength.
Comcast router. I live alone so iPhone, iPad laptop, nest, garage door opener and two smart plugs. No issue with any device staying on line except doorbell.
All firmware up to date.

Had another incident yesterday, I turned off/on power and reset router which takes 10 minutes to reboot. All devices connected again. There has to be a fix for this???

Reading through this thread I also have similar connectivity issues with my WYZE doorbell. This is my second WYZE doorbell as the original worked great until it failed to connect. After working with WYZE Support, they replaced the unit under warranty.

Now with this replacement WYZE doorbell when it fails to connect, sometimes a RESET from the app would bring it back. Other time takes a power off RESET to bring it back. I pull the wires at the transformer end to remove the power. So far once the power is restored, the doorbell reconnects without having to delete and add the unit back, which is a plus. I don’t like to remove the doorbell from the mounting, because I feel the mounting tabs may break.

The wifi signal is at 3 bars with device info. I have a V3 Cam 3’ away from the doorbell and that it has no connectivity issues. Both unit are with 6’ of my wifi extender so they have a nice strong signal. All of my WYZE devices are on the latest firmware and app is current too.

Now my most annoying issue with doorbell is the Error (code 06): Failed to fetch the video from the cloud. Is that a server issue or the doorbell issue? I have Cam+ enabled on the doorbell. I can see the Live view, but can’t see previous activities with this Error 06 issue. How could we fix this? Thank you.

Welcome to the forums!

Is the v3 outdoors next to the doorbell? What is between the wifi extender and the doorbell? what type of exterior wall and construction? Is there a different wifi source to try with as I have heard wifi extenders arnt the best.

The V3 Cam (not outdoor model) is about 3’ further away from Doorbell Cam looking out the window next to the door. When I open the door, I could see the wifi extender about 10’ away. So the signal is through the wooden door jam and not the stucco wall. Both cameras has 3 bars full signal strength from the device info page. I also ran that 3rd party tool when I was troubleshooting with WYZE Support with the original doorbell cam and they didn’t say it was a signal strength issue.

Anyway the original doorbell cam worked flawlessly for months before it started to connectivity issues. The warranty replacement doorbell cam work fine from May until it started to get those Error 06 a couple of weeks ago. Nothing has changed at my house so if you are looking toward a weak signal issue, they would not have work from day one, which they did for months before the errors showing up.

Now something strange with the doorbell cam today without me doing anything. The doorbell cam appeared in the app Event log page starting at 9:48AM. I saw motion event at 10:01AM, 10:10AM … 3:07PM, 3:10PM. No more Error 06 which is exactly what I wanted. Did WYZE support do anything because I didn’t. I waited to see how long this would last and at 3:36PM I saw the 1 of 3 authenticating message not able to connect. Now the doorbell cam is down again sad to say. Device is offline (error code 90).

Somehow it came back on it’s own with alerts and everything, but then it died again. So look like I have the power off the doorbell cam to see if it would comeback again. May be I should add a WYZE switch to the 110V side of the doorbell transformer so I would power it off with a command instead of pulling wire off from the low voltage side.

So now I have connectivity issues with this warranty replacement doorbell cam, instead of just not able to see the event log with the Error 06 fetch issue.

What do you suggest now? Has this doorbell cam also have issues?

I got to the doorbell cam yesterday. The power reset did not bring the unit back at first. I removed the doorbell from the mounting plate, then pushed the Reset button. Deleting and re-adding the unit back brought it back online.

So far so good. I’ll monitor to see how long it stays working.