Wyze Cam v3 Pro firmware - Released 11/1/2023

We’re releasing Wyze Cam v3 Pro firmware today with security improvements! Please update when you have a minute. :lock:

:notebook:Read our Release Notes:


Done, Cam went off line and stayed that way after update. Power Cycle via smart plug got it alive again (I hope it stays alive). The update was very fast.


Attempted to update 3 Cam v3 Pros. 2 were successful. 1 failed and will not recover even after powercycling. Will attempt a firmware flash, but may not attempt until tomorrow due to cam’s location. If you need me to do something for debugging before attempting flash, let me know.


mine got offline, power cycled, factory reset to no avail.
will not update other one.


Yikes. Reports in here are not promising…


Doing mine now. After reading the reports, decided to do it one at a time and see what happens. I am not using the bulk Firmware update process


All of mine updated successfully and was able to live stream. Updating them one at a time may have helped. I did note on all updates, the app reported network issue and then cleared itself. Not sure if the process resets the network connection which causes the message.

but they did update successfully.


Updated the one at home (4 feet from the A.P.) just fine. The other one is in my truck in a concrete parking structure about 100 yards or so from the nearest A.P. and it failed - but it’s a really crappy signal. When I leave work I will drive closer to the A.P. and try again.


I have three V3 Pros, and I know two of them got that weird network issue too about mid-way into the firmware update (but auto-recovered). The other one might have gotten it, but I did not notice it. Each took about 3-4 minutes on my network to update. I would love to know what the security updates were, but maybe ignorance is bliss.

Updated one V3Pro via the Bulk Firmware Update page. Fast install, no issues, rebooted to online.

Given the issues with this and other cams having problems when updating multiple cams simultaneously thru Bulk Update, I suggest only updating one cam at a time.

Certainly makes a good case for Progressive Updates

1 Like

I only have one V3 Pro and I updated from the device info > firmware section of the app not the account > firmware bulk section. I just checked and it is still working after the power cycle from a few hours ago.


It would be nice to know what was done. Sometimes, security updates are done because of a finding or need. Not sure we will get additional information, but it is worth an ask.

@WyzeJasonJ , any more information on what security updates were done?

1 Like

Updated one of my v3 pros to the latest… Will no longer connect to wifi. “can not find the specific network name” Tried factory reset, still same error. Reverted to previous firmware and still wouldn’t connect. Gave it one more factory reset, after downgrading and it finally came back to life. Tried to update firmware again got the can not find the specific network name error. Disabled auto update on the rest of my cams…

1 Like

Two brand new V3 Pro cameras and both will not recover after the attempted firmware upgrade. Tried factory reset and doing the manual fw upgrade. Neither worked. Totally bricked!

1 Like

Did a reset on the v3 Pro with botched firmware update and it’s back up and running. Checked firmware version to retry the update… previous update actually succeeded because is loaded and running fine. :confused: That was a weird one. :thinking:


Who is signing off saying the release was ready? It bricked all three I updated. Who ever gave the green light to push the release needs to be fired.

You are a company now offering home security. This type of action is not acceptable.


Similar to what others have described so far, took update and never came back online. Attempted factory reset several times (hold setup button 10+ seconds) and still get “cannot find the specific network name” each time. Same network it was connected to previously. I changed some settings on the router to make sure 2.4ghz band had a different name and tried to connect to that - still can’t connect. I will try to flash the firmware to the previous release to see if that will get it back online.

1 Like

Looks like both of mine are bricked too. Sigh

1 Like

Stuff like this is what starts class action lawsuits…

Started updating mine. First 3 went perfect. I was feeling good about it.

4th one took forever, then said update failed.

  • I went and restarted it, but that didn’t work.
  • I then went through setup, but it said something about not being able to find or connect to the network.
  • I reset it to factory settings and tried again. Failed again
  • I tried again. Failed again
  • I reset to factory settings and tried again, it failed again.

I brought it inside the house, used a different cord and had it next to a satellite mesh router…I reset it to factory settings and tried again. This time it was successful

Thoughts: Where it was outside, it was on a longer 3rd party cord, and might have not has as direct a signal to the router as it wants, even though it normally functions perfectly fine in that position. Perhaps it gets slightly less power and slightly lower signal there, so it couldn’t do the update there.

My suggestion: If your camera fails the update and won’t turn back on, bring it inside close to the router using the official Wyze cord or a short cord with an adapter that provides sufficient amps. Then reset it to factory settings, go through Setup again.

I still have 4 more of these to go through, which probably means if 1/4 go non-responsive, I will have to do this at least 1 more time. Might wait till tomorrow to do it.