Wyze Cam v3 Pro firmware - Released 12/12/22

Wyze Cam v3 Pro firmware is releasing with improved low light performance, noise cancellation, and thumbnail image quality! It also fixes 0-second Event Video and device connection issues. Better, faster, stronger! :mechanical_arm:

Read our Release Notes:


The firmware killed my V3 Pro :astonished: It will not stay connected now, it just keeps freezing the live view. 2K, SD 360 makes no difference. I have powered cycled the cam 3 times already ! Picture is horrible because it will not load live view correctly.


Do I have to change the file name if I flash the firmware again with an SD card???

That’s a good question. I don’t see any specific support info for flashing a v3 Pro. I’d try leaving the filename as is “recovery_wcv3p.bin”. If the name isn’t correct, the file simply won’t load. You might also try renaming to “demo_wcv3pro.bin” if the original filename fails.

1 Like

Thanks maybe later. I am tired of moving the ladder around and moving cams. I put a V3 back to cover the driveway. I brought the V3 Pro inside, it works next to the router but won’t even stream in a bedroom across the hallway 16 feet away. I worked great watching the driveway for about 6 weeks until I upgraded today :frowning_face:
Can we get the old firmware available to download on the release notes page sometime soon??


Wyze will need to respond to that request. It sounds reasonable to me.


I extracted the files and this is what shows up on the card.

Try loading it as is. If it fails, try renaming to recovery_wcv3p.bin. If that fails, WyzeJasonJ is going to have to get the info for us.

I tried the firmware as shown on the downloaded file. The cam will work right next to the router but not 8 feet away inside the house. I have three V3 cams outside at 15 feet, 35 feet and 40 feet all working. The 4 WCO are at 8 feet, 35 feet,40, 45 feet and will all live stream?
Now I get this.

1 Like

Longshot and may sound silly, but try restarting your phone before giving up. Also try turning your VPN off.

Already started both the iPhone and iPad. VPN not turned on, on either device . Jameson time for me, enough for today, got my driveway V3 back in place scouting the :raccoon: :raccoon:

1 Like

V3 Pro works in the same room as the router. I’ll take it back out side later today and test it out again in the same location it was for the last 6 weeks and hope it connects again. :nerd_face:

1 Like

No sense of getting out the ladder. Froze again and will not load even in the same location from the video above 5 feet from the router ?

Perhaps you have a defective cam. Is this your only v3 Pro cam? If not try swapping cams/locations to see if the issue follows the cam.

My only V3 Pro which worked great until I updated the firmware. All the 7 other cameras I have work just fine, three V3 and 4 WCO version one.

Please submit a log and post Log ID here in this topic for visibility.

While viewing the live stream with Error code -67, either rotate your device to portrait orientation or tap the live stream space once and tap the orientation icon upper right corner. Tap Settings (gear icon upper right) > Wyze Support > Submit a Log > Connectivity Issues > briefly describe issue (e.g., unable to connect with cam 5’ from router), make sure “Send log files” is checked > Submit

Log # 852499 just submitted. I can’t deal with support chat right now, I have things to do and will contact them later.


Much appreciated! thumbsup2

The strangest part is if I tap it to live view the clock on the bottom right will show the correct hour and min but the clock does not keep changing time and the view is all blurred. It does record events though???
Maybe I’ll try a factory reset, nothing to lose.