Fix-It Friday 4/1/22

Good chance I’m older than you. Highly likely I will go to my grave before we see the feature that I shall not name.

1 Like

I am one of the victims of Wyze Sense Hub Despite several reports citing specific issues with that firmware, it sounds like Wyze is still having issues nailing down the issue and is asking for additional details, so I tried to really outline the specifics, with accompanying log submissions.

BLUF, ever since updating to this firmware, I have struggled to get new leak sensors to work with the hub. The sensors either refused to pair or … pair, but do not appear to function correctly. While putting this timeline together, I APPEAR to have gotten them to work through a specific sequence of events I’ll detail here.

As background, I have a Hub but do not have an active HMS subscription. I also do not have a keypad, just V1 contact sensors, V2 climate sensors, and V2 leak sensors.

Starting off, the Wyze Hub appears to be in a stable state. All 3 lights are solid. My objective is to pair (2) new leak sensors.

These events all took place today, on 4/2/2022, in the Eastern Time Zone (EST).

9:37am - Attempt to enter pairing mode from the app. The app shows ready to pair but the hub never announces pairing mode and the three lights remain solid. I attempt to pair both leak sensors by holding the reset button, neither pairs. I submit hub log #526455.

9:40am - I conduct a reset on the hub by disconnecting the AC power and holding down the reset button. The hub resets and then enters the strange “crackling state” which has been elsewhere described in this forum. This state appears to repeat the following pattern.

A. All 3 lights flash for approximately 20 seconds.
B. All 3 lights are solid and the hub is quiet for approximately 1 minute.
C. All 3 lights are solid but the hub’s speaker emits a “crackling” sound for 1 minute.
D. Return to A

9:50am - I attempt to enter pairing mode again via the app. I believe I attempted this during State C above. At this point, the hub announces it is in pairing mode. I try to pair both leak sensors and neither pair. I cancel pairing mode and submit hub log #526462.

9:54a - The hub remains in the same state as above, cycling from A-D. At this point, I wait for State B and again enter pairing mode. At this point, I am able to get one leak sensor to pair and submit hub log 526469 and leak sensor log 526465. I successfully repeat this process with the second leak sensor.

Shortly thereafter, I attempt to test both leak sensors and these tests are unsuccessful. At this point, the hub is still in the same state … cycling from A-D. Specifically, I dip the sensors in water; the red light on the sensor blinks signaling it has detected water, but the app never updates that a leak has occurred and I receive no notification that a leak was detected.

11:30am - At some point between ~10:00am and 11:30am, the hub has returned to a stable state, where it’s no longer cycling between A-D and all 3 lights are solid. I again test the leak sensors and both work; the app appropriately reports leak detected and I get notifications. Even though I didn’t need to pair any additional sensors at this point, I tried to enter pairing mode and the hub DID announce it was in pairing mode.

THIS IS DEFINITELY A PROBLEM THAT WYZE NEEDS TO INVESTIGATE (and they now have plenty of data/logs to look at), but if you’re having similar issues it appears this workaround may help:

  • Reset your hub
  • When pairing new devices, wait for the hub to enter state B above OR (maybe) just wait for the hub to return to a stable state.
  • Do not try to test your new devices until the hub has returned to a stable state.

My hub behaves exactly the same and I have also found that if you time it right you can get certain things to function like adding a sensor but you basically have to follow your exact steps.

The only problem is there is no way to tell when it will go back to doing the reboot cycle and it does happen. So just don’t rely on your system to much right now cause Iv seen mine report armed and appear fine on app but when I entered the home the alarm didn’t trigger and found the hub going through its rebooting cycle again and nothing was functioning. It eventually sorted itself out again and was working but it’s been repeating this cycle and going in and out at random intervals. Worse yet the app doesn’t report offline or anything like that and appears to function and arm/disarm. So just be aware that’s it’s still not reliable.

My biggest complaint is, not having the data to find a solution is no excuse for making us suffer and be stuck on this firmware with broken systems for this long. It’s made me realize that this system has a major design flaw since it doesn’t support firmware downgrading. If we could downgrade to the last firmware then our system would work perfectly fine and then wyze can do their own testing and get their own data instead of relying on us to do the work for them while the devices we paid for don’t even work.

I totally agree with you. I’m also frustrated by the excuse that they don’t have the data despite several reports on the forum citing this issue, which likely means many other users who don’t use this forum also have this problem.

At this point, though, Wyze and the forum moderators should not have the ability to make this excuse. As a result of my post (and other similar ones), they should have the logs and the repro steps necessary. If they still can’t identify the problem, that is very concerning re: the stability of this product, especially as a home monitoring device.

If it would actually help them diagnose the problem, I would be happy to send them my hub (assuming they first send me a new hub I can swap out and without needing to rebuild my sensor lists/rules).

you can take the sd card out of the camera and stick it in your computer and be able to do all this… it’s not ideal, especially for cameras in annoying to reach locations, but it does work.

1 Like

Cameras do support firmware downgrading and even manually firmware flashing to new version and they provide the files online. The sense hub which has these problems does not support it and wyze doesn’t even offer the firmware files online so this is not an option with this device. Which just sounds crazy to even say considering we’re talking about a simple camera having the ability to downgrade but a device that’s sole purpose is to protect your home and family cannot downgrade. Everybody knows updates can cause problems, even updates from major tech companies with loads of money, so having a way and a procedure to handle such issues is absolutely critical.

The fact that this was not a feature that was designed into the sense hub before release is major design and security flaw and speaks volumes to how much wyze actually values your home and families protection. It also says that they find it acceptable to randomly leave you without protection for your home/family for extended periods of time. Especially considering the cams they make they always said we’re not for security purposes and the cams support downgrading. However the device they make which is specifically made for security does not support it.

You shouldn’t even have to do that. They are a tech company. They should be able to setup a testing site. Setup a hub and some sensors and whatever else they need and do all the testing they need to do and log all their own data. They are legit just relying on us to do most of that leg work for them while they sit back and claim they can’t do anything for us until we do that for them. Didn’t realize I was on the payroll……WYZE!

1 Like

huh? i think you replied to the wrong person

Please issue a new firmware for the Wyze Plug (2021 version) that keep them from going offline so frequently.
Here are some threads over on the Wyze Power and Lighting Forum:


I actually now wonder (since it has been a month) if they haven’t broke their internal firmware. Perhaps they messed this up so bad they cannot get the Hub to load any new software. Otherwise, why wouldn’t they have just pulled the old version of software out of their GITHUB repository, change the version number, and then re-issue the new-old software so the problem would be fixed temporarily?
I am really surprised that no one has initiated a class action lawsuit over this Home Monitoring System from Wyze. As many have complained, this system has had bugs since it was released about a year ago and at times (like now) I have a system that is not securing my house as they promised when I purchased the system. I am not litigious, but just say’n.

What bugs were present when it first released? I was never aware of any and can’t find anything reported in the forums off hand.

I recall my system working basically flawlessly (bug free) for months using the original firmware, and don’t recall anyone complaining until at least July 1st when it had an issue with the V1 sensors locking up the hub. They fixed that and it was then basically flawless until the Septermber firmware that turned the hub volume to whisper mode. And the third issue was this March Firmware (which is ongoing).


You are correct and I stand corrected. I first bought the system when it was released in April but returned it because it was MISSING features like chimes and separate entry delays for door/window sensors that I was used to with my previous systems. But then I read that chimes were coming in an upcoming release so I repurchased in June - and then the problems started. From day one I had window and door sensors randomly showing up as offline in my notifications - and then they are magically back online. I suspect this was just an over-zealous reporting of signal loss between the hub and sensor, but try to explain that to the wife who is concerned about her safety. (never saw that with my Honeywell security system).
I consider the issue with my different camera’s showing up as Offline being an issue since day one. This is another one that I don’t understand - why do they randomly go “offline” and the only way to fix it is to go up on a ladder and unplug them? Maybe that is not technically with the HMS, but it is part of my security system and something I have to again keep making excuses for. That seems so simple to fix in software - they are not offline so why show me a cloud with a slash?? Oh well! Just another bug in what should be stable hardware/software.
Sorry for the rant!! :wink:

Something changed, @carverofchoice ? Last time I recall you were basically saying it wasn’t ready for prime time. I guess that was a ways back.

@TextMan thanks for the clarification, I understand what you mean now. :wink:

@Customer I was never happy with the risks that came from professional monitoring (using Noonlight and having law enforcement dispatched unless I explicitly said not to every time there is an alarm). I always wanted improvement toward self-monitoring (alert me and let me decide if I’m calling law enforcement or pressing the panic button…so active vs passive dispatching to reduce false alarm fee issues), but I wasn’t complaining about bugs (early on there was an Alexa trigger bug I advocated for though, but that got resolved) as much as I was begging for improved features. It worked pretty well as it was designed, I just wanted the design to be updated to be better. Here’s my original list of all the things I thought the HMS should consider improving since it launched. Almost all were feature requests, not bugs. So when I say it worked flawlessly at launch, I meant in the context of bug-free…the sensors triggered, everything was fast, great reception, very reliable and consistent and stable, that sort of thing. It needed more features to be highly competitive and prime time, including schedules (which it has now and I use every day), geofencing, rules, and many other things I listed in that link…there are still a lot of improvements that should still be made, but the only things worthy of Fix-it Friday (bugs not feature request wants) are 1) the ongoing low-volume bug and 2) the bugs introduced in the March Firmware (which I did not upgrade to and am not experiencing myself, but am still advocating for to be resolved) and have been reported in the previous fix-it-friday, but for which few people have answered all the questions for in Wyze’s response (the response of how to help them find what’s wrong went basically ignored by users as far as I can tell). I hope that clarifies. :slight_smile:


I would agree with the statement that HMS isn’t ready for prime time. The hub has been and remains unreliable. You may or may not be able to add new sensors. You may or may not be able to arm or disarm the system or get an accurate status of it. Motion sensors that trigger for no reason. Single PIN. Single locations/hubs. Single contact number. (I know, this one is under testing along with shared access.) Keypad may or may not arm/disarm the system. Low volume for the alarm feature (a hardware, incorrectable problem.) Inability to change the “Tunes” setting.

Forgot to mention no geofencing (for one or many) and no outdoor sensors.


This morning I reported in the Beta reporting system that I have noticed that the Home Monitoring “Tune Setting” menu item is gone. It must have something to do with the Chimes being off on the Hub so maybe it thinks that feature is unavailable. But when I look and it is there (I just reset the app, and now it is available as a menu item), I can turn “Entry Notice” back ON and the Chimes came back. How long it will stay is anyone’s guess. I’ve found that it randomly goes away 24-48 hours (in my experience).

I suspect someone (everyone?) has reported this already so it’s probably old news. But just in case they haven’t. (I tried going through the forums but there is a lot to go through!).

You are correct, there are known Tune setting issues. Wyze has reported there is a fix on the way for that.

(The rest of this is a general response for anyone having hub problems from the March x.213 firmware)

EDIT: I also stand corrected about the lack of response in the Fix it Friday thread, there were a couple of people who responded to Wyze’s questions in the fix it friday thread:

1aaronj did a thorough response here
motoxmat4 did a thorough response here
Mynus64 did a thorough response here
I don’t know how I missed or forgot about those before. My Appologies

And now mattbrav’s great answers to the request in this thread below (EDIT: And he has posted a very thorough, high quality response in that previous Fix-It-Friday thread now too)

Wyze has also asked people to respond to the following questions and post them in the previous Fix It Friday thread (they even made 2 attempts to get interaction on this), and I don’t recall seeing [many responses] from people answering any their questions as they requested:

And again a second attempt to get some response from users that also went [mostly] ignored in that thread as far as I saw:

So far as I have seen, [few people have] responded to either response from Wyze asking users to answer all those questions in that thread so they can try to figure out what’s wrong. That may be why not much has been done. Everyone says there are problems, and granted there have been plenty of logs submitted before these requests went out, but [few people] ever responded to either post from Wyze asking for help so they can fix it. I’ve continued to see people say the problem still exists, but [fewa are] responding to those posts or answering the questions Wyze has said they need help with to figure it out. I would encourage people to go through Wyze’s steps one by one and give a detailed description and answer about each step and question so they can gather the info they say they need. I’ve been tracking and making suggestions to people about it, but again, so far, [few people respond] in that thread answering the steps or questions like they asked along with a log at the end. Not one since they asked for more information. I’d highly recommend do as requested so they can resolve it.

Edit: I stand corrected, originally I said there was not a single response in that thread since Wyze posted their response and as I just reviewed the fix it friday thread again and noticed that there were 3 in that thread:

1aaronj did a thorough response here
motoxmat4 did a thorough response here
Mynus64 did a thorough response here

And now one more great response for Wyze to use in the following post (and in the original Fix-it-Friday thread). Thank you mattbrav for contributing.

My sincerest apologies for the previous oversight.


That is a ridiculous and incorrect statement. My response from 9 hours ago IN THIS SAME THREAD clearly answers those questions and goes much further to try and point out the issue to Wyze.

If you/they can’t parse my more detailed response for the answers, there’s a much bigger problem here.

That said, so you’ll stop stating that no one is providing Wyze answers to their questions, here are answers to their questions…

  • Confirm that the app reports network connection. YES
  • Are you able to arm/disarm using the keypad? Can you do it using the app? I DON’T HAVE A KEYPAD, AS STATED IN MY PREVIOUS REPLY.
  • Try holding the Reset button on the hub to reboot it ANSWERED IN MY PREVIOUS REPLY
  • If you’re having issues with your sensors, what is the message you see when they fail to pair? Is it failing 100% of the time or are you able to succeed sometimes? ANSWERED IN MY PREVIOUS REPLY
  • Please submit a Wyze Sense Hub log after trying to pair your sensor with the date, time, and time zone that it failed in. Afterward, please post the log number here! ANSWERED IN MY PREVIOUS REPLY
1 Like

Did you respond on the original thread where those questions were being posed? Not in this thread, but where wyze was asking a week or two ago? That’s what @carverofchoice was asking.