Wyze bulb setup

You can go onto the router and turn off 5 ghz, do your setup and turn it back on.

That would be nice, but it’s not an option thats available on google mesh.

As a WiFi device the Wyze Bulb will have a lot of the same general caveats as the Plug. That said, if you are having setup troubles, make sure none of these things are interfering:

To start, if you are on iOS 13, confirm that you are using the most recent version. Also, iOS 13 users should update to version 2.5.53 or above of the Wyze app using the Apple App Store. iOS 13 won’t allow the app to see your local networks if location services for the app are turned off. You can turn the location permission off again once the last device is set up (Settings > Wyze app).


  • Bulb can’t be on a dimmer circuit.

  • Bulbs must have access to a 2.4 GHz network.


  • Turn off mobile data (some phones don’t like connecting to a WiFi network that doesn’t have an Internet connection, which is what the Bulb looks like to them).

  • On Android, after connecting to the Wyze Bulb, wait 5-10 seconds to see if it warns you that the network has no Internet access, asking if you want to stay connected anyway. Tap Yes you want to remain connected, then proceed with the rest of the Wyze Bulb setup.


  • Turn any MAC filtering off during setup (you should know if you engaged this unusual item on your router.)

  • Sufficient range of DHCP network addresses must be available (some people restrict this).

  • Depending on your Bulb’s firmware version, if your network name (SSID) is 25 characters or over, you may have trouble setting up the Bulb. The workaround is to set up the Bulb on another network (like your Guest network), update the firmware, then set it up on your intended network. If using another network isn’t an option, then reducing your network name (SSID) long enough to set up and update the Bulb will be necessary.

  • If you have a PLUME WiFi mesh network and your Bulb times out repeatedly (you may also get a 404 error), then temporarily disable “Online Protection” and/or the “Advanced IoT Protection”, as they appear to block access to either Wyze or the Bulb. After the Bulb is activated you can re-enable protections.

  • If you have band steering on your router, know that some implementations won’t allow the Bulbs to connect to the 2.4 GHz network if the 5 GHz network is available. The solution is to turn off the broadcast of your 5 GHz network long enough to set up the Bulbs.

  • The original Bulb firmware couldn’t connect to 802.11n networks. If you are having trouble connecting to the Bulbs, allow 802.11b/g (“compatibility mode”) until you can update the firmware.


  • When the app asks you to input your network name and password, click the closed eye at the end of the password line to see the password you enter. Remember the password is case-sensitive.

  • Set up the Bulbs in a single socket lamp close to the router. Once all settings are in and the Bulbs are working, they can be moved to the desired location and all the settings will remain.


I forgot that, no back channel with Google mesh, the reason I ended up with Velop mesh…

John Taylor

Thank you so much! My problem was I had my network restricted to performance mode 802.11n and changing to compatibility mode allowing abg etc solved my setup problem. Instructions must be updated with this all these tips ftom the forum like this and mobile data.



The phrase “performance mode” triggered me to look at my Verizon FiOS router which had that set. Setting it to “compatibility mode” finally resolved this for me.


Yup! That was the solution for my Pixel 3.

Thanks! That worked on my Pixel 3


Thanks. Worked like a charm!

1 Like

Additional tips from WyzeMike:

So am I to understand that the bulbs can’t be set up with the Google Mesh routers? Cams don’t seem to have any trouble with the mesh. Any solution(s)?

I set mine up on google mesh. I just had to turn of the data so that when I logged on the bulbs wifi connection I selected continue when it said there was no internet connection. Then went back to the wyze app and waited until it logged on.

Thanks, I’ll give that a try.

Added this to my list in post 23:

  • (Assume this is mostly necessary if the bulb has old firmware): If the bulb flickers then stays on just after you enter the countdown, then the bulb is probably on its way to being set up. However, if the countdown reaches zero after you see that, then cancel the setup and go back to the home screen. If the bulb is listed there, try to upgrade its firmware. Whether the firmware updates successfully or not, flip the switch 3 times and go back into setup. Rinse & repeat until you go thru setup successfully & the firmware is updated successfully.
1 Like

i type n short shrt hand lol… If u are installn the bulbs its simple but can b confusing.MAKE SURE b4 hand u on a 2.4 network and turn off phone data!!!. do the on/off thing 3 times. find the wyze_…apxxx and click on it… ur phone or device may pop up with a box asking to stay connected to that wyze_… apxxx, click yes then the back button on ur phone or device so it can sync. if installing multiple bulbs, i suggest the following… Do the above, then update that 1 bulb with the fireware, name that bulb and then unscrew it out the socket!!! hopefully this post saves some1 a lot of time and confusion.

:wave: Hey there, I made a review on the Wyze Bulb which includes brief set up instructions on my YouTube Channel. I upload new content weekly and would appreciate the support. I tried to make it shorter than my last Wyze product review. Like and Subscribe if it’s what you are into. Hope you find this video helpful, Thank you and may your home be Wyze! :raised_hands:


Yes, could not connect until I turned off data, then it worked fine.

I have Google Wifi, too. Now, I live in a rural area, so this may be easier for you than it was for me. But I called tech support for my ISP—as they have no app or anything—and they switched me to 2.4 on their end. Once my modem was changed to where it only used that band, Google Wifi doesn’t have a choice but to use the 2.4. (Apologize if I used any wrong terminology. No formal education in that field.)

Check your router setting on the 2.4 and make sure that the 2.4 is not setting on only “N” … I had the problem with my Galaxy s9 plus doing the same thing but then I checked the router and it was set wrong … After I changed it … All of my bulbs are now connecting and working really great… Check your router :+1:

1 Like

I found solution for my new MESH set up…all I had to do was unplug the router downstairs and only have my main Router that’s plugged into my modem operating. Quickly did 2 bulbs and presto, all good. Took a while to figure out but it worked great. Now my outdoor Cam should be easy to get online also using same procedure.