Wyze Bulb: unable to finish pairing, Connection timed out

I don’t know why either. All I know is that my phone will not let me set up the bulbs but my wife’s can, no problem.

Pixel 2 tried fixes, uninstalled Beta reinstalled public, App now crashing

update I used old Nexus 7 tablet runs only 2 ghz setup went straight through, can access on pixel 2…!!!:footprints:

I also had the pairing problem – tried with two different bulbs. Clearly the issue is communication with a WiFi AP that has no internet service. On my Pixel 2, I was unable to find a setting to disable the automatic switchover from “bad WiFi” to cell data, so I had to switch off cell data.

I strongly recommend that Wyze PROMPTLY update the Android app to suggest that users turn off Cell Data prior to starting the pairing process.

1 Like

I have also had the same issue. Wyze products usually pair quickly and easily. Now I can not update my pan cam. Updated and restarted phone and app. Turned mobile data off. Only on 2G network and NOTHING. Can’t get any of these lights to pair. Kind of want my money back if this can’t be resolved.

1 Like

If you are having trouble with bulb setup, see if any of these suggestions help:


Or just fix the app so it works like just about any other IoT setup program. I’ve connected various sorts of devices to my local network and have never had these sorts of issues.

Hopefully the Wyze folks are working on an actual fix instead of some sort band-aid solution.

I too have 4 bulbs still in the box. I’ve been trying for 4 days. I have tired Pixel 3, wife’s iPhone, and my Chromebook. I have turned my router back to “legacy” shutting of N.

I get to the countdown part of adding a new bulb. It flashes and stuff. But then never finishes. And yes cellular data is off.

Dear Wyze, whats up?

Got at least further. Used a lamp right next to router and ot set up. However once I moved bulbs to kitchen they didnt reconnect to network. Have 2600 sq ft house but router is in a very central location and gets full signal anywhere in house. Was able to update bulbs but that’s about it.

Sweet!! I was having this problem at my home (using Google Wifi). I’ll try disabling my mobile data tonight. I really appreciate these notes on your experiences.

Same problem here on iPad. Connect to bulb’s local wifi and specify 2.4GHZ only network with router 6 feet away (previously tried on Google Wifi). Mobile data turned off. Continues to timeout. Tried 2 different bulbs. Pretty disappointing.

Everyone having trouble be sure you check off the items in post 58.

Thank you! Can’t wait to get back home and try again.

I hate to steal a thread so let me know if I should be creating a new topic… but I am still experiencing the connection timeouts after making all of the changes that were recommended (e.g. no mobile data, 2.4ghz b/g/n, no MAC filtering, etc.).

I am on an iPhone X with two separate Wifi networks for 2.4 ghz and 5 ghz. I am having this issue with all four bulbs.

Any other suggestions?

Did you set an IP address reservation range limit on your router?

Yes but it is assigned a a full /24 and has only used ~20 IPs.

@pivotforensics, The IP address reservation range (DHCP scope) is what caused my bulb setup issues (even though it appeared that I had not used all the addresses in my range). I increased the available addresses and was able to set up all my bulbs without issue.

1 Like


I have 4 bulbs I was trying to pair yesterday, nothing but connection timed out.

I have a iPhone and a Google Pixel 2 so I tried a couple different things but finally got it to work on my Pixel 2.

Turn off the LTE connection, so only WIFI is on. (and it was on 5ghz, so this works for Google WIFI users).

Pair your lights up with the LTE Connection off. It works just fine that way.

I’m not sure if the same will work via iPhone because I have iOS 13 beta and the WYZE app doesn’t work correctly, the UX is all messed up so I can’t finish the pairing via it.

Good luck!

1 Like

I cleared the known devices, renewed all DHCP leases and expanded the DHCP IP lease range to no avail. Also tried it with data off and Wifi only.

Update for those who have tried everything and have persistent issues:

I have a Linksys WRT3200AC router with DD-WRT firmware installed. Separate 2.4 ghz and 5 ghz wireless networks. I tried Mixed, B/G Mixed and N/G Mixed modes with no luck. The bulbs can “connect” to the 2.4 ghz network and but are not assigned IP addresses. I tried setting static IPs on a static range, not through DHCP static leasing, but that didn’t work either. No error logs available to explain why this might be happening. Still just getting connection timeouts when trying to add the bulbs, because the bulbs aren’t routable (of course). Worth mentioning that I have Wyze Sense and three Wyze v2 cams currently connected to the 2.4 ghz network on this router (what legacy protocol are the bulbs using?).

I set up an older Linksys router with the stock firmware and the bulbs connected just fine. This is not ideal of course since I now have an extra 2.4 ghz wireless network just for the Wyze bulbs, but it narrowed down my issue at least. So, long story short is… it looks like a configuration issue in my wireless settings or a compatibility issue with the router/firmware itself, but the rest of my DD-WRT wireless settings are set to the defaults so that would mean Wyze bulbs will likely not work out-of-the-box for anyone using DD-WRT firmware.

Side note: If anyone has a router with DD-WRT firmware and connected/working Wyze bulbs I am all-ears to any suggestions for re-configuring my 2.4 ghz wireless network as needed.


Thank you for sharing that, @pivotforensics. I’ll ping Wyze with this info. :slight_smile:

1 Like