Cannot connect wyze bulbs

I finally got them connected last night.


That’s great, glad to hear that. I hope you enjoy your bulbs as much as I enjoy mine. :slightly_smiling_face:

1 Like

Good to hear ya got em hooked up

I bought a four pack. After wasting a lot time yesterday, I finally got two of them to connect. This morning I tried to set up the other two. No go. And what makes this more frustrating, the two that were connected are no longer recognized by the Wyze app.

I give up. Asked for RMA. Wonder if I’ll get one. Support seems unwilling to acknowledge how bad this product is.

This is without a doubt the worst product that Wyze has released. Charging customers for this awful experience is unacceptable.


Sadly, I wish I would have paid closer attention to this forum before I purchased the Wyze bulbs. I am not gonna bash Wyze at all because I love their cameras and think their products are amazing. I own 4 cameras and the senses as well. So I could not wait to get my Wyze bulbs as well. After hours of frustration and reading through the forum and following the steps to the letter I cannot get any of the bulbs to connect. I purchases a pack of 4 and tried all four. At first I thought it was the light that I was trying to place the bulb in because its a can type light so I brought down a lamp and tried that as well and no go. I am stuck. I am no tech wizard and thought these would be similar in difficulty to setting up the cameras but that is not the case. So what do I do now? Do I wait for a update or a fix or try to get a refund? Not sure. Any thoughts?

1 Like

Did you do anything specific to get them to finally hook up or did you just keep trying the same steps over and over? If you did anything different then what the earlier posts suggest would you post if you get a chance. Thanks.

Did you try the possibilities in this post?

1 Like

Everything but the Router network settings. Thanks for the tip. Will try that this evening.

I also had the issue of the bulbs not connecting. I have 6 bulbs that I wanted in the ceiling within my kitchen. Would not connect no matter what I tried. I then took the advice of the above where you use a lamp close to the router. I was able to connect and upgrade the firmware on each bulb successfully. Note the procedure I used:
iPhone 10

  1. Turned off Cell Data in Settings.
  2. Opened Wyze app and selected to add a new bulb.
  3. Followed instruction in app to cycle the light 3 times. (it started to blink for pairing)
  4. Selected Next and added in wifi password.
  5. Selected Next and it showed me that I needed to connect to the bulb in my wifi settings. (I found this process is what worked next…)
  6. I went to my settings / wifi and selected the new bulb. (This was the trick in that order)
  7. It then started to pair. Took 15 seconds each time and connected successfully.
  8. Back to listing of items and selected the new bulb to trigger the firmware update and it did.

Now to place them in the sockets and test. Note that I labeled each bulb as in 1,2,3 to know what socket I would place them in and that I could control the bulbs individually or in a group.

That will be the next test…

Hope this helps.


I have all bulbs connected in a group and working as one.

Now to see how long they stay that way and if I have to reboot my router will they loose connections…

1 Like

I have 3 different bulb groups , I have restarted router many times they always come back online


It worked finally. Got all four bulbs hooked up and updated. They now work great, or at least have for the last two days. Thanks for all the help. I think the key was I shut off mobile data way before attempting to hook up this time and also did the connection right next to router with a lamp. Thanks wrkuchar


I have FING to monitor any new devices that are added. I also have it set to block any “new” devices. Unfortunately, I also have a tendency to forget I have this setup when I personally add new devices. My issue with the new pack of bulbs not connecting was directly my fault because I did not turn off the block feature in FING. Just sharing this in case there are others that have their security setup in a similar manner. Hey, it happens.

I am so glad I read the forums before spending any more time attempting to purchase the 4-pack of bulbs plus the free one. I have no patience for devices that make big promises and then fail to meet them. These would have been immediately returned. Except I never got the opportunity to order. The Checkout option is hung up, I could not complete my purchase. After reading these, I’m glad it did. No devices of any kind with Wyze on them for me. Seems as if this is a big-name company with half-crap products. Goodbye Wyze, grow up and then try again.

1 Like

These bulbs are hit/miss. 2 of them were instant setup, the other 2 , 1 sometimes works, the other never works. Mostly a cheap crap product. If you have nothing to do for hours you can play with settings, turn off this and that, etc. I also have a Hue bulb which works flawlessly. Wyze even says they will not refund or replace bulbs not bought from their store. That speaks volumes. So I ended up spending hours to connect a light bulb so i can tell alexa to turn it off/on without getting out of bed…
The more technology, the more things fail, and cost $$$$$ to repair. Waste of time and money. Trouble is that this crap is in TV/washing machines/microwaves, etc. The customer is screwed.

I too am not having any luck connecting my Wyze bulbs. Can someone at Wyze please give us the exact specs necessary for a wyze bulb to connect to the WiFi network? I gather from reading posts to this forum that the bulbs only work on 2.4GHz, not 5GHz. And someone suggested that 802.11n does not work. Is the bulb using 802.11b or 802.11g or both? What about WPA-PSK vs WPA2-PSK? Which one does the bulb support? What about encryption? Does the bulb support TKIP? or AES? And which ports on UDP and/or TCP are required to be open, if any?

When Wyze products just connect as they are being installed it is super simple. But if the product does not connect we’re all just left in the dark as to why. Troubleshooting information is sorely lacking!

to the Wyze bulb design team, especially anyone involved in the decision to be 2.4ghz only:
I want to gather all of the defective bulbs (most of them, if you really think about it) and your team, then hammer [MOD EDIT]. I cannot believe How much time I’ve wasted over 2 days trying to get the bulb to connect. The “connecting” page in the app is burnt onto my retinas. I hope you all go blind.

MOD NOTE: Post edited to conform to the Community Guidelines.

1 Like

Wow what a mess. Over an hour trying different networks, settings, etc just to connect this bulb. Such a bad interface with no help as to what might be wrong. Final issue turned out to be not having location services enabled for “always”. Why would this be required to add a light bulb? Never an issue with adding cameras or plugs in the past. So disappointing for a company that used to just do things right.

That’s an Apple thing. Because what networks you can see can reveal your location, they now require you to give location permission access to see networks, which you need to see the Bulb setup network. So not a Wyze thing…

1 Like

Agree the actual connection with the wifi network is an Apple thing. However, the app is useless to help debug the issue. It just doesn’t advance to the next screen. No error that it can’t see the network you entered in the previous screen. No error that it can’t connect. No hint on what to do to see the wifi network. Nothing. Could be so much better with just a simple message.

1 Like