Still can't connect to the bulbs

I’ve tried everything, read all the posts, turned off all the things I’m supposed to. Everytime I get to the point where it’s in the countdown to connect, about 10 seconds in my phone switches back to my home internet. Then the countdown continues down to 0 and fails. Wyze… Any ideas? I’m using a Pixel 3 with Xfinity internet.


If you are having trouble with bulb setup, see if any of these suggestions help:


See the following thread for bulb setup as well:

I am having trouble with one of the bulbs, the other three work great. I was successful connecting the bulb in question once after much persistence, but this caused one of my other bulbs to go offline. I paired the one that went offline, and everything was working for a few hours when again the bulb in question went offline. I have not been able to pair it again. I haven attempted putting my phone into airplane mode with WiFi as my only network but was not successful. Any suggestions? Could it be a bad bulb?

Setup each bulb one at a time in a lamp. After you finish that bulb, turn off the lamp and remove the bulb. Then setup your next bulb. After you finish setting up all your bulbs, you can use them anywhere you like.

I’m sorry you’re having problems! We are hearing some Android users are having similar problems so try these steps:

  1. Make sure you are entering the correct password for your 2.4GHz WiFi network. You can click the eye icon to reveal the password and confirm there isn’t a typo. Wyze Bulbs do not work with 5GHz networks.
  2. Prior to setting up Wyze Bulb turn your cellular data off. Because the Wyze Bulb’s WiFi network doesn’t have internet access some phones may automatically reconnect to your cell data. This will prevent setup.
  3. When connecting to the Wyze Bulb’s WiFi network some Android versions will send an alert saying the network doesn’t have access to the Internet. Click on this notification and opt to stay connected to the Bulb’s network. Then return to the Wyze app. If you continue to have trouble or do not see this pop-up, forget the Wyze Bulb’s WiFi network and try again.

Thank you for your reply. After pairing one bulb at a time as suggested and keeping the disconnected bulbs to the side I have still only been successful in keeping 3 of the 4 bulbs to stay paired. The fourth connects for a little bit but drops off. I notice it is not related to one bulb, it jumps around. Restarting the router connected once but eventually one of them disconnected.

So I did more digging and noticed that the bulbs are getting the same IP addresses leased to them. Two bulbs get and two are getting I went ahead and created address reservations on my router using the bulbs MAC address and seems to be working so far. Weird thing is that even after restarting the router the Wyze app shows and as the bulbs IP address even though the router shows the bulbs using the reserved addresses.

1 Like

@WyzeMike - that is above and beyond what Wyze should expect the average “Harriet Homeowner” to do. The bulbs should be plug - connect to WiFi - and work or play.


Since you know your way around a router, you’ve probably already looked at this but, make sure there’s no limits set on the number of DHCP allocations or the number of WiFi connections allowed.

If the router has Airtime Fairness is turned on, it can also cause problems with smart devices.

I do have a limit of 99 IP addresses that the DHCP server can lease. I only have about 26 devices on my network which should not cause the issues I have been experiencing. Also, everything has been working perfect since I created reservations on my router using the bulb MAC address. Lastly, after several restarts of my router the Wyze app still shows the incorrect IP addresses for the light bulbs. It is still showing for two and for the other two.

Hey guys, I had the same issue, but I think I figured it out. And I’m pretty sure it is an App bug.

When on the page for setting the 2.4ghz password, click the “eyeball” to “show password”. Then click next. This worked 100% of the time for me, after spending 45 minutes setting up the first bulb.

After this I tested multiple scenarios on 3 more bulbs and in every case selecting the “show password” button made it work

One lat note: When using Android, it’ll earn you if you connect to a network with not internet. Make sure you click the pop-up and select “Stay connected” or sometimes it’ll block the connection, assuming it to be unsafe.


Not sure if you figured this out already, but android/pixel has an option in the WIFI settings near the bottom under “Wi-Fi preferences”. By default “Turn on Wi-Fi automatically” is turned on, you’ll want to either turn that off, or “forget” your wifi connection so it doesnt re-connect before your bulbs finish setting up

I show im connected to a 2.4Ghz network but I still cannot connect the bulbs to my wifi. These should be easier to connect. I’ve requested to return them. Very frustrated.

1 Like

I have tried everything and I just can’t get my phone to recognize the network for the bulb. When I try to use the wifi network for the bulb it asks for a password and I don’t have one specific to that. I only have my regular network password. Im thinking these just don’t work. I’ve requested to return them.

1 Like

That’s what it’s asking you for , is your network password


Why doesn’t it work on 5G? Are you saying that if my router automatically allocates from 2.4 to 5G I can’t use these bulbs? Would have been nice to know that before I bought them.

How do we restrict our WiFi to only broadcast at 2.4 just for these bulbs?

I don’t have a dual-band router. Mine is 2.4GHz network. We have plenty of others on the forum that can help you with this issue. They have more knowledge about the 2.4GHz/5GHz networks than I do. Maybe @Bam can chime in and help or @Loki.