Wyze Bulb: unable to finish pairing, Connection timed out

I have gotten my Wyze Bulbs in the mail today and I am not able to complete the setup. It gets stuck on the finishing setup step. I have followed all the steps in the app, as well as power cycled my android phone, the blubs, as well and the router. The only thing about my setup is I am running the Beta app for android, v2.4.82.
I have uninstalled the app and re-installed. Cleared the cache. Made sure the my 2.4Ghz network was the only one used by my phone,

If you need any further information, let me know.


I got mine today too. The 2 android phones I have here can connect to the bulbs wifi, but the app never establishes a connection. Will wait to see if there are any updates

1 Like

Same boat here. My router (Google WiFi) broadcasts both 2.4 and 5 frequencies on the same SSID. I don’t have a way to turn off the 5 or select 2.4.


Interesting enough I have the Google WiFi router too.

1 Like

I was having the same issue as well. After a lot of experimentation I found that the issue was that pairing wouldn’t work when I had mobile data enabled on my phone. As soon as I disabled mobile data before starting the pairing process, all pairing was successful.

As an FYI, from my experimentation this is what I learned:

  • WPA key length does not matter (I tried several lengths and nothing changed)
  • Having an SSID that uses both 2.4GHz and 5GHz does not matter (I tried disabling 5GHz and nothing changed)
  • Having the SSID broadcast or not does not matter (I tried both with broadcast enabled as well as disabled and nothing changed)
  • If the phone is connected to 5GHz during the pairing, it doesn’t matter, as long as 2.4 GHz is available (I tried pairing with the phone on 5GHz but the bulbs connecting to 2.4GHz and nothing changed)
  • As soon as I disabled mobile data on my phone, pairing always worked regardless of any of the above settings

I do not have Google Wifi but based my experimentation it wouldn’t appear to matter. I do have an Android phone. Not sure if these results are specific to my config. Perhaps a Wyzer (no idea if that’s what Wyze folks are called :slight_smile: ) can comment. It seems like this should be able to be worked around in the setup or at least have the app check for this setting directly or indirectly.

Hope this helps!


That worked like a charm! Thanks!


I tried turning off mobile data and ran setup again with no luck. I checked my router and the bulb connects to the router but does not get an IP address from the DHCP server.
I am going to try a few more things.

EDIT: I had to turn off all wireless encryption and retry a few times, but got a connection. I was able to get to the firmware update section of the setup for the bulbs. After the update I will try again.

Turning off mobile data worked for me too. Thanks!


If your router allows you to have different SSIDs for the 2.4 and the 5 GHz bands, try that.

I tried turning off mobile data, setting up a new ssid on a limited 2.4 frequency, and everything else I could think of without success.

The bulb moves from pulsing to full intensity within 5 seconds of staring the count down. Based upon the WiFi icon on the phone, it looks like that is when my iPhone is dropping the bulb WiFi in favor of my home network. Unfortunately it never completes the pairing.


A lot of wifi connected thermostats have the same problem. Enough that they now tell you to disable mobile data before starting right in the instructions.


The issue is that your phone is connecting to a WiFi network that doesn’t have an internet connection. So, instead of your phone just sitting there offline, it aromatically switches back to mobile data. Which is great for most situations and people.

On my Pixel 3 (Android P) phone I get a pop-up asking if it should to stay connected to the “dead” WiFi network. As soon as I hit yes, the app was able to finish setup.


That is a great explanation, @mattrk! Thank you for sharing that info. That makes total sense. :slight_smile:

I had the same problem, and found this forum. I disabled mobile data on my Pixel 3, and that did the trick. I was able to get everything set up.

Relatively easy if you know this workaround, but I’m surprised that Wyze didn’t include more comprehensive instructions. Surely they should have caught this in testing.

didnt work for me

It connects to bulb for me but returning to the Wyze app does not continue setup. Please help


Tried to pair in my s9 and wife’s 10xr with no luck so far. Would like to see a fix from a wyze person. Also new color bulbs like Phillips hue :smiley:

1 Like

Have you tried disabling mobile data in the phones yet? @mattrk had a great explanation why this may be necessary on some phones.

Ya tried on both and also now on my old s7.

I’m going to state the obvious, well…because I have to. :stuck_out_tongue:

Are you trying to set it up on a 2.4GHz network?

1 Like