Robot Vacuum Motor Doesn't Start

Tried starting robot vacuum but motor never spins or even attempts to. Completely silent. After about 30-60 seconds it says the lidar is blocked.

I don’t think it’s the lidar being blocked; I have had that message before but the unit still starts up the motor.

Voice says she’s starting, but no motor, no spinning and no noise at all. Completely silent. Then the “lidar blocked” message.

I’ve already cleaned the unit, checked the lidar belt and reset back to factory settings. Anything else I can try? Does the motor die on these things?

You’re not the only one. How old is it and how often do you run it?

Since you checked the lidar belt, did you check the motor connections while you were at it?

I did not check the motor connections - are there instructions for that?

I don’t run it often but it’s probably old; I think I bought the first round of them when they came out.

Thanks for the reply!

1 Like

I guess you didn’t actually open it to check the lidar “belt”, but the lidar does spin?

Might want to use compressed air to blow out the holes in lidar tower just in case. Mine started acting up even though there was no visible blockage, blowing it out took care of the issue.

I agree that the vacuum motor should still start even if it’s a bit dirty, but not sure what happens if it was not spinning at all or if it wasn’t getting a proper signal from the lidar unit itself.

If you have a camera with nightvision (e.g. Wyze cam), you can check that the lidar is casting its beam.

Since it’s past warranty, it might be worth taking it apart to look inside. But first it might be worth disconnecting the battery for 30 seconds (go longer to be safe) to see if a full hardware restart helps. It probably doesn’t matter, but I would turn it off first.

Here’s a recent opening:

I’ve seen at least a couple (Wyze) tear-downs on youtube.

Using the below keywords on aliExpress, there are lots of available parts. And Amazon at much inflated prices. I don’t know of anyone who’s replaced their motor.

“STYTJ02YM motor”. Note there are a couple very similar looking models, see below…


  • Mijia STYJ02YM (viomi-v7)
  • Mijia STYTJ02YM (viomi-v8) also known as the Xiaomi Mi Robot Vacuum-Mop P or Viomi V3 (non-Max)
  • Wyze appears to be based on the STYTJ02YM.

A couple more age related questions…

Look at your cleaning history, how much runtime? I’m at 10,640 min, I know others with a lot more. Mine runs about twice a week (two floors).

I use medium speed most of the time. What speed do you have yours set?

Less than 7k minutes. I didn’t know there were speeds but it looks like I was on the quietest setting.

I did disassemble and make sure the belt was on the lidar… I assume the motor is somewhere else? I’ll check out your previous post on parts.

But nothing spins or moves on its own… The lady voice says she’s starting, or going back home, but there’s never any noise of any kind after that. No suction, no lidar spin, nada.

I’ve sprayed the lidar with air and verified it spins fine on the belt (by hand).

When you said motor I thought you were talking about the vacuum part specifically. Yeah, need to see why the lidar is not spinning, I’d try the battery thing first, then check the connections.

Mine is currently inaccessible because reasons, but I definitely need to do some testing to see what the exact order of operations are.

I couldn’t get to the motor under the big plastic shield, even with all the screws out it wouldn’t pop off. Was hoping for a tear down vid; looks like there might be a few online. Battery connections should be solid, just because the voice activates and lights flash; although I need to chase the ones back to the motor too. LIDAR connections were all in solid, though I didn’t use my volt meter to test.

You want to disconnect the battery for 30 seconds to do a full hardware restart. There could be a stuck electronic charge (among other things) somewhere messing things up.

Left the battery unplugged for about 5 minutes, no difference. She talks, but no other sounds or movement come from her … Might need to try the tear down and test the motor.

1 Like

I haven’t been able to do a test run since my tear down, but I will clean the LiDAR sensor with air, the belt was still ok and it does spin.

Holy Crap mine has a lot of hours, but it was cleaning 4 days a week for two+ years.

1 Like

Cleaned the LiDAR sensors, is this what they all look like? Brass looking barrel on the left and what looks like a clear LED bulb on the right?

Tried a quick mapping, when it was completed the robot stated “returning to charge”. It had a hell of a time navigating back to the charger, the map looked good but it just got lost in front of the charger and the new map just disappeared. This is quite depressing as we have had the Robot for almost three years with no issues. I went back and checked the logs. It was running everyday until May 30, 2023 and then there was about two weeks in the timeline that it didn’t clean. From there it appears it has only been when I tried to get it to clean on the weekends, but there was no more than 9 sqft cleaned at any one time. I am hoping Wyze revises the firmware and or give use the option to rollback as this wasn’t happening before June 1.

Yes. The brass part would be the laser, the other detects the bounced pulses.

It can manage to un-dock and quick map, but no longer able to navigate properly.

Check the charger, there is an IR source between the charging bars, point a camera straight at it, should see it.


Try moving the docking station to a completely different place if you haven’t tried that already. Guessing that won’t help if it was being dopey all the way to the current one.

Might be waiting for what comes after 202.

1 Like

If it was able to successfully map your house the LiDAR is probably fine. Like purchark said it may be the IR on the base. I would try wiping down the front area of the base station and the front of the vacuum.

1 Like

Went ahead and did a teardown… I tried to start it up while disassembled, and it started moving backwards VERY slowly upon powering it up. But when I try a full clean, no movement, no sound (except the lady saying she’s starting) and then LIDAR blocked error.

1 Like

I might have time tomorrow to check some things on mine.

Probably is the LIDAR like it says. Should be easy to check the LIDAR motor. Unplug it and check with an ohm-meter. If you have a variable power supply, you can see if it spins, guessing 3V might be safe under no load. Set a low current limit if you can. Or a couple AA’s in series.

Start-up sequence

  1. “Starting cleaning”
  2. LIDAR spin
  3. Side brush spin
  4. Both wheels forward for a bit
  5. Rotate - room scan.
  6. Stop - facing forward
  7. Turn a bit to go off in another direction to do a second stage room scan. (if needed)
  8. Vacuum start

Docking sequence

  1. Gets in front of the docking station, faces towards it.
  2. Moves forward with side-to-side movement to line-up between the two IR emitters on the docking station.
  3. Slows down and goes straight until almost touching.
  4. Rotates 180.
  5. Goes backward slow until contact is made.
  6. Re-try if needed.

Immobile (lifted)

It tries to move the wheels in different directions and speeds. I stopped it after a minute or so since it didn’t want to give up so easily. This method can be used to inspect the wheel motor function.


(used two of these gave the height needed to keep the wheels off the ground and still satisfied the drop sensors. Height: 1-7/16" minus carpet deflection)

Other observations

  • “Front bumper blocked or soiled” (something along those lines) – First time hearing that, not sure what caused it.
  • All 4 drop sensors must be covered to defeat detection of lifted-off-the-ground, not just the side-most ones.
  • It does appear to have some kind of tilt/angle sensor, with all 4 drop sensors blocked, it can still detect that it is not level or upside-down!
  • “Please check that my wheels are touching the ground” message is triggered by the drop sensors. (Added 2023-11-04)
  • “Please move me to a level surface” message is triggered by the internal tilt/angle sensor. (Added 2023-11-04)
  • If the robot is off the ground AND at a steep angle, the drop sensor triggered message takes priority. (Added 2023-11-04)
1 Like

Thanks for the write-up! I get continuity through the lidar motor when using a multimeter. I wasn’t able to start the lidar with an external power source; I was clamping onto the motor terminals directly but I was only able to feed it 1.5v.

I have a second wyze robot (that does work) that I could potentially swap out lidar and see if the broken one starts. Or potentially brick both :joy:

I’ll probably try that today. Why not…

1 Like

Decided to check mine out a bit…

Some have a USB connector here also, so it’s just the one under the battery.

LIDAR motor

Appears to be a minimum 6v motor, would have been my next guess. While I imagine the circuit is protected from back-feeding, I would still unplug it, but I do see they made that difficult by gluing it.

In-circuit I got ~8ohm. You also need to slowly turn it a bit at a time, it always settled at ~8ohm.

Starting vacuum I read 4.4V (belt attached) at the motor. I could see what it does without a belt, but rather not touch that at this time. So I’m probably right that 3V could run it without a load.

Cool design. Some kind of coil to feed power (no-contact) and a photo-diode to receive the pulses/data from the head. Also another place debris could get in and cause issues as it’s only somewhat sealed.

You can find replacements online, so swapping LIDAR heads would probably be okay.