Robot Vacuum Not Charging

@b25pilot – I can’t see your videos, and I am on a Mac – although an older version.

So I am in the blind. I do know of an old issue where the vacuum had problems if the charger was on a soft or uneven surface, tho. So, if your vacuum charger is on carpet, move that to a solid surface like tile. If that helps, then Wyze does now sell a more solid pad to go on carpets for $5:

1 Like

@Newshound – the floor is tile. The first video, on the charger, it was trying to rotate in-place. In the second video the vacuum is going in circles and hitting a chair leg.

Check that both wheels are working properly. Assuming no debris, slowly turn each wheel by hand, does the rotation feel similar between them?

@b25pilot What’s the firmware version?

If the floor is tile, it is not what I mentioned. So that is there for previous issues.

I have no experience on the current version, as I have not been invited to join it. I am on 1.6.192, which isn’t even listed on the release notes page, lol. That is at least a year ago.

No invite to go higher.

Just communicating an old issue and solution, which you do not appear to have.

1 Like

1 Like

When did you get 202?

November 2020, I decided to fully disassemble, cleaned the interior, checked all the wiring connections. After assembly, still doing the same, after a few attempts I got it to stay on the charger.

Anyone have an idea of the issue?

How long was it running 1.6.202 before having the issue?

Not sure about when I did firmware update but it has been about a month having issues. Today it lost the map,

Is there a way to downgrade firmware?

Not officially. Otherwise, I do not know of anyone successfully replacing the firmware on a Wyze Robot Vacuum. Most recently I saw a method for un-bricking that involves copying the firmware from a working unit onto the broken unit. Sounds like the ability to do that has been patched-out in more recent firmware.

Have you tried cleaning the LIDAR sensor? Use canned air to blow out the little hole on the side of the sensor

1 Like

I think it will clear the map and start over after something like 3 failed dock attempts.

I don’t think it immediately overwrites the saved map though?

@b25pilot Open the multi-floor sidebar and check, if you have an additional floor, switching between them will force a reload. Normally need to do a full run and successful dock before it writes out the map.

Just showed-up on the “bricked” thread, but mentions “not going rogue anymore” with 1.6.202.


Tried running manually, no luck see photo #1

Photo #2 is what it used to look like.

Hoping WYZE has a firmware fix coming.

I’m trying to identify what it might be doing…

I tried placing an object to block the LIDAR on top of the robot. It just caused it to bump into things more, but otherwise it continued doing the perimeter sweep like normal. The LIDAR has to compensate for those cover standoffs after-all.

Response to LIDAR obstructions (around robot perimeter)

Response to bumping

Response to random bumping (including after perimeter sweep)

  • Upper-left: Used bumping to keep out of an area
  • Lower-left: Used LIDAR obstruction to keep out of an area.

It would be useful to see a video of it happening.

Tried again today to use the vacuum it just seems to wander.

Tried sending robot home, it just wanders and the charging station no longer shows in the map. I cleaned the IR sensors, is there a way to check if they are emitting? iPhone 13 camera filters IR light.

I don’t think filters are 100% blocking when it’s straight-on. At least that’s the case with mine. You can also use a security camera’s night vision with its IR turned-off.

It recognizes that room so the LIDAR appears to be working. I wonder if there was a change in the interpretation of the bump or fall sensors. You could try taping foil over the 4 fall sensors.

The charging station disappearing is odd. I’m still leaning on broken firmware rather than a hardware issue.

Bump sensors are a type of light gap detector…

1 Like