Flashing your WyzeCam v2 firmware

Here is the instruction: (different from v1 firmware)

  1. Download a specific version of firmware, unzip it, put it on root directory of your SD card and rename it to ‘demo.bin’ (Starting from, you don’t need the ‘rename’ step. We change the name to demo.bin directly)
  2. Power off your camera, insert your SD card
  3. Hold the setup button, plug in your USB cable, keep holding the setup button for 3-6 seconds
  4. Once the light is solid blue, release the button and wait for 3-4 minutes. The camera will reboot and change light status during this time.
  5. After it is done, your camera should be functioning with original setup. No need to re-setup your camera!

Other related topics:

Flashing Wyze Cam v1 – https://www.wyzecam.com/forums/topic/flashing-your-wyzecam-v1-firmware/
Flashing Wyze Cam Pan – https://www.wyzecam.com/forums/topic/flashing-your-wyzecam-pan-firmware/





Thank you!

I down loaded the firmware. I did the setup and I did it 3 times. Each time it said “could not find the network named”. I know that I did it right. Could you send me a prepaid label and I will return it and get my money back, including the postage that I paid. Ron Gutman

Hi, sorry for the issue. If you hear ‘cannot find the specified network’, the camera can’t find the wifi network. It is usually because of two possibilities:

  1. The SSID you entered is not an exact match. The SSID field is case sensitive. Also, please make sure you remove the trailing space. Some phones have auto-complete feature with a trailing space which could cause trouble.
  2. If the SSID is an exact match but is a 5GHz network, we will prompt 'cannot find the specified network' as well. Unfortunately we don't support 5GHz network for now.
If neither suggestion works, please send an email to support@wyzecam.com with your order # for any replacement/return request.


1 Like

BTW, can you tell me why you had to flash your v2 manually? I would not recommend manual firmware flash unless your device can’t be connected at all (including after factory reset - pushing the setup button for about 5 seconds for v2). There is more risk with manual flash. App upgrade is recommended. Thanks!


Just received my WyzeCam’s and setup my first one today. Mine shipped with the firmware. I updated the firmware, however the “whats new” link takes me to a changelog and I did not see the v4 firmware in the list (I did not look at it extensively on my phone) It appeared to be sorted by date. Is there a better location to see what has changed from version to version?


Thanks for reminding us! We forgot to update for v2 firmware. The release note will be posted on the link you saw today or tomorrow.

My V2 will not start set up right out of the box - solid yellow goes to flashing yellow, I hold the set up button, but do not get a voice prompt at all. I figured I would try a manual firmware set up - had to do it on my V1 when it disconnected during a firmware update and would not reconnect - but that’s not working. Just keep getting solid yellow, then flashing yellow - and not able to start the set up.

Sorry about that! We will for sure replace it. Please send an email to support@wyzecam.com to replace it. Before that, if you can try following two that would be great.

  1. If you have a different power cord, can you try with that cord? It may be the cord not providing stable power
  2. When it is flashing yellow, it may still scan even you didn't hear the voice prompt. You can give it a try and see if it scans. If you can scan it could be speaker related.
1 Like

Thanks for replying. Funny thing happen - instead of pressing and holding the set up button, I double pressed and held - and was able to go through set up and connect. The camera seems to be working fine - so we will keep it for now and see how it goes. Not sure what happened - but it works now.

Thank you.

Haha, glad to know it is working now. :slight_smile:

I bought a couple Xiaofang from China and found out they are region locked. Can this firmware be used to flash them into WyzeCam?

Seems I was able to flash my Xiaofang to WyzeCam v2 firmware - I got English prompts now. However the setup would stuck at flashing blue light stage after scanning the QR code. So at least the code runs.

I did this and the cam still does not connect. I have had enough!

Either give me a refund or send me a cam that will for sure work.


Sorry for the poor experience! We don’t have enough info so we can’t diagnose what happened. Please contact support@wyzecam.com for diagnostic, refund or replacement. Thanks!

Jumping on here. My camera went green image on me, so I thought I would try to revert back to .42 to see if it fixed. However, I can’t get the camera to go in to step 4, where the blue light comes on.

I have the file on a formatted SD card, changed the name of the file, but it always comes up with the “ready to connect” voice. The light never turns blue.

Any thoughts?

Yep, mine has never connected nor given any kind of voice prompt, just some clicking noises. I tried doing the firmware flash but it never went into the mode where there is a blue light, just a flashing yellow one. Mines a v2 cam and I’m still waiting on a ticket resolution - likely a replacement since this WyseCam is too little to make a good paperweight.

1 Like

Please press & hold the setup button ‘before’ you plug in the power cord. Keep holding the button for another 3-4 seconds after you plug in the power cord. In that sequence you should not hear ‘Ready to connect’ and should be the light becoming blue after 3-4 seconds.

Flashing yellow means it is ready to connect. If you push the setup button you should hear the ‘Ready to connect’ voice prompt. In a very rare case you may not hear the prompt. Then you have to flash the firmware. Please press & hold the setup button ‘before’ you plug in the power cord. That is the key to flash successfully. Thanks!

Once again, I follow those steps to the letter and it won’t flash. I never ever get the blue light, and the cam makes no voice sounds, only some intermittent clicking.

1 Like