Flashing your WyzeCam Pan firmware

Hi, here is the instruction to flash your Wyze Cam Pan firmware. It is pretty much the same steps as flashing v2 firmware(different from v1 firmware).

  1. Download a specific version of firmware, unzip it, put it on root directory of your SD card and rename it to ‘demo.bin’
  2. Power off your camera, insert your SD card
  3. Hold the setup button, plug in your USB cable, keep holding the setup button for 3-6 seconds
  4. Once the light is solid blue, release the button and wait for 3-4 minutes. The camera will reboot and change light status during this time.
  5. After it is done, your camera should be functioning with original setup. No need to re-setup your camera!

Other related topics:

Flashing Wyze Cam v1 – https://www.wyzecam.com/forums/topic/flashing-your-wyzecam-v1-firmware/
Flashing Wyze Cam v2 – https://www.wyzecam.com/forums/topic/flashing-your-wyzecam-v2-firmware/

demo_4.10.0.222.zip (9.64 MB)

demo_4.10.0.223.zip (9.59 MB)

demo_4.10.1.8.zip (9.8 MB)

demo_4.10.1.28.zip (9.81 MB)

demo_4.10.1.27.zip (9.82 MB)





Andrew Blatt,

This is Chuck Duke and I talked to you yesterday about my Wyze Cam Pan camera losing power after being on for a while. I tried several times to flash the firmware in the way that you listed. I had on success with the process. After the third attempt I couldn’t even get the blue light to come on and my sd card became corrupted. I did not want to take the chance with another card, so I was hoping that you would allow me to return it for a replacement.

Thank you for your help support Ticket #68333

Chuck Duke

But I have Firmware Version what is the or Do I go back to I don’t know which version I had… and I’m not sure how to down load to a card on a card and then put it in the phone… do I put the card in my computer??? I’m not to techie with this kind of stuff.

I was in your position a while back. Let meet briefly outline what I did to get started.

  1. The very first thing is that your must have a method of loading the firmware that you download from this site on to a SD card.
  2. I have a iMac, so I did a search on Amazon and purchased and inexpensive SD reader / writer that would hook up to a USB port.
  3. I downloaded one of the demo files from the above list. To be honest, like you I didn't know which one was the "best," so I picked the one with the "highest" .xxx number.
  4. After that, I meticulously followed the instructions listed in the post and successfully flashed the camera memory.
  5. Subsequently, I used the app to check for any firmware upgrade (which there was) and let it get the latest and then let the app upgrade the ROM.
That all worked for me. It may seem like an intimidating process but there are plenty of people here that will help you through the steps; patience is key. Also, the SD reader / writer will come in handy for reviewing and editing of the continuously recorded video from your cameras, so it is not a one-time use type of device.
1 Like

I downloaded the demo_4.10.1.28.zip file to my desktop and I unizipped the file to my desktop. I saved the already named ‘demo bin’ file to my SD card. I followed your directions above, it went through the update but I still have the Firmware Version on my camera… and the camera is not working for me. Everyone else that I’ve shared with can see the camera and it works fine for them… What the H*** am I doing wrong???

As I read your last post:

  1. You have flashed the ROM following the instructions.
  2. Other users you are sharing the camera video with can see the camera and it works for them.
  3. You, on the other hand, continue to show in the device data the 1.27 firmware and the camera doesn't work for you.
My best assessment at the moment is that your App is somehow corrupted and not working properly for you. I would suggest that you delete the Wyze App and re-download. Give that a shot. If you are using Flight Test to get the app - after you delete the app in the normal iOS manner, Flight Test will DL it again. Install it as you did originally with Flight Test.

Give that a try and let us know how it worked.

I am using a HTC 10 android phone and downloaded the app from the google app store. I have deleted the app multiple time and reinstalled and still cannot view camera properly…

I have no idea what Flight Test is…

Sorry - my bad. I misunderstood that you were working with the Wyze app on the Apple iOS. Still, the indications are that the problem is with the app, that is because the camera is being shared and seen properly by others; unfortunately, just not you.

I am out of credible recommendations for you to try. I hope one of the Moderators here will answer up with ideas that might be more suitable to the Android version of the app.

This is weird but I went into the Wyze app itself and turned on the hardware decoder… and IT WORKS NOW… Never had it on before but now it has to be to enable it to work… How weird is that???

Yesterday I received the Wyze cam pan. I am in the Netherlands. When installing the wyze cam it was connecting fine, until there came the firmware update. It freezed right away en did nothing. The I deleted the cam in the app en now there is no way to connected to the cam. I tried android, Iphone, firmware update ( I got no idea which one I should pick???), but still nothing. I very disappointed. I ordered the cam pan by ebay, because it couldnt be deliverd in Holland, so I was very enthusiastic… for about 5 min!!!

What to do now??? I still have blue/amber light blinking en it making me crazy with its spinning all day!!

How is it possible that there is now way I can connect it again???

1 Like

Hi, flashing amber/blue usually means the camera can’t connect to your router/internet. If you setup again, can you hear “ready to connect”? What happens when you enter the Wifi name and password there? Please make sure both of them are case-sensitive. After that please watch the light status on the back and what the voice prompt is. We have different status and different prompts based on errors.

Hey, thanks for your response…

You asked me :If you setup again, can you hear “ready to connect”?

Yes I do

What happens when you enter the Wifi name and password there?

Then the app/ca,=m is trying to make a connection but everytime it fails. I even tried to use the guest wifi and changed the wifi name and password, still no luck.

When its trying to make an connection, the light is blue/orange blinking, sometime is blue for a couple of seconds and then again it starts blinking blue/orange.

Iḿ really out of options. The problem is tha I live in Holland and returning the cam isn tha simple.

I also made a log file, but it doesn make any sense to me


log_A4DA22310E89_20161011020726_s.txt (1.13 MB)

Which version is the newest?

Hi @jmesser2006, you may find our release notes here: https://support.wyzecam.com/hc/en-us/sections/360001763251-Release-Notes to see the latest versions. Do you see a prompt to upgrade your cam firmware?

Hey Mark,

Of course after I emailed the experts it decides to accept the flash and started working again. Thanks for reaching out.



1 Like

My Pan don’t do motion tagging/tracking nor events. Only sounds events. So I try to flash the firmware.
I did exactly what you said. It just never solid blue lights.
Always ready to connect.
PS: I did put demo.bin in the root. I did press the button THEN plug the power.

A common problem with windows is when you rename a file the OS puts an extension on it. Check to make sure it’s not demo.bin.bin

1 Like

Thx for replying.
Now when download it’s automatically “demo.bin”
I tried different versions. Can’t make it work.
Do I need to delete the “.bin”?

If you are using the native File Explorer you need to have MS windows file browsing set to show file name extensions.

1 Like

Well. Amazon is replacing one for me since there’s a problem.
But I still think flashing the firmware and update again could make it work.
For 4 days I didn’t realize the motion events doesn’t work. Since I could get a new one. Then I need to make my lose back.