Wyze Cam V3 Pan - Failure to flash firmware

I’ve been trying to update a Wyze Cam Pan V3 firmware and I’m at a loss. It will not update via the app, crashes every time. I’ve got a clean MicroSD card, so I followed the instructions to load the most recent firmware on it to update manually.

However, there is never a point where the light is anything but red. The instructions say:

" 1. Hold the setup button, plug in your USB cable, keep holding the setup button for 3-6 seconds until the light is solid purple, then release the button.

  • Note: For “Solid Purple” both the blue and red LEDs will be on at once, making it appear to be a solid purple."

It’s a reset button, not a setup button, and no matter the process the light is red. It never even throws blue. It just goes to “ready to connect” if you hold it long enough. I cannot get it to boot off the MicroSD in order to update.

Any ideas? It’s been down for weeks now and I’m at a loss on what to do at this point. We did contact support, and they offered to replace it with the order info, but we did not purchase the camera and therefore do not have the information to request replacement.

The camera does connect to the app, but the app will not allow it to be used because the firmware is so old. It forces the upgrade, which just throws us into a loop with this camera, since the upgrade never loads.

It is a setup button because it is the button that initiates the setup.

I have had other cams that also refuse to flash for many different reasons, mostly the SD Card.

  1. Make sure it is a 32GB microSD.
  2. Make sure it has been freshly formatted - Full Reformat in a computer to FAT32… NOT a quick format that just wipes the data.
  3. Make sure the .bin file copied to the SD Root has been renamed appropriately if needed. In this case recovery_wyzepan3.bin
  4. Insert the card and use a blunt object that won’t pierce the weather boot to hold down on the setup button while the cam is plugged in. I found that occasionally I didn’t have it pressed all the way in or I let off of it while plugging it in.
1 Like

Sometimes Wyze cares with regards to terms, that’s why I mentioned the instructions. The button cover says Reset.

1 - it is a Wyze branded 32GB microSD. I actually have two to try.
2 - I have done so.
3 - Triple checked the naming, as I hoped I’d either downloaded or named it wrong.
4 - I have verified it’s going in.

I wonder if it makes any difference that I’m moving the bin and unzipping it from Mac?

Not sure. I don’t use any apple products. I open the zip archive on Android and then drag the .bin to the SD Card.

We did try redoing the process from a Windows based computer - formatting the card and going through the flash process. We still never get the “purple” or red/blue light to show it’s going into the right mode. It’s red or “Ready to Connect”. It does not flash the update from the microSD.

Any other ideas? This camera is effectively bricked at this point, since the app won’t allow it to function without an update.

1 Like

If you can’t get it to accept a flash update from the SD Card after a factory reset and repower, I would recommend contacting Customer Support and getting a ticket started by requesting a Warranty Replacement.

Hold the setup button in for 10 second for a factory reset. Then press again for setup.

1 Like

Did you ever get this resolved? I’m having the same issue. The camera is bricked from go if you can’t update. That’s no way to do business.

Just adding my experience for anyone else in this situation:

My Wyze Cam Pan v3 bricked as a result of a failed over-the-air firmware update.
Power-cycling and a factory reset had no effect. The camera powers on with a solid red LED, but pressing the Setup button has no effect.
I tried different power adapters as recommended by Wyze, but that isn’t the issue.
Finally, I downloaded the firmware (recovery_wyzepan3.bin) to an SD card (formatted FAT32).
Powering the camera on with the Setup button pressed got the camera to enter firmware flashing mode (solid purple LED). And that’s the end of the story; it never got past that point even after leaving it overnight.
I tried a few different firmware files and various file names, but nothing worked.
I filed a support ticket and they gave me a gift card for the cost of the camera.
I’ll hang onto it in the hope that someone eventually figures out how to resurrect a bricked camera. I can’t believe that Wyze engineered the camera without a failsafe image to boot from. That’s worrying for future firmware updates.

Welcome to the Wyze User Community Forum @nigels! :raising_hand_man: Thanks for sharing your experience.

Did you attempt a factory reset without an SD Card and then flash to one of the older versions available for download or just the most current version?

Double check the SD Card to be sure you’re getting the bin file, without extraneous file extensions. Also make sure it is the BIN file and not the ZIP file. Also make sure there is NOTHING else on the card.

1 Like

Double-checked the extension, but I did notice that macOS had added some dot files and there was a dot subdirectory with the name of the firmware file. I removed all the extraneous files, checked and double-checked. Yup, exactly the same behavior: purple light forever. If I had to guess I’d say that the firmware file is getting expanded, hence the subdirectory, but then the next step is hanging.

Good suggestion. I haven’t tried an older firmware version, but I’ll give it a try and report back. The factory reset has never worked for me with this device. The LED stays red and nothing else happens, including the setup button.

1 Like

Any non-Wyze cards? Any size will do as long as it is smaller than 32gb and FAT32.

Today, I installed the oldest firmware available ( Unfortunately, the firmware update fails in the same way: purple LEDs during the update and it never completes.

1 Like

I think it’s time to contact Customer Support, run thru their obligatory troubleshooting attempts, and request a Warranty Replacement and RMA. The cam was only released in Q4 last year, so it is still under its 12mo warranty.

(206) 339-9646 or 1 (581) 500-1166 (Canada)

1 Like

Has anybody ever gotten this to work?
I’m not looking for suggestions from well-wishers.
But I’m looking for steps from someone that actually got it to work
I’ve had no issue installing RTSP version on Wyze Cam V3 cameras in the past.
No luck trying to flash anything with the Pan flavor of the camera.

Welcome to the Wyze User Community Forum @vaguy! :raising_hand_man:

I have been successful at manually flashing firmware to a Cam Pan V1 cam. However, I must note that this was done prior to the 4.10.9.xxxx series of FW updates. I have yet to have the need to flash the Pan V3 and those are currently mounted in rather inaccessible areas.

I posted the following tips in another thread:

Sorry for the confusion
I’m looking for someone who has successfully flashed a Cam V3 Pan camera and can provide steps.
Is there a particular bin filename it’s looking for?
I’ve successfully flashed non-Pan V3 cameras in the past

I’d be willing to to drop back to a previous firmware OEM version if that would help me get over the hump
Current OEM version in Pan V3 is
I tried to flash using a filename of recovery_wyzepan3.bin
No luck

I guess today was the day to finally bring back to life my Pan V3, thankfully no spirits attached with the exception of the one I’m drinking, cheeerrrs!

Not sure if this was a one off or can be replicated. This was one of three of my first Pan V3 that had failed during the update possibly due to location. Since then I’ve used the same SanDisk 32gb trying to revive it with no luck just as others above. This SD would at least get me to a purple led reboot but to no avail, just stuck. I just let it sit there every now again checking status hoping it would may be change, nope. Well at least not until today trying different SD cards other then the original SanDisk I used to get to purple but still no luck. Tried copying the SanDisk with its original flashware to other SDs, no luck. Tried using the available current flashware to reboot using the other misc SDs with no success, not even purple light. So I new something must be up with original SD card SanDisk because all others failed up to that point where this one didn’t. I noticed my Chromebook didn’t have any issues reading the SanDisk but my WinPC did. The WinPC didn’t like something on that card but yet the files could be seen on the drive in both systems. I dared not format the SanDisk as this was the only SD card I had that made it past the staring red light. Instead I played around with copy / paste back forth with PCs and only deleting the file. Finally ended up deleting the original flashware on the SD and downloaded what’s available today 1-6-23 directly from Wyze’s site which is the November update.

So at this point I have the original SD unformated SanDisk that was able to get to the purple phase and now has no visible file cause they had been deleted. In essence a blank SD (but not really cause something in it that’s recognize by the purple gaze) that is now ready to receive from today’s 1-6-23 download directly from Wyze’s site which is the November update. Inserted SD, did the usual plug and hold, next you know its Track Motioning me under 15 minutes timer. Gotta say it really spooked me but with a happy twist to starting of a brand new year. May this in some way help, good luck to all !!!