Attempts to factory reset V3 unsuccessful

New camera.
Attempts to factory reset V3 unsuccessful.

Pressed and held the setup button from 5 to 30 seconds.
The cam only responds with the tone and “ready to connect” repeatedly.
It never goes to a yellow light.
Times out and returns to flashing red.

Thanks for pointing me where to find the fix. -NJ

1 Like

The V3 is having issues right now. All of us with new cameras are waiting for them to fix this issue so we can connect. Blargh.

Here’s the link to the forum page where we are congregating for an update. Just purchased V3 not connecting - #10 by emdoller

Thanks for the quick reply. I’ll remain in a holding pattern for now.

More remarks: I initially set it up as a non-v3 cam. That was a no-go. I went to the factory reset for the fix. That was also a no-go.

1 Like

Welcome @greenisgold!
Pressing the setup button factory resets the camera. It sounds like you’re trying to flash the camera’s firmware manually, I’d suggest trying this again.

He’s trying to do a factory reset which is failing. I am having the same problem. Nothing to do with updating the firmware.

Welcome to the forums!

Question for ya, why are you having to factory reset the new camera? what issue is it having?


We were trying and failing to get our cameras to connect. One of the troubleshooting steps was to reset the camera back to defaut. The issues with the connection problems has since been resolved by Wyze. It was weird.

Our v3 cameras did work. I ran an update and now the app says error 90 and there is a steady red light on the camera. I have unplugged. Checked wifi. Reset multiple times and still get constant red light. Even after 5 minutes. I have a flood light wyze camera on the network and works fine. What was in that update?

Welcome to the Wyze User Community Forum @morris.brink! :raising_hand_man: Glad to have you aboard! :grin:

It sounds like your cam didn’t get a clean update or isn’t starting back up. The solid red light indicates it is still trying to initialize.

You may have to run it thru a setup again for it to come online. Don’t delete it from the app, just reinstall it.

  • Remove the SD Card.
  • Press and hold the setup button until it does a factory reset.
  • If you don’t hear “ready to connect”, press the setup button to initiate the “ready to connect”.
  • Use the App to add the cam as though it were a new install.
  • Name it the same name as before.
  • All your previous cam settings should be saved.

Hello Wyze,

Your prognosis might be correct.

I was reading a different forum before I read your reply and did delete the two v3 cameras from my app. I still have one functioning Wyze camera on my app.

I took out the sd card and try to reset. I hit the setup button for at least 10 seconds with no success.

I still have a solid red light.

Any other way to reset the cameras?

Thank you


Just to let you know, I am not a Wyze Employee. I don’t work for them. I am just another user like you in the forum who volunteers to help.

So after powering up, if you press the button once, you don’t hear “Ready to Connect”.

If this is the case, you might have to manually flash the firmware to the cam.

The current version and previous versions are available for download on the Notes & Updates page :point_down:. Click the blue version number to download it and then follow the Flashing instructions :point_down:.

I would start with the current version and then move backward if that doesn’t work. Make sure to use a 32GB card. Once you get a good firmware flash, you should be able to press the button once to get “Ready to Connect” so you can reinstall to the app.

1 Like

I appreciate your transparency and your help!

I will try it.

Thank you


1 Like