Cam V3 - Can't Connect & Can't Re-Set Up / Loops

My front of the house Wyze Cam V3 lost connection and wouldn’t reconnect after a power cycle, etc. so I deleted it and did a factory reset.

I go through set up, it connects, then in the app I get an offline error -90 message. Then I hear a click. At that point the LED is flashing red. So it’s gone back into set up mode (without pressing reset).

Reset. Setup. Same thing. Rinse, wash, repeat.


If the camera really is going into setup mode on it’s own, you may need the help of Support to see about a replacement. The only thing you can do on your own is a manual firmware replacement.

Customer Support

There are many ways to contact Wyze. Their phone number is (206) 339-9646, or you can chat with an agent or create a ticket on the support site.

They’re open for support between 4 am-8 pm PT Monday through Friday, and 8 am-4 pm PT Saturday.

I am having this same issue all of a sudden. I did a manual firmware update and its still going through this process. Following.

What version of firmware are you two using? Have you tried manually flashing a version older?

I was using the latest December 6th update. That’s when the issue happened. I manually updated the firmware thinking maybe it didn’t install correctly but the problem continued. So, I rolled it back to an August firmware ( and its now working again.

I tried to manually flash using the November 22 update and nothing changed. I’ll try August.

So, apparently the August 26, 2021 update ( ** fixed it. What a pain.

And the camera actually didn’t respond to the manual flash process as described by Wyze. The purple LED went red then flashing red immediately, with no sign of a reboot and then I had to go through the setup process.