Wyze Cam v3 Code 90

I bought 2 Wyze Cam v3’s about 2 months ago. About 2 weeks ago one of them got the error code 90. I’ve done all troubleshooting steps found online (reset router, pull sd card, try reset button, power cycle camera, etc) and nothing works. Red light stays solid on device. Last night the 2nd camera is now experiencing the same symptoms with the same lack of results from all the help I find online with the error code 90. Red light stays solid. No help from power cycling, reset button on device, router resets, etc.

Am I missing some sort of normal fix for this sort of thing? Is it common for these v3 cameras to not last more than a month or two? Any ideas?

Thanks!

1 Like

Welcome to the forum @gamesetmatchwin.

Looks like you checked the hardware and network side of the house. Did you also check your wyze app version and firmware for updates?

I did. I was already at the latest firmware. Actually tried loading the prior firmware to see if that would work but no change. I have not tried a different app version but since the failed a few weeks apart with no change in the app I figured it’s likely not an app issue.

There have been some issues with cameras stuck on red light. I have had to return 2. Mine failed during firmware update. Are you able to manually update the firmware with older version?

Attempting to load prior firmware has not resulted in a change. Not sure if successful as neither camera will connect any longer. But both were running the latest firmware from June and had run fine after update. It’s been the weirdest thing. I loved these cameras and had convinced my dad, an aunt, and an uncle to buy them based on the first few weeks of use. I’ve had to go back and tell them all to hold off due to my current issues.

When you load firmware, does the LED ever change color to a purple-ish or always stays red?

I’d give support a call. My best experience has been contacting support via phone vs. a digital ticket

WYZE Support Number
(206) 339-9646
Normal hours, available Monday - Friday 5 am - 6 pm PT
Saturday 8 am - 4 pm PT

It does change to purple then back to red.

Fair enough. Thank you!

Yea, if you’ve gone through all of that and this well put together troubleshooting guide by another member then time to check with the company support. Hope you get it resolved!

Same as mine. I don’t think firmware actually loading. Supposed to reboot once firmware loads, you should see some blue or alternating blue/red light. If you don’t mind me asking, what brand and size SD card are used on those cam’s?

They both have 128gb micro center SD cards. I’ve tried removing them. Loading firmware on other, smaller cards but nothing changes.

Yup, mine also has 128Gb when it died.

And welcome to the forum @gamesetmatchwin! :slightly_smiling_face:

The uSD card for bootloading firmware (manual process) must be 32Gb (or smaller) and format in FAT32. https://support.wyze.com/hc/en-us/articles/360031490871-How-to-flash-firmware-manually

yes, had to remove 8Gb from a Pi3 to load firmware, didn’t have anything smaller.

When both cameras died during firmware update, they had the same 128Gb card installed. Reading other posts, same as happened to other users. That said, others have 128Gb and larger and have had no issues. Just ordered a 3rd camera, would be nice not having it died again. Was on phone with Wyze, while pleasant call they didn’t offer any clues to why cameras died.

1 Like

Ok. I’ll try that.

Wyze “officially” supports 32Gb uSD cards. I’ve had good luck with the 64Gb on newer firmware. The 128Gb are hit and miss.
A bad cell on the (32Gb) uSD can hose up the system as well. You could try a low level format to mask out bad sectors and replace with redundant sectors.

There should only be one partition on the uSD card as well for the demo.bin file.
The alternating blue/red light is hopeful.

1 Like

@WyzeMina @WyzeGwendolyn fyi on this. Seems to be an increasing occurrence.