Multiple Wyze Cam v2s bricked after firmware update

I have a few Wyze Cam v2 cameras that have stopped working and it seems to be when the firmware got updated.

  • The first unit went offline in early February and shows error code 90 when trying to connect to it. The light is solid yellow. It makes a physical clicking noise occasionally.
  • I have a few of these boxed/unused in a drawer so I got a new one out, set it up and it worked. I upgraded the firmware via the app and it did exactly what the other one was doing - error code 90 and a solid yellow light.
  • I setup #3 today and I’m really reluctant to run the firmware update and brick another one so it’s currently running which is ancient and doesn’t work with Cam Plus.

So far I’ve tried:

  • Holding down the reset button for 10 seconds to do a factory reset - no response, light remains yellow
  • Downloading the latest firmware to an SD card, holding the setup button to trigger a firmware flash. Light turns bright blue for about 30 seconds then back to solid yellow. It still doesn’t connect or reset when I hold the setup button

My guess is that there is something in firmware that came out in early February that took out the first camera. The 2nd camera worked at first on the old firmware but developed the same symptoms when I upgraded that to

Any ideas on what I can do to revive the old cameras or at least prevent the new ones from suffering the same demise?

1 Like

You seem to be having a problem with the manual firmware flash. The cameras are very picky. You need an SD Card 32gb or less formatted FAT32. You also need to be sure you have the extracted version of the demo.bin file (from the ZIP file you download) and, if you are using Windows, make sure the file isn’t named demo.bin.bin.

Thanks for reporting this. I have several NIB, as well.

Thanks for the info. I double checked the SD card again and everything looks good there.

I was using a 32GB formatted as FAT32 and the file is renamed to demo.bin (confirmed via command line that there’s no hidden extension).
I tried a separate 16GB card - still the same.
I tried deleting the drive partition, reformatting as FAT32 again and did the full format instead of the quick format. Still nothing - it always goes back to the solid yellow light.

I also tried a few different firmware versions but nothing seems to work.
I’m out of ideas now.

1 Like

And you did extract the bin file from the zip file, right?

Yes, I extracted the contents of the zip and then renamed the file from demo-{VERSION}.bin to demo.bin.

I always get the same thing and it won’t take the firmware update.

This is a screenshot of what I see on the card.


1 Like

Which version of the firmware are you trying to flash? I’m running (March 17, 2022) but you’ll need to do a factory reset on the camera first to get this one installed on the V2.

I also have two cameras that are bricks since update. One is Pan Cam and the other is Cam V2. My other cameras are all working fine? I’ve tried everything mentioned above.

Update - I just got my V2 to connect. I deleted the camera from my app/phone. I added it as a Pan Cam instead of Wyze Cam (since there isn’t a V2 option).

Deleted the Pan Cam and just reinstalled it. It’s also working now.

Hope this helps.

So far I’ve tried all the versions which are available for download from the firmware page: February 2022 December 2022 November 2022 September 2022

Anything from earlier than September 2022 has been removed from the download page so I haven’t been able to try those.

I wish I could just reset it and revert to the older stock firmware but I can’t get the reset to work.

Interesting - I removed one cam from the app and left the other one in there but both behaved the same way. I’ll try removing the other one and see if that helps.

I was also wondering if this is anyway related to the fact that there’s no V2 cam option in the app. I selected Wyze Cam V1 when I added them to the app as there isn’t a V2 in the list.

From another post:

This solved my issue. My cameras were doing just what yours were and they appeared bricked:
ATTENTION: TurboQAM (QAM256) support in DD-WRT must be turned off for wyze cameras to connect in setup after April, 2023 software updates. Cameras that are running older software stay connected but upgraded cameras or new cameras purchased with newer software WILL NOT CONNECT to a DD-WRT router using TurbQAM (QAM256) support ENABLED on the 2.4GHz WiFi radio. This took me forever to figure out!!