V2 solid yellow light, how to fix

Wyze camera v2 has solid yellow light on,
Tried to factory reset same thing.
Tried manually re-flashing firmware, even tried oldest available
Loaded so card, held button during power on, blue came
On, and same solid yellow

Any idea’s on how to fix ?


I have the same problem and I’ve tried the same solutions. Nothing makes any difference and there is zero way to get any assistance from support.

1 Like

Same here. I hope someone comes up with a solution soon.

I’m experiencing the same problem on one of my v2 cams. Would like clear instructions on how to fix.

I tried flashing the last working firmware for V2 but it didn’t work for me. There does not seem to be any answers. Cam stopped working after a firmware update. Sad, I won’t be buying any more Wyze products.

1 Like

I also had problems flashing the firmware of my V2 cam.

But then I found it was a problem with my MacOS. Every time I tried to unzip the downloaded file, it was showing an error that was misleading me to copy the wrong file to the sdcard. When I realized the unzip was fine and ignored the MacOS error, I copied the correct file to the sdcard and the rest of the process went fine.

1 Like

Have you tried a different power supply? I used my cell phone charger and it booted normally. The Wyze power supply measured 3.6 volts so it was done for.

OMG I’m dealing with this now-everything was super smooth…until I tried updating the firmware. I’ve tried everything here and here to NO AVAIL. I want to toss these things thru the wall!

Same issue here! Just installed two Wyze V3 cams and they are fine. However, the Wyze app prompted me to upgrade firmware on my V2 camera, then it bricked! Solid yellow light! Created the demo.bin file with the latest firmware, held reset button, powered it up, light did turn blue for 4 seconds, then solid yellow again! I do hear periodic “Clicks” from the camera as it’s plugged in. Any solutions to this issue??? Thank you!

same issue! 2 out of 5 v2 cameras bricked after firmware update. The 2 cameras were bought in 2020 and were only opened in Dec 2022. Both had no issues with initial setup. After receiving the firmware update notification in the app, I tapped without thinking. Now both v2 cameras show solid yellow light.

I tried updating to every available old firmware version ( to 4.9.91574) and could not get past the solid yellow light. I tried holding the reset button more than 6s, 5 mins and 10 mins while plugging in the power cable. During the update, the light did change to purple light. Then after a while, purple light changed to solid yellow light.

3 out of my 5 v2 cameras updated from to the latest with no issue. The only difference I can see is that I kept up with firmware updates on these 3 cameras whenever a new firmware is released VS directly jumping from a much older firmware to the latest in the 2 bricked cameras. Unfortunately, I did not check which firmware version the 2 cameras were on prior to the brick. I would guess a 2019/2020 firmware since they were bought in 2020.

While it’s on the solid yellow light, it does have the periodic “click” sound

I also tried updating to the webcam firmware and then back to the standard v2 firmware. It didn’t help.

I have tried 4GB, 8GB, 16GB and 32GB cards.

Anyone ran into the same brick issue with updating from a much older firmware to the latest?

1 Like

Tech support reached out but, because the v2s are older I’ve gotten this reply; “We would like to offer a replacement for this unit but it looks like this product is outside of the warranty period and is not eligible for being replaced.” Then I’m offered a $15 gift card for THEM screwing up my cameras.

I feel like I’ll be trying to reach out to Louis Rossman on this one

1 Like

Same issue…solid yellow light and can’t get past it. Tried resetting, leaving unplugged for days, deleted from app, different power source…no joy. I now have a paper weight. This is a V2 Pan camera that bricked after a firmware update.

V2 Pan is petty new. Have you tried to flash to older version? using a 32gb or smaller microsd card?

I’ve tried the same, resetting, leaving unplugged for days, deleted from app, different power source…nothing. I have a second cam v2 that is working just fine. :frowning: What now WYZE???

Apparently the only thing left alive is this thread? Is there no workaround for the solid yellow light?

I tried all the suggested and i am still getting the SOLID yellow status. I guess i will try a few more times before declaring lost.
My go forward approach with the rest of the Wyze product …NO more updates.
Crossing our fingers and pray … a terrible upgrade strategy .

PS… I have to write off a few door sensors and motion sensors… Out of battery could kill the devices and they would not wake up even with new batteries.

I have 8 camera’s all v2. Five of them were disconnected because of a renovation about six month ago. Of the eight, three remained hooked up and running while I completed my renovation. These three received updates as they were released and is current today. It’s important to make note that my network hasn’t changed at all since initially installed in 2019-2020. Upon completion of my renovation I reconncted five that were offline during this downtime, Of the five three of them started right up two failed. I set the failed camera’s aside while I ran the updates on the three, one of them them updated successfully while two whick ran a minute ago were bricked in the process, solid yellow light. As for the other two, one was able to read out very briefly “ready to connect” before also being bricked. To surmise, one of the three installed the firmware update successfully and is still operational, the other two-even while they operated on the old firmware became bricked only after the “update” and the other two never powered on after sitting for a few months. So I have four v2 camera’s that refuses to setup. It’s frustrating that WYZE does not offer support.

I literally just reset a Cam v2 that I hadn’t used in a while. It was able to connect (could see the video output) and then the Wyze app suggested upgrading the firmware. Doesn’t work. Manual flash downgrade didn’t work.

Very disappointed.

I have 2 cams pan V2 , 1 camera stuck in solid yellow, 1 camera stuck in solid red .I’ve tried reset and flashed firmware and never pass solid light. Same though, no help ,no solutions at all ???

does anyone know how to get wyze support engage here?
Looks like a common issues to us , ‘old timers’ of their product , and wyze had turned deaf to us !