Can't get past the solid yellow light

I received the V2 unit today and set it up on my home network. I upgraded the firmware and the cam worked fine for about 6 hours, until I unplugged the unit to reposition the camera and add the extension cable. I proceeded to plug the cable back into the camera and nothing…just a solid yellow light.

I unplugged and plugged back in…the camera clicks and displays solid yellow after about 15 seconds the blue light flashes and then goes back to yellow. Every few minutes the camera clicks, but the light remains yellow.

I tried resetting by holding the reset button for 20, 30 , 40 seconds and still solid yellow.

Am I doing something wrong? or is the camera toast?

I have another V2 camera on my network and it works fine.


Is there a microSD card in the camera? If so, try removing it and then resetting the cam.

I have this EXACT issue. Any solution?

1 Like

Return & replace.

Same here, one worked one had trouble, the reset worked for me, so far.

I too have the same issue. No SD card. Tried to reset. Any other solutions?

Please contact, you most likely have a bad unit.

1 Like

Make sure the phone you are using to set it up is on the 2.4GHz wifi network and not on 5GHz…Worked for me…Good luck!

1 Like

Same issue! Did you find a resolution?

1 Like

Was working fine for a day after upgrade. Tried to move unit a few feet away to permanently install, disconnected power plug, unable to reconnect at the new location, waited and waited still nothing. Solid yellow light even after taking out SD card, re-set numerous times, etc etc.

If you did factory reset (hold setup button for 20-30 seconds) and that didn’t work, you may want to try to re-flash the firmware:

Otherwise, you’ll need to file a support ticket for this camera.

Same issue , took the support 5 days to get my complaint, replied to factory reset which I tried several times before. Now waiting 2 days and still no reply to the email reply . This suooosrt sucks , you get what you pay for , garbage .!!!

I had the same problem with one of three cams I received. You can get it working by reflashing the firmware mentioned in this thread. It took me a little while to figure out because I’m on a Mac, but it’s really not that hard. I understand if people don’t want to fool with doing this, but the only other option is waiting for support, then waiting for a replacement.

O has the yellow light solid. After a little while, it would just go out completely. Long story short, took out memory card and held the reset button for about 20 seconds until the yellow stay light came back on. This worked. Now I’m trying to see why my phone’s qr code screen doesn’t work. I just get a big qr code symbol.

Edit. Just realized I’m using the camera to scan and not the phone. Hopefully all works fine.

1 Like

I have the same issue… I held the reset button for 2mins… Still nothing. And this cam was working fine before. I think an update bricked it. Please, and resolution asides from returning??


I received a replacement Pan Cam camera for one that was working then it had a solid yellow light. I received a new one to replace that one. Same problem. I left it plugged in after resetting a few times. It would click a few times but it never moved. It just stays a solid yellow light. I even tried to download a firmware. Nothing changed.
I feel like chugging it into the garbage. I think a Wyze representative said that if you get a replacement for a replacement, we get a refurbished one, not a new one to replace the original new one I bought!
I think this is why the replacements don’t function 100%. There is something wrong with it, and sometimes it doesn’t even work at all.
Any solution to fixing the solid yellow light?

I feel you. Solid yellow light after numerous attempts at trouble shooting:
unplug and replug
tried different locations
tried different cable charger

Seems to be a common issue. It will have to be replaced. I got one also. I got a hold of them via chat for a replacement.

Yes, it does seem to be a common issue.

I called Wyze today and told him that I believe Wyze sends a refurbished camera to replace your new camera if it doesn’t work properly. Camera was finally recording to he cloud and the SD card but it kept going offline.

I tried it his way, which was to download a firmware flash. All it did was destroy the SD card. Now it only records to the cloud if there is no SD card inserted. Still having online and offline issue too.

Today I finally received an email in response to the original rep that helped me. She confirmed that it was called an Open Box Replacement, which means it was a refurbished camera to replace the replacement of the original camera I purchased.

I told him I am sick and tired of all the problems I am getting. I am going to get a Ring camera. It is more expensive but it is worth it after all the headaches of getting bad pan cam cameras. The Wyze Cam seems to be good but the Pan Cam ones suck.

I am not recommending Wyze anymore to anyone anymore.

1 Like

I had the same issue… well, and other random issues earlier: buzzing noise from speaker, connecting to camera worked every third time, it would randomly power cycle itself.
Well, today, everything seems to be working perfectly. And after having tried everything “easy” to fix… which didn’t solve much of anything… I ran through the process of manually flashing it as a last resort. (download the latest firmware to my laptop, unzip, put micro SD card in adapter and in laptop, renamed the file to demo.bin and put on SD card, put back in camera, and started camera while holding the setup button until the light went from yellow to yellow and blue.) A few minutes later, ran through normal setup process and everything works.