Can't get past the solid yellow light

I tried the process of flashing or with the firmware download from their site. It went from solid yellow light to flashing yellow & blue. It stayed flashing yellow & blue light after it is powered and doesn’t change or do anything.

The other one is just solid yellow and does nothing too.

Same issue!! So Annoying!!

Same issue here, its a shame how after all this months customers are facing the same issue still.

1 Like


I had the same issue. Wyzecam v2 stopped working after i upgraded. I was told to re flash thefirmware. I tried twice and was going to give up.

Finally i noticed that you want to remove the power cable to the wyze cam v2, insert the SD card with the new firmware, KEEP PRESSING THE SETUP BUTTON & Now insert the power cable to wyze cam. This played the trick (the previous time i plugged the power cable first and then was pressing the setup button and it did not work). Within few seconds light turns blue and within a minute it had flashing light and my camera is working fine now.

So, please unplug the wyze cam power connection, load your SD card with new firmware and put it back in Wyzecam v2, now press the setup button and then insert the power cable to Wyzecamv2 and you should be good.




That sounds like too much work for upgrading the firmware. Upgrading firmware in my cameras disabled my cameras.

I have resisted upgrading the firmware cause my cameras are working fine now and like they say, don’t fix it of it ain’t broke.


What if you dont know how to load the right firmware onto the sd card?

I hate updating the firmware. WYZE sucks when it comes to downloading and upgrading the firmware. It makes camera inoperable, unlike other software updates from other companies like Apple or Ring.


Flash Firmware for Wyze Cam v2 & Wyze Cam Pan

  1. Wyze Cam v2 and Pan firmware files can be found on the Release Notes page.
  2. Download a specific version of firmware, For Windows 10: Right-click on the folder and select extract all. For Mac: Just drag and drop the folder, put it on the root directory of your microSD card. For both Mac and Windows, rename the file to demo.bin .
  3. Power off your camera and insert your microSD card.
  4. Hold the setup button, plug in your USB cable, keep holding the setup button for 3-6 seconds until the light is solid blue, then release the button.
  • Note: The “Solid Blue” in this case is not the same as the one normally seen on the camera. Instead, both the blue and yellow LEDs will be on at once, making it appear to be a lighter blue.
  1. Wait for 3-4 minutes. The camera will reboot and change light status during this time.
  2. Once this is done, your camera should be functioning with the original setup. No need to re-setup your camera!
1 Like

This procedure mostly worked for me, but I still had to remove my original setting (remove device) and then add it back in as a new device. After completing all of the setup steps again, the camera is now functioning normally (but I have removed the SD card now to keep the damned cam from revolving all by itself uncommanded)!

1 Like

I followed all the Flash instructions to the T but the solid yellow light remained solid. It never went to blue and never rebooted to a flashing yellow. Now what? Suggestions?

After flashing, I had to remove the camera from the app (remove device) and then add it back in as a “new” device. Finally, after completing the series of setup steps again, the camera is functioning normally

So if I don’t have a sd card in it to begin with I need to buy 1 to reset the camera?

My v2 camera came down with the dreaded solid yellow light last week. Reflashing new firmware did not fix the problem. Camera now makes a clicking sound every 30 secs (approx) and the yellow light goes off, or comes back on. When the light is on, the Sense Bridge light turns yellow; then when the v2 yellow light turns off, the Sense Bridge light flashes blue/yellow. I noticed that the continuous sd card recordings started failing (missing foldings/files on sd card) a few days before the constant yellow light appeared. Why has Wyze not indicated the cause of this failure? My guess is that the v2 camera fails due to heat issues when the Sense Bridge has been plugged in for some time. The Wyze app now indicates the camera is OFFLINE, and all the Wyze Sense devices are OFFLINE!

I’ve had 2 Cam v2 units brick after the firmware upgrade.
Manually flashing both older & newer firmware haven’t fixed anything.
The status light stays a solid yellow and even resetting the units doesn’t do a thing.
Is there anything else I can try before trying to return these units?

I have the same v2 issue after an upgrade, gives me a solid yellow light even after carefully flashing the firmware as directed . I cannot perform a factory reset at all. Sent an email to and waiting for a reply.

I had the same issue for months. Luckily managed to resolve using a 16GB storage card, initially I was using a 128GB.

I followed the reset procedure however, held the reset button before connecting to power… Plugged the power (still holding reset button) for like 10 seconds, unplugged and immediately plugged back the power (still holding the reset button) Blue and yellow flashed. Well, not guaranteed but it worked for me…

Similar issue here — can’t get past the solid yellow light.

Tried the solve listed on this thread (without the SD card as I don’t have one)

Opened and set up to connect to app and test functionality — everything worked.

Unplugged and mounted to its location in the room and got stuck on the yellow light. No micro SD card or firmware updated. Just moved, mounted and it’s stuck on the yellow light — device won’t factory reset. :man_shrugging:

This camera was a gift so unfortunately, I don’t have the receipt would love if there’s a solve out there.


I had a same issue with the solid yellow light. Followed all the recommended process from Wyze support, including flashing the July 2020 firmware but still not working. After Wyze recommend a replacement and ended the phone call, I decide to flash the camera with the August 2020 firmware and the yellow light finally blinks.

1 Like

Thank you for this feedback. Can you kindly share the August firmware details for easy reference.

1 Like

Did you manage to reconnect it after it started blinking again ? Had the same issue, now the yellow light is blinking, however I do not get the 'ready to connect" audio signal.

I have a wyze cam pan and the light is solid amber. Ive tried changing the plug and cord, getting it closer to the wifi router, and resetting it and nothing happens. Please help