Perpetual Flashing yellow light!

One of my 7 Wyzecams appears to be having trouble. It keeps losing connectivity. I will reboot it and get a blue light and no issues, then next time I check it’s a flashing yellow light again. I just can’t seem to stay connected. I tried deleting it from my network and reinstalling it, but that failed to help. Is there something else I could try to get it working as it should (just for clarity, I am running the latest app version and all firmware is up to date)



First recommendation would be a factory reset.

To perform a Factory reset on your camera, follow the instructions below:

If using an SD card with the camera, remove it before proceeding.
Leave the unit plugged in and power on.
Press and hold the setup button on the bottom of the unit for 20 second.
Allow at least 30 seconds for unit to initialize, in some rare instances this process can take up to 5 minutes.
The LED on the back should move from Solid Yellow, to Blinking Yellow.
The device is now ready to be setup once again.

If it is still not working as expected there is one last thing you can try if you want to, but you can also just email to initiate a replacement under the warranty.

We do have a forum post referencing a troubleshooting method to flash the firmware for your WyzeCam V1, here is the link for your convenience:

We recommend starting with a single firmware file at a time; Please try this version first: FIRMWARE_660R_F_3.9.1.102

Additionally Noted: You will need to be logged into your Wyze Account in order to view the firmware files available. ( Currently there are 5 of them total )

Thanks. I gave it a shot and we’ll see if it worked.


I noticed that other than wiping the settings, that little else changed and the firmware version was the same, is that how it should have worked?

The same happened to me.
As requested I uploaded the last firmware yesterday.
Since, nothing works and unable to connect again. I have reset the cam, following the steps and then I don’t succeed to connect the Wyzecam. Now just blinking blue and orange all the time.

Everything worked perfectly until last night.
Very disappointed.

I found the steps described were not quite accurate in order to induce a reset.


Try this:

Unplug the camera.

Push and hold the reset button.

Plug in the camera while holding the reset button.

Keep holding until it makes a noise and start flashing yellow.

Set up the camera again.


After doing this my problems went away.


1 Like

I tried twice and nothing. Its stay bilking all the time. Thanks for your advice, anyway.

I tried this and my camera said, “Can’t Connect To Local Network” The camera case seems warm to the touch? Is this normal with everyone’s cameras?

Here’s the connectivity troubleshooting guide:

If that doesn’t solve it, keep in mind that this is primarily a user-to-user forum. If you don’t get help here from the community, file a support ticket, preferably from within the app while the bad camera is selected. That will ensure that the logs are captured. You might want to submit the ticket right away because there’s somewhat of a backlog. You can always let them know it’s already resolved when they contact you.

This actually worked!

1 Like

I’m having the same issue. Came from work. Camera blinking yellow. None of the resets described work. The concerning part is it never makes a sound and the yellow LED blinks immediately after plunging the power adapter in even if you were holding the reset button while plugging in.
This is a version 1 Cam Pan

Hit by the flashing yellow light on one of my v2’s. From what I read, support takes a long time to get back on email. Is there a more efficient way to get this reviewed by the wyze team? Only solutions online are to reset the camera, and that did not work for me.

Wyze currently has a two week backlog. However, they are working hard to alleviate that situation.

Here are the Troubleshooting Guides. You can also run through the troubleshooting flow chart by clicking “Begin Troubleshooting” at the top of this page.

Keep in mind that this forum is primarily a user to user community. If you don’t get a helpful reply here, please file a Support Request. Depending on the nature of the problem, rather than use the previous website link, it is helpful to submit an App Log and/or a Firmware Log.

Got a revert from Wyze after waiting several days. Troubleshooting didn’t help. Now I’m back again in the queue waiting for a revert…

Out of curiousity, what did support recommend to you?

They asked me to reset and check if the light pattern changed. I’d already done that so the issue remains.

Was it a factory reset, or just a power reset that they recommended? Please be specific with your replies so maybe someone with the same issue may be able to help you. :slight_smile:

Factory reset

You could request a replacement if you are still within your warranty period.