Can't get past the solid yellow light

Is had been a while since I’ve set up my cams. One of the main things you need to make sure you are doing is being on the same wifi that your cam is going to be on.
For example, my wifi has 2.4ghz and 5ghz freq. Wyze only uses 2.4ghz.
Ensure your phone is on the same signal. Your phone gets that information and password and creates the scan box which the cam uses to log in to your router.
I think that’s the main thing that gave me problems at first. Once you get the cam working you can then switch back to the other frequency on your phone if that is the case for you.

Someone mentioned about the micro-SD card in the Wyze Cam Pan. As soon as I removed the SD card, it responded again. After it connected and worked, I put the SD card back in. This is how I fixed my solid yellow light problem. Hope it helps someone.

1 Like

I used this video to install firmware. It worked with no issue. WYZE CAM - FLASHING FIRMWARE - YouTube

1 Like

New Pan camera (well, 1 year old but hadn’t used it until now), ran setup as normal, firmware upgrade failed, light went solid yellow. Pressing Setup button for 1,3,10,20,30 seconds didn’t help. Rebooting camera, phone and router didn’t help.

I eventually tried a firmware update (using .193 as that’s in my other cameras) on 32GB Micro SD card. Afterwards light was flashing blue and I was able to press the Setup button and do a clean install. Then moved it to a new location, waited about a minute for the various lights to settle on solid blue. Now working well.

Note that I’ve read somewhere else that firmware upgrades only work on SD cards of 32GB or smaller.

Yes, Wyze recommends that SD cards of 32GB or smaller be used for the Wyze cameras. I was told that if the SD card size is bigger, it can ruin the camera and the mess up the workings of it.

I tried several times to fix the yellow light. After awhile, it was too much work to try and fix the solid yellow light after a firmware upgrade so I asked for a replacement. They sent me a replacement and it has been fine since then. I think they just have batches of bad cameras for some reason.

Just had this issue yesterday, and solved it very quick, i saw this video : WYZE CAM - FLASHING FIRMWARE - YouTube. …try and let me know!! Good luck!!!

1 Like

The point of buying a cost effective item is to not have to spend dozens and dozens of MY time to keep fixing the product. We have about 9 or 10 badges…which is now looking like 9 or 10 returns. I can’t afford to keep up with problems. I can just pay a security company 1500 bucks a year and THEY will fix the problems with their hardware if there is any.

1 Like

This worked for me! Thanks Jacob!

one of the last updates broke one of my v2 cams, I finally got a chance to get up on a ladder and pull it down. I tried to manually update again to the latest firmware but ended up back ant the solid orange light. So googling I found this thread and specifically the post from Wongmichael24, so was able to install the august 2020 firmware and that got the camera working again. I then tried the latest firmware again and it successfully installed… took longer than I was expecting, but it did install and the camera is back up outside working again.

Something else I discovered as I was having this same issue that I thought is worth noting for others in the future…

I encountered the solid yellow light as well. I tried doing a firmware update via micro-sd (ironically, it was a failed OTA firmware update that caused the problem in the first place). Anyway, several attempts to update the firmware had no result - still a solid yellow light. Then I realized I was using a “large” (64GB) micro-sd card.

I dug out a 4GB card and viola - problem solved.

Anyway, if a firmware update isn’t solving the solid yellow light, maybe check the size of the memory card you’re using…

Hope that helps someone.



Thank you for this tip! I thought I had another bricked camera, but tried a smaller sd card and was able to get it going. I had been using a 64GB card. Switched to a 32GB one to flash the firmware and that worked.

1 Like

Bingo! Found in a YouTube video from wyze, for cam v2…
*** Rename file to demo.bin. ***
Insert card, hold button, plug in USB.
Renaming fixed my camera.

Here’s that video. WYZE CAM - FLASHING FIRMWARE - YouTube

Renaming to demo.bin on a 64gb card has woked for me to update to the latest firmware!
Up & Running now!

Thanks mgmoon!

I know this is old but did you ever get this resolfed? I did the same thing… used aug 2020 firmware, got blinking yellow light, but never got “ready to connect”

Are you using a 32GB or less SD card?

Yea. I’m using a 32gb

I just spoke to support at Wyze, official statement is they are aware of the issue that their firmware bricks devices and are working on a solution but nothing forthcoming. Also, their official policy on whether to do a firmware update boils down to this: they always recommend firmware updates, but if it bricks the device and it is out of warranty, you are S.O.L. So basically, if within warranty period on your device, update away. If not within warranty, do it at your own risk because you will need to purchase a replacement.

Typical Wyze support. (sigh…)