After Firmware update - cameras stopped working

I have 5 Wyze cams - all V2, when I got the notification through the app to update the firmware I did, it said failed.

Backed out tried to connect to the cam, it generated the error code -90

This happened 2 times - 2 different cams - so I have 3 of 5 working the others will not reset properly and from what the girl in the WYZE video says it dosnt alter software so if the firmware is corrupt it will not help me.


What should I do? - Calling customer support only gets me hung up on as their Queue system is obviously not installed to handle many customers :slight_smile:

First, don’t let it try to update the 3 working cameras until you determine what caused the first two to fail.

What version was it offering you? I’m in the beta and my v2 cameras are running firmware. And I have Android App version 1.5.42 (now public as well). And they updated without issue. I am not sure what version they upgraded from.

First thing I would try is to make sure you have the latest version of the App loaded. The firmware and app need to be using the same features.

There is a manual firmware upgrade method that involves downloading a file on your pc, copying to a microSD card and holding buttons. I have never had to do that yet, but others reported success. Some of the commenters said they had to double press and hold to get it to work, not sure it this is just coincidence or a fact (I find it hard to understand how double pressing when the camera was powered off could affect anything).

If you have a microSD card you can use, and you want to try reflashing, here is the thread

It doesn’t have the version I am running, the latest version in that thread is, but since was “released to the public” on Sept 17, I am not sure why it isn’t in the above tread. Perhaps there have been issues and it was pulled, or perhaps they never updated the post with a link to the new version. That seems unlikely, I don’t see a lot of complaints in the thread.

Thank you BukeEye

I didnt give up easy, followed the directions they left for manual firmware installation on an SD card - it worked well, back up and running.

The automatic firmware updates have worked in the past, except for this one released on the 17th - after the second cam went down, I definitely stopped the others :slight_smile:

Thanks for you help - have a great night!