Firmware update failed

I attempted a firmware update that apparently failed. I can no longer connect to the camera. What should I do? Thanks!

I had the same problem with one of two cams. One updated fine, the other never finished the update and no longer can connect and is broken. Both cams are in the same room, same wifi, same everything.

The LED blinks alternating blue/yellow.

Tried power cycling it, hard reset, deleted the cam from list of devices and then tried to add it back but that doesn’t work.

The firmware update failed and the camera is bricked.

Submitted ticket, got the automated email with a ticket number #23511 but no further response yet

I had the same problem, and am waiting to hear back from the support team.

I to have this problem , i’ve rebooted , uninstalled the app, deleted the camera and tried to connect get the same message . It flashes yellow .WyzeCam Support Ticket #23556.

they show no support what so ever…

I too bricked my cam but I will not be putting in a ticket. My 4th camera arrived today so I connected it and got the firmware update is available. I proceeded with the update. When the update was around 20% I decided I wanted to change my location so I unplugged the camera and immediately panicked buy it was too late. I don’t expect Wyzecan to support my stupidity. I ordered a new one 30 minutes after opening the new one that I bricked. The only odd thing is the camera will reset, scan the QR code but never connect. I’m glad these are not too expensive.

I never unplugged mine during the update process.

I’m having the same problem. I have 3 cams set up and 2 took the update, but one will no longer connect to wifi.

No firmware update that I’m aware of, but the app updated and now no connection (-90) on my only camera

I have the same problem. I updated my first camera and it failed. I try rebooting then readding the camera but nothing, it just fail to conect. Then I updated my second camera and it was successful. Please provide an answer at least to know how to fix the cameras with failed firmware update.

All three of my cameras apparently went through the update process ok and I believe were working. However today two of my three cameras will not feed video data, they connect, authenticate, but stuck on getting video data (3 of 3). On TinyCam I see about 30KB/s data rate but 0 frame rate. One of the failing cameras is set to send notifications and I got a bunch all at once but when I try to play them, file doesn’t exist. The third camera seems to be ok. My app version is 1.2.50

Hey guys, I am having the same issue, one camera updated with no issue. My other camera did not survive. I’ve unplugged it. Deleted that camera from the iOS app. Attempted to re-add that camera. All goes well, I’m hearing “ready to connect” and every once in a while (yes, I’ve attempted this several times) getting the “QR code scanned” message. But when trying to connect to my wifi I get nothing. I’ve put in a ticket and waiting on a response from the support team. Support Ticket #23879 has been generated. Does anyone care to share the “hard reset” directions. If it is holding down the reset button for 20-30 seconds, I have tried that. I read that holding the reset button down and plugging the unit in will work as well.

It appears my problem was low bandwidth internet connection. All cameras working now.

I finally got a response to my help ticket. Haven’t tried it yet, still stuck at work.

I recommend performing a factory reset. While performing the reset, please ensure that you remove the MicroSD card from the camera if you’re using one, as leaving it in has a high probability of causing the reset to fail.


To perform a Factory reset on your camera, follow the instructions below: If using an SD card with the camera, remove it before proceeding. Leave the unit plugged in and power on. Press and hold the setup button on the bottom of the unit for 20 second. Allow at least 30 seconds for unit to initialize, in some rare instances this process can take up to 5 minutes. The LED on the back should move from Solid Yellow, to Blinking Yellow The device is now ready to be setup once again.

I just tried performing the factory reset according to the above instructions. It did not work. When I release the setup button the LED goes from solid yellow to nothing. It never flashes. I tried to connect anyway but it failed.

Doesn’t work for me either. It goes fine until “QR code scanned” then the LED starts alternating blue/yellow and never connects.

I tried it…no luck. It scans the QR but never connects, same as before.

Same here. Got a ticket. A response email to factory reset and same Failed to Connect.

After running the firmware update, and not getting connected again, I did the factory reset, and it still won’t go through setup. Connection fails after scanning the QR code. Haven’t had it for a month yet. How can I return the camera now that the firmware update has bricked it?

My camera only worked for four days before the update bricked it, wish I kept the original packaging to return it via Amazon since there doesn’t seem to be any support from the manufacturer.


Has anybody else got any sort of response to their help tickets other than the factory reset suggestion that didn’t work?