V2 update thread

What did update fix?

No clue but so far one of my wyzecams is not connecting to my modem after this update :rage:

I updated my firmware to and see no change when it did connect after multiple attempts.

Well, I got an Upgrade Failed. Nothing worked.

After power cycling the cam at least a dozen times and doing the setup twice, I finally got it up and running and attempted to do the upgrade again and the device info page reports it’s at Sigh.

There were several times the LED went from yellow-blue blink to off.

Then View Playback wasn’t coming up so I formatted the SD and got a format failed. I tried again, the format took and View Playback is OK.

BTW, the What’s New link on the upgrade progress page brought up a blank page.

Thinking it’s the night vision LED upgrade, I can’t find a setting for that.

So, about an hour screwing around for what???

Camera settings Advanced and there is Night vision mode Off Auto On is that what you looking for?

It said Update Failed. Now will not connect, says to cycle power error -60 or 90, repeats.

Update: after several power cycles and an hour later it started working again.

Could always adjust night vision mode on auto off from the main camera page. Have seen nothing different with this upgrade except the ability to now do this same thing from the advanced settings menu page. Was hoping for an “IR Lights” on auto off option.

I updated one of my V.2 cameras and it updated just fine. I guess. I haven’t explored every function but I can get content from it.
I have 5 more but I’m going to wait until WYZE refreshes the “what’s new” page and I stop seeing “update failed” postings here.
Good luck everybody.

I don’t see this version listed on the wyze website:


I entered a support ticket asking them to confirm this is a supported update. I have 1 out of 5 cameras prompting for it. I will skip it until I hear back from support.

1 Like

My first two cams failed to upgrade and were unresponsive. Went all the way to 100% before reporting failed. One is remote so there is nothing I can do but the local one I have done a hard reset (unplug) and it eventually came back up and is reporting installed firmware I then exited the app and went back in and now I can reach the remote one as well (and has the latest firmware).

Trying my third one…upgrade failed. Cannot connect with error code -42. Restarted device (soft) and get error code -60. Exited app (from BlueStacks emulator) and now getting error code -90. Now it’s working. Will wait till tomorrow to do the rest.

Edit: Got them all to work. My guess is that the update site got bogged down and the app just timed out.

1 Like

@mathews_patrick… it is listed on the page you linked now.

I’m having the same\similar issue as everyone else. I have about a half dozen of the v2s.

The first one appears to be completely unresponsive. I’ve tried moving it around, using different power cables and outlets, etc. I also deleted it and tried re-adding it and it told me it couldn’t find my wifi network - so I unhid it and still nothing. So I’ll try flashing the firmware to the last one and updating it again (the new firmware doesn’t appear to be available for download).

The second one got to 100% and said update failed but then appeared to come right back online and seems to be fine (and is reporting the new .28 firmware version). I tried a third and had the exact same experience as the first - it seems to be bricked now too.

So there doesn’t appear to be any consistency in what the update will cause or the final result. Has anyone gotten any info from Support?

Well after leaving the one that seemed to be bricked sit (the first one) it seems to have come back on its own. If this is the expected behavior then there should be SOME kind of warning that the update may take longer than the app indicates and to just leave the camera sit. With so many and a completely inconsistent experience\result this is very frustrating - especially when someone relies on these devices as part of their security system.

UPDATE: So when the first camera started working again I moved it back to where it belonged and now it doesn’t work again SIGH. And the third camera has been rebooted but hasn’t come back online yet (the status lights did what they would normally do and it shows solid blue but no connection). Not sure what’s going on with this latest update but it seems to be terrible and incredibly frustrating.

UPDATE #2: So I started to wonder if the issue had to do with the age of the camera (and therefore its internal components). The two that I have that have had the issue are older and in the first batch of cameras that I ever bought. The one that worked was newer. So I tried one of my newest cameras and it updated just like always - the update was quick and it came right back online with no issue. So I’m going to try the remaining 2 I have and see what happens. I also have at least one or two more that are brand-new in the box and may try those to see what happens. Will post another update.

UPDATE #3: So the remaining 2 have done exactly what the first and third cameras did. They updated and the update “failed” and now I’m waiting to see if they eventually come back. The first camera finally came back online and it seems to be fine now. I have not had any issues with my cameras prior to this update (including the mentioned bug concerning poor network connections causing reboots) - WiFi is perfect throughout my entire house and I have quite a few IoT\WiFi devices installed on-prem (Nest, Amazon, Apple, Comcast, etc) none of which have any connectivity issues.

So for those out there it seems a little patience and the cameras seem to come back online eventually for some unknown reason (it would be great to hear from Support as to why). I’m still going to try my newer ones at some point and see what happens. Good luck everyone.

Both my active V2 cams (w/SD installed) updated to the new firmware yesterday with no problem. I had experienced this bug:

Fixed an issue leading to poor network connections causing device reboots

It is the unprofessional PROD deployment!

How could the team do that? Release a update without explanation then added the note later after people asked?

The IT release manager or PM should be fired!

There are two sides to every story. If an update is urgent enough to push immediately, then there are reasons. You have to realize that above and beyond the support and technical side, they are also developing. There are many things that factor to a release going out before release notes. If you read the release notes, one of the bullet points was security patch. I’d rather my devices are secure and safe before any thing else. They would not release a firmware if it was not absolutely necessary. Another food for thought is Wyze relies explicitly on these services and camera to run, that is how they profit. They would not do anything to jeopardize that. From my experience, if there are any issues that occurr, they will do everything possible to remediate it.

@alahome, are you having any issues with the production update?

Sorry it’s still not acceptable for me.

As a professional IT company, NO matter how urgent it is, for your release manager or PM or whatever name of role, they should still prepare the release notes before pushing those updates to the clients. There is NO excuse. And please honestly ask yourself how hard and how long it takes for your release manager or PM to put just couple lines release notes?

And it’s very common to keep new development and hotfix running paralleling. DevOps tools are so popular right now. I really don’t get it why it needs to be addressed.

Don’t get me wrong. As a wyze client, I really wish your company going well. If the constructive suggestions are not welcome here, I will shut up in the future.

Have a good day!

Any suggestion is welcomed in any community for any company to grow. I agree partially that the notes should have been out a little bit sooner. I am a Wyze client just as you are. But, justifying the termination of an employee just because the release notes were late one time in the middle of a small outage I think is a little excessive.


I have currently have 4 v2 cams and updated one to yesterday.
Today I decided to roll the dice and try another.
When I went to device info on a cam I hadn’t run the update on, it shows installed firmware as Checked the next and it also shows installed firmware even though I did not run update on either cam.
Weird part is when I checked the 4th cam it shows installed firmware and check update on that cam comes back as my firmware is up to date ?

Just updated to and my two Cam 2’s are getting errors. One got error code -90 and the other got -20018. Right after update I got unable to update notifications on each one but when I went back to check device info the new version number showed on both. I tried restarting and also unpluging for 6 seconds and trying again. Both cameras keep tying to starup steps 1//3 and fail with the same errors. I waited 15 minutes and now they seem to be working. What is going on as I’m questioning reliability/stability of the update.