Self diagnostic for upgrade failures

Hi, firmware upgrade is a painful thing. We have seen different ways of failure for upgrades. We would like to list the most common scenarios and possible fixes. The common situations are 1. Can’t connect, 2. Can’t upgrade, keep prompting but keep failing 3. Bricked (always solid yellow), 4. Tried to re-setup after connection failure but kept failing. Here are our suggestions:

Can’t connect after upgrade
Suggestion: Try to power cycle the camera (do not re-setup). If not working, please try 20s factory reset and re-setup. If still not working, you can try manually flash the latest firmware (currently for v1 and for v2).

Can’t upgrade:
Suggestion: try another 2-3 times for upgrade. If it keeps failing, try to manually flash the latest firmware

Bricked: (solid yellow light)
Suggestion: The only way to get it back is to flash the firmware

Tried to re-setup after connection failure but setup kept failing:
Suggestion: 20s factory reset and then re-setup. If not working, try manually flash the firmware.

Flashing firmware link:
Note: You may be hesitant to flash with the latest firmware since that is the one broke your camera. Actually that is not necessary. The main problem is the upgrade process which needs a lot of memory and space. Failure is usually not the new firmware’s issue. The higher version you flash, the less chance you have to upgrade again :slight_smile:

Of course, if above doesn’t work for you, please feel free to contact our support team at for assistance.


is there an easier way to update the cameras? I have 6 and i have to go to each cam confirm the update wait for it to finish and move on to the next. can’t i just confirm once to update all my cams?

The “Flashing firmware link” is obsolete as of 10-28-2020. My v2 camera repeatedly failed to upgrade. I found a recommendation to remove the SD card; after do so, the upgrade to succeeded.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.