Self diagnostic for upgrade failures

Hi, firmware upgrade is a painful thing. We have seen different ways of failure for upgrades. We would like to list the most common scenarios and possible fixes. The common situations are 1. Can’t connect, 2. Can’t upgrade, keep prompting but keep failing 3. Bricked (always solid yellow), 4. Tried to re-setup after connection failure but kept failing. Here are our suggestions:

Can’t connect after upgrade
Suggestion: Try to power cycle the camera (do not re-setup). If not working, please try 20s factory reset and re-setup. If still not working, you can try manually flash the latest firmware (currently for v1 and for v2).

Can’t upgrade:
Suggestion: try another 2-3 times for upgrade. If it keeps failing, try to manually flash the latest firmware

Bricked: (solid yellow light)
Suggestion: The only way to get it back is to flash the firmware

Tried to re-setup after connection failure but setup kept failing:
Suggestion: 20s factory reset and then re-setup. If not working, try manually flash the firmware.

Flashing firmware link:
Note: You may be hesitant to flash with the latest firmware since that is the one broke your camera. Actually that is not necessary. The main problem is the upgrade process which needs a lot of memory and space. Failure is usually not the new firmware’s issue. The higher version you flash, the less chance you have to upgrade again :slight_smile:

Of course, if above doesn’t work for you, please feel free to contact our support team at for further assistance.


Upgrade failure.

Have tried every suggestion in the Forum.

Failed to connect every time.


Any further suggestions?




Ron Grimm

Is it a v1 or v2 unit? Did the manual flash succeed or not? If it worked in the past I am surprised that it doesn’t work after manual flash.

When it fails to connect, is the LED light flashing yellow/blue or in other state?

V1 unit

When it fails to connect I get blue/yellow flashing Fail to Connect message.



I have 5 v1.0 and 3 v2.0 plus a Pan. All v1.0’s are working fine and reliably for the last many months. The v2.0’s are another story, 1 of them will not upgrade at all but still works fairly well, the second one upgraded and has to be restarted many times a day to use, if you don’t restart it just says to power cycle the camera error -90 and the 3rd v2.0 is essentially dead, it will not connect to the network, I tried every fix I can find, tried the manual update with the fine on the SD card many times, still nothing, it goes through setup until it goes to connect, then it fails

I have written tech support with all the details from my purchases etc and have NEVER received a reply.


So what is my next step? None of the V2.0 cameras are of any real use to me in the state that they are in? I have even reformatted the 32GB SD cards in each, and swapped them around and they work fine in v1.0 camera’s


FYI, I didn’t have to hold down any buttons to manually update the firmware on my three v2 cams. After copying the new firmware to the sdcard I was able to update in the usual way through the app. I formatted the sdcards I was using so there was nothing on them but the new firmware.

I updated the firmware as described v2: Update took, but now it comes online, then reboots, comes online for 5-10 minutes, reboots, etc.

Wyze V2 cameras don’t work here. The V1 cameras are fine.

Did you have any problem before the update? You can try a factory reset (by pressing the ‘setup’ button 5-6 seconds and release) and re-setup your camera. Yours may be a hardware defect but it is worth a try.

All of my V2 cameras are dead. V1 cameras are working fine.

Trying the factory reset on V2 reset the camera, but it cannot connect to the network. The camera keeps saying Ready to Connect and can’t get past the QR code. It stops talking after a minute or two and the camera just clicks and the led flashes fast blinking yellow.

It is hard to diagnose without touching the unit. I suggest you email for a replacement request. To save time, you can tell them you had forum discussion with Tao and Tao recommended for a replacement. Thanks!

This is an odd problem: The firmware updates correctly but the app reports that the update failed. When I look at the device info it shows the correct version of the firmware. This looks like a bug in the iOS app to me. This has happened on 2 consecutive updates on two different cameras.

Thanks for reporting! This could happen following our logic below. Once the app kicks off the upgrade command, the camera will download the firmware, reboot, and upgrade. In most part of it the camera is not connected to internet/phone. The phone app uses a timer to check camera back online with a timeout value. In your case, very likely the camera went back online after the app hits timeout. In that way on the app side you saw upgrade failed but it actually succeeded a little later. We don’t see a best way to solve this issue. We can extend the timeout value but the real failure case will take longer to return. What we did was trying to find a good balance between not waiting too long for failure and having less false positive failures. For some reason the timeout we chose was not good for your case. If we have more customers hitting that we will reevaluate the timeout value.


This sounds like you need a timeout retry counter. Set this to a small number like 3 and you will never wait too long and if the upgrade is labeled “failed” it probably really did fail.