Not Getting Purple Light - Brick V3 Cam - Any Thoughts?

Hi Everyone,

Just got a new Wyze Cam v3, and after installing the latest firmware it it’s stuck on Solid Red. Holding the Setup 10 secs. to reset does nothing.

Tried using the oldest available (Dec.2022) to download on the official website, with my SD Card with the file named demo_wcv3.bin in the root (no in any folder). But holding the setup and plugging it in doesn’t make it purple either.

December 15, 2022

Do you know or have a link to a factory firmware? Maybe its because its a new version? Any thoughts or any other workarounds?

Read some other topics, but didn’t help as well.

I’ll try anything, used it for 5min and gone, and its not cheap for me.

Thank a lot!

I had a similar issue the other day that I was able to solve, I’m not exactly sure what did the trick but here are the things I did: as odd as it sounds I found that plugging the cable itself in the camera while the cable is connected to power was a more reliable way to get the purple light. I also changed power bricks and outlets. Hope this helps!

1 Like

Things to try:
Maximum 32 gb sd card formatted FAT32
Make sure to extract the bin file from the zip, don’t just rename the zip to bin
If using Windows, make sure that the file isn’t named bin.bin, which is highly possible.
Make sure you have the correct firmware file for EXACTLY your camera V3 not Pan V3, not V3 pro
Make sure you are actually holding the reset button when you apply power, use a small tool to make sure it is full depressed.


Welcome to the Wyze User Community Forum @pgarganon :raising_hand_man:

Everything from above… and: When doing the factory reset, do it without any card in it. Then unplug it for at least 30s. Then insert the flash card, then do the setup button while powering.

Always use a fresh format card, never one that has been in the cam from a startup boot. The cam writes files to the card when it boots. Always do a full format before every flash.

Try multiple brands of cards. Some are notorious for not flashing because of really crappy formats.

1 Like

Here is another thread on this issue. Good luck.


On the V3, I use a small non-pointed tool (usually a pair of needle nosed pliers that have a blunt nose) to press the reset button. When I am flashing I have the power cable plugged into a USB battery bank that is turned off. Once I press and hold the reset button, I turn on the battery bank. Much easier than trying to plug in a cable.


I’ll try this method as well. Thanks

Hi WildBill,

I have a 128GB card, I’ll try it on a 32GB (will have to buy one).

All the rest I’m doing like using a tool to hold the button pressed (removed the rubber cover)


1 Like

@ashtonwalky @WildBill @SlabSlayer @StevenA @K6CCC

One more question, I’ll try all the methods mentioned by you guys. But, shouldn’t I be trying to Flash it with an older Firmware? Since the newer ones (not sure which one) bricked my Camera?

In the Wyze Website, only the last 2 are available to Download and not the older ones (no links available). If this is the case (that I need an older firmware), how and where can I download it? Do you guys have it?


The oldest version I am able to see available released on April 25, 2022 with If you continue to scroll down past the most two recent firmware updates you will see a greyed out firmware and then two more available firmwares, the oldest being


More likely the download was corrupted - not that there is a problem with the current firmware. Most of us here are not having a problem with that version.

1 Like

It worked! Thanks a lot, I bought a 32gb card and it was pretty simple , 1st try.

Thanks guys .


I successfully used a 128GB card.
Out of the package it was formatted as exFat, which didn’t work. The status light wouldn’t go to solid purple.
I then used the “Disk Utility” program on my Mac to reformat the card as “MS-DOS (FAT)”, re-copied the firmware file to the card, followed the manual update process, and everything worked fine!
FYI, although I had previously attempted to add the camera as a new camera; once the firmware was updated, I could again see it as the existing camera (prior to the initial, in-app, failed firmware update attempt). There was no need to to re-add the camera as a new camera.
For other Mac users, the exact settings I used to format the SD card were as follows (Note: once you select “MS-DOS (FAT)”, the “Scheme” will already be correct):
Format: MS-DOS (FAT)
Scheme: Master Boot Record

I left the name as “UNTITLED”, and I doubt if the name matters at all.