Cannot flash firmware on V3 cameras

I’ve tried flashing the firmware to a previous version several times on two different v3 cameras, and it still won’t work.

Followed these instructions to the letter:

Light never turns purple and always get “ready to connect” message no matter how long I keep pressing the setup button (yes, as I plug unit in). Is there any solution to this?

This is why I’m trying to go back to a previous version of the firmware: Choppy video with wyze v3 cam right next to access point - #2 by spamoni4

1 Like

Have you tried a different SD card? Try taking the SD card from a known good camera, and put the demo_wcv3.bin file on it. I would delete the other files on the SD card if they are not important. Not sure if the flash will take if other files are on the SD card.

Thanks. What I actually just tried was taking a new blank SD card and placing demo_wcv3.bin on it and inserting that into the camera. That worked. Don’t think I tried that before. Going to try with the other cameras tomorrow to see if that will do it. Have to take the cameras down from their locations and re-setup any way.

But, yes, to answer your question, I don’t recall (I tried this several weeks ago, just reporting it now) if I used cards other than the one(s) that were already in the cameras. Also don’t recall if I tried using an otherwise empty sd card. But I do know I tried with the same camera on which I just successfully flashed a previous version of the firmware.

Update: I flashed earlier firmware (placing .bin file on blank, fat32 formatted sdcard) on 2nd camera successfully. Both cameras would not manually flash before, so it appears that the key is to place the demo_wcv3.bin file onto an empty sdcard before inserting into the V3 camera.

The light never really turns purple.
Hold button for a few seconds, you will see blue light with additional kinda purple ish light.

Hope it helps

Yes, it’s actually blue and red lights blinking simultaneously.

@sysop Could you do me a favor? When the next release of v3 firmware comes out, will you please let me know if your two problematic cameras are able to update via the app?

I’m asking because I have a v3 that wouldn’t update via the app. I had to update it manually just like you did. Then the next firmware release came out and guess what; it won’t update via the app again. Go figure this camera is outdoors and mounted in a hard to get to location.

When I try to update this cam via the app it just ends up going offline. I then have to power off the camera (unplugged on outlet end) and then power it on. The camera comes online again, but not with the new firmware. I should also mentioned when I manually updated it the first time, I used a brand new uSD card.

So far, I’ve reverted the firmware successfully on 3 cams, and each time I was asked if I wanted to upgrade to latest version. I don’t plan on upgrading any of my cams to latest versions, at least until this DTLS issue is resolved.

And, in fact, I’m sort of giving up on Wyze and purchasing mini poe ip cams as replacements. Wyze images (especially night time) are pretty, but way too much of a headache trying to get smooth video via wifi.

1 Like

Well shoot…I can’t say that I blame you and good luck.