Flashing wyze cam v3 pro

I have been trying to reflash my v3 pros and I searched on the forums and supposedly you follow the same steps as the v3… This can’t be true becuase I hold the setup butron and plug in my power cord ansvit doesn’t go into flash mode… The light never turns purple and it goes directly to ready to connect… Does anybody have a clue how to reflash the V3 pro… Wyze evidently doesn’t care enough to publish the steps like they do for the other cameras…

It’s been months since I did it, but I did flash a couple of V3Pro cameras by following the steps outlined for the V3. I have heard from some people that it can be temperamental in some cases.

One thing that is really important to make sure of that lots of people mess up is to make sure you unzip (Extract) the downloaded firmware file first, extract the Bin file from the zip file. Load it onto a BLANK 32GB SD card (I have heard people have had troubles flashing a camera with a large SD card).
I don’t know how important this is, but back when I did it, I renamed the extracted .bin file from recovery_wcv3p.bin to demo_wcv3pro.bin although the instructions say to name it as demo_wcv3.bin so maybe try both names if one is giving you problems. I’m pretty sure I wrote “pro” on the end, but I think other people I know of have left “pro” off the name, so maybe it doesn’t actually matter.

Then, with the USB cable unplugged, you insert the SD card and then while the USB cable is unplugged, hold in the setup button and keep holding it in while you plug in the USB power cable. Keep holding in that reset button nice and firmly the hold time. It says to hold the setup button for 3-6 seconds until you see the LED light turn solid purple, and I think I remember having to hold it in a little longer than 6 seconds. I think one time it may not have even turned solid purple, so if you don’t see it go solid purple, maybe try different intervals of time before releasing it. I would try 6 seconds, 10 seconds, and as long as 30 seconds. I think I had to try something like this once long ago when I tried to flash one. Anyway, like it says, you might have to wait a long time for it finish the reflashing process. It says 3-4 minutes, but I think it took even longer one of the times I did it. Just be extra patient if needed.

One other thing you might do before retrying to flash it again with the above in mind. Maybe reset it back to factory settings first, then try again. That might reset anything that might be jamming up the normal process: https://support.wyze.com/hc/en-us/articles/13570239069723-How-do-I-factory-reset-Wyze-Cam-v3-Pro-

Let me know if any of that helps, and which part if you notice anything specific. Like I said, it’s ben a long time since I attempted flashing a V3 Pro, but I can confirm that I definitely did it successfully multiple times by mostly following the V3 Flashing instructions, so I know it really does work. It would just be helpful for us know which of the above suggestions are things to mention to others in the future if you discover which helped the best if you can get this resolved.

1 Like

I flashed my V3 Pro at one time and I never changed the file name, I used it as is.

1 Like

I have this already on a card I just can’t get it to go into flash mode… I hold down the connect button while plugging in the power cord the light never turns purple, it goes directly to waiting ro connect… I’ve tried letting off the connect buttons at diffrent times but the camera never goes into flash mode

When you extract the file there’s a folder then open the folder then move the file and rename to the sd card . It cannot be in a folder otherwise it will not flash.

The instructions say extract and move it to sd card but what it doesn’t say it that you have to open that folder then move the bin file alone to the sd card

1 Like

I am also in the same boat. Have a Wyze Cam v3 Pro and it seems impossible to flash the software to get RTSP. I have followed the official instructions for flashing the Wyze Cam v3 as well as your advice in this thread. Nothing works.

I have tried the following:

  • Two different sd cards, one with 8GB and one with 64GB. Both have previously been used to flash a Wyze Cam v3
  • Factory reset
  • Two different formats exFAT and FAT32.
  • The file names demo_wcv3.bin, demo_wcv3p.bin, demo_wcv3pro.bin and recovery_wcv3p.bin.
  • Always hold down the setup button when connecting the power cable
  • Tested and managed to flash a released software recovery_wcv3p_4.58.11.4679.bin

A clear difference from @carverofchoice is that the file I download is called demo_wcv3.bin and not recovery_wcv3p.bin. I have searched for a sw named recovery_wcv3p.bin for version 4.61 (RTSP) but unfortunatly without success.

As an alternative solution, I will now try this: GitHub - mrlt8/docker-wyze-bridge: WebRTC/RTSP/RTMP/LL-HLS bridge for Wyze cams in a docker container

Welcome to the Wyze User Community Forum @Frickadillen! :raising_hand_man:

Wyze quit supporting RTSP firmware long ago. I don’t think it has ever been released for the V3Pro.

demo_wcv3.bin is Wyze Cam V3 Firmware and will not flash to a V3Pro or any other non-V3 cam.

demo_wcv3p.bin and demo_wcv3pro.bin are improper file names and will not flash to any Wyze Cam.

recovery_wcv3p.bin is the proper file name for the V3Pro flash file, provided you extracted it from the proper download archive and did not rename it.

There is no .bin file with that name and it will also not flash to any cam. What you have typed is the name of the zip archive containing the .bin file. Note the proper name of the download archive is recovery_wcv3p_4.58.11.4679.bin.zip

The proper name of the .bin file extracted from the archive, which is already named correctly for Windows and Android, is recovery_wcv3p.bin

I don’t believe RTSP firmware exists for the V3Pro. 4.61 (RTSP) firmware is only for the V3.