Flashing V2 camera to a previous version of firmware

I slowly replaced all my V2s with V3s and I have 8 old V2 cameras laying around. A local church asked if they could have them and I said absolutely. I wanted to make sure they all worked before I gave them the cameras, so I plugged each of them in and went through the setup process. Seven of the eight cameras setup perfectly. One had the dreaded solid yellow light.

I have read about, but never tried, flashing the firmware back to an earlier version. There were seven V2 firmware versions available for download. I tried them all.

Here are the steps I did (over and over):
Use a 32GB card
Reformat card using FAT32
Download firmware version to PC
Extract zip file to PC folder
Open 32GB card on PC
Copy single extracted file to card
Rename file on the card to demo.bin
Safely remove card from PC
Insert card in camera
While holding setup button, plug camera in
Blue light comes on
Release the setup button

Each time, the light turned on blue. Yea. The instructions say “Wait for 3-4 minutes. The camera will reboot and change light status during this time. Once this is done, your camera should be functioning with the original setup. No need to re-setup your camera!”

After less than a minute, the light on the camera changed from blue to solid yellow. I waited another 5 minutes. Still solid yellow.

Did it work? I don’t know, but I don’t think so. When it works, what does it look like? The instructions say no need to re-setup my camera. OK, if it works, how do I add this camera to my account to make sure it works?

Maybe you should try factory reset and just update the firmware via the app if you are able to set it up as a new device.

1 Like

Antonius - Thanks for the suggestion. I tried that, but the camera is solid yellow immediately when it’s plugged in and never comes off solid yellow. Unless I’m flashing the firmware, then it’s blue for about 45 seconds and then solid yellow forever. I know my cable and power supply are OK because I just reset seven old V2 cameras using them. Any other suggestions?

No I can’t think of anything else and I don’t have a V2 cam to play with. Maybe another V2 user will have some better ideas.

For V2, use firmware especially those early supporter of Wyze.
1002 is the last stable firmware I could suggest.
and use app 2.3.1 with android and never update both app and firmware.

iphone is out because U cannot sideload with ios.

When you reformat the card, make sure you are doing a Full format and not a Quick. Here is a Wyze video that may be helpful.

1 Like

StevenA - Thanks for the tip. I tried to do a full format but it never finished. So I just did the quick format. I’m out of town for a couple of weeks, but I’ll do the full format (whatever it takes) and see if that solves the problem.

If a Full format never finishes, it could be a bad SD card.

What about v3 and how are you plugging in v3 and holding down the button at the same time and what are we naming it ???

I’m not trying to flash any V3 cameras. Yes, I’m holding down the button while plugging it in. I’m trying to name it V2-8.

OK, I’m back in town. I did a Factory Reset with no card in the camera, holding the Reset button for 10 seconds and then I tried 30 seconds. No change. Still a solid yellow light.

Then I got a new 32GB SD card and formatted with FAT32 and made sure it completed the full format, not the quick one. Then I did the steps in the original post above with the exact same results. Solid yellow light.

I guess the old V2 camera might just be BAD. Does anyone have any other suggestions for me to try?

One more thing to try is use a blunt object to push in the Reset button while someone else plugs in the cord. The reset button can be very picky.

StevenA - You’re right. The reset button can be tricky.

I plugged the cable into the camera and asked my wife to plug the other end into an outlet when I said Go. I used a pencil eraser to push the reset button and held it and said Go. The purple (red & blue) light came on almost instantly, same as all the times before. I held the reset button down for another 10 seconds or so and then released it. The purple light stayed on, same as before. About 45 seconds later the purple light changed to a solid yellow light, same as before.

I’m not really concerned to get this camera back in action as much as I’m interested in making sure I’m doing the flash correctly. If this is simply a bad camera, so be it. But I still don’t know for sure that I’m doing all the steps exactly right for flashing the firmware.

Maybe I’ll take another old V2 camera that I know is working OK and try to flash its firmware. Does anyone have any other suggestions?

1 Like