Flashing your WyzeCam v1 firmware

Hi all,

We are working on solutions for firmware upgrade issues. One of the solution is to provide a way to revert back to older versions. Here is the instruction:

  1. Download a specific version of firmware, unzip it, put it on root directory of your SD card and rename it to FIRMWARE_660R_F.BIN
  2. Power off your camera, insert your SD card
  3. Hold the setup button, plug in your USB cable, keep holding the setup button for 12-15 seconds
  4. Release the button and wait for 3-4 minutes. The camera will reboot and change light status during this time.
  5. After it is done, the camera light should be flashing yellow (ready to setup)
  6. Re-setup your device as a new device
Note: I heard sometimes this method may not work on some SD cards. Please do reply this thread (with your SD card model, type, and size) if that happens to you. We have plan B if that happens but I am hoping this works for everyone. :-)

Other related topics:

Flashing Wyze Cam v2 - https://www.wyzecam.com/forums/topic/flashing-your-wyzecam-v2-firmware/

Flashing Wyze Cam Pan - https://www.wyzecam.com/forums/topic/flashing-your-wyzecam-pan-firmware/

FIRMWARE_660R_F_3.9.2.30.zip (13.5 MB)

FIRMWARE_660R_F_3.9.1.102.zip (13.4 MB)

FIRMWARE_660R_F_3.9.3.22.zip (13.6 MB)

FIRMWARE_660R_F_3.9.3.26.zip (13.6 MB)

FIRMWARE_660R_F_3.9.3.28.zip (13.6 MB)

FIRMWARE_660R_F_3.9.3.56.zip (13.6 MB)

FIRMWARE_660R_F_3.9.3.62.zip (13.6 MB)

FIRMWARE_660R_F_3.9.3.72.zip (13.6 MB)

FIRMWARE_660R_F_3.9.3.88.zip (13.6 MB)

FIRMWARE_660R_F_3.9.3.96.zip (13.6 MB)

This is awesome. If someone were to flash a different IFTTT firmware over their Wyzecam, would this let them bring it back to factory defaults?

Great! How/where do I download firmware?

You guys are quick! We reached file size limit on the website. Working on fixing it.

After that, I will post on this thread

Sounds good. Where would one find the firmware file to download?


It should.

My suggestion is use an Amazon S3 bucket - offload any static or other media via a WordPress plugin and let Amazon scale your downloads without affecting your main site server resources. We do it for clients all the time, you don’t have to worry about file size limits! firmware, remember rename it to FIRMWARE_660R_F.BIN

Oops, still blocked by website security settings. working on it

Thanks for the suggestion! This is a trial for a small group first. Once it is verified we will likely move it to our support website.

It seems like zip file works for now. I updated the original thread and attached the files again

Updated the original post


I had the V1 camera all updated to, then tried to go through the process with It seemed to complete, but was still on It’s possible I did something wrong.

So I started over, still starting with This time I formatted the card using the app before starting. This could have been the issue the first try. I used for the 2nd try, changing the file name as directed and putting it at the top level of the microSD card. Success.

Holding the setup button and plugging the camera in and holding setup another 10-15 seconds takes quite a bit of dexterity. Not easy. It took 2 minutes before the status light started flashing. Camera was on “old” firmware after setting up as new.

Lessons learned: (1) format the card before starting this process (not sue if it mattered, but couldn’t hurt). (2) Make sure the status light is enabled. I had it disabled the first time, and that makes it really hard to know what is going on during the process.

Will this procedure work for cameras that are bricked?

No luck on my ver.1 camera. I get the “unable to connect, please retry”. I tried both versions of firmware. The only difference I see is that the LED is now solid blue.


SanDisc 32 - Formatted Fat32



Version 2.30 gave me a “connection complete” message but the camera never appeared on my app. It eventually said “Unable to connect” and I tried the other firmware. The other firmware never said “connection complete”. It just said “Unable to connect”. So I rebooted my router and reinstalled 2.30…perfect! My camera works again!

Thanks !!

How do you know what version of firmware the camera is on if it cannot connect?

Many thanks for this!

Thank you!!!


It will fix some of them. But it is worth a try before calling it garbage

Wow, nice save!

Thanks, Rick! Likely the first time the camera didn’t recognize the file which didn’t kick off the firmware flash. After the SD card format, the camera recognized it. I agree formatting will be helpful.