Cam v2 solid yellow light after update was interrupted

Hi! I need help with my wyze cam v2. While I was updating it got interrupted and now it’s got a solid yellow light. I tried flashing the latest firmware but it won’t work even after minutes of holding the setup button.

The solution is to manually flash the firmware. Below are links to the firmware page and instructions page. My standard couple comments on manual flashing (I’ve done well over 100). Make sure you rename the file correctly. Windows by default hides extensions. If that is the case on your computer, it is very easy to end up with the file actually named demo.bin.bin (which will not work). Second is that it can be hard to hold the setup button while plugging in a power cable. My solution is to power the camera with a USB battery bank that has a power switch or button. Plug in the camera with the power off on the battery bank. Then press and hold the setup button and press the power button on the battery. Hold the setup button for 8 seconds after powerup (it only takes about 5, but the way I position everything, I can’t see the LED while pressing the startup button). Another way is to use a AC plugstrip with a power switch. Plug everything in with the switch off, then like my method, press and hold the setup switch and turn on the plugstrip.


Thanks for the response. I did everything you said and made sure the file name is correct but it still doesn’t work. Even tried pressing setupp button for more than 3 minutes.