Can't get my V3 to initiate firmware update

I got a brand new V3 cam, and tried several times to initiate the firmware update by holding the button while powering it up. I already changed SD Cards, and I have the file added to it, as it was for other cameras I did the firmware update. It just does not initiate the firmware update bootup.
I already tried the following:

  • Different cards
  • Formatted in FAT32 (8gb and 32gb) cards
  • Formatted the card in the camera itself. Removed and added the file, and put back in the camera.

Tried several times. It just does not go to purple/blue light ever.

Looked all over the internet to see if anything changed on Wyze to initiate the booting process for firmware flashing. But could not find anything.

Anyone could give me any other suggestion.

Thank you all

I agree with you that its a tricky situation. You’ve done an excellent effort and explained what you did. But I didn’t see in your list of what you did, if you renamed the file. For the V3 you MUST rename the file name. It must be named demo_wcv3.bin

And its my experience it should be the only Wyze file sitting at the root of the Micro SD.

Don’t give up, its something simple that preventing this from working.


Thank you for answering. The file name is demo_wcv3.bin (Copied directly from the file)

There are no folders in the card.

One thing I noticed, different from the other cameras I was able to perform the firmware flashing, is that this one isn’t going to the booting state. It does not get to the blue/purple light. It just goes straight to the " ready to connect"

My question is why are you even trying a uSD card based firmware update on a brand new camera?
Normally that would only be used if you are trying to install RTSP firmware or downgrade to an older version, or the camera is bricked.

1 Like

I’m trying to install the beta firmware to have RTSP enabled option. The camera is working, as I have added to my app, done updates. And confirmed the card is working.

I have done the same procedure in half of my outdoor Wyze cams. Those are all V2s (NOT outdoor graded - I know). But I didn’t have any problem with the file demo.bin. But with this V3 it just does not go to firmware booting mode. Tried so many times. Tried adding it to my cameras, add the file to the card after it is on my app, and doing again. Again. Again. It just does not get to the first 3-6 seconds boot load. It just goes back to ready to connect.

1 Like

And that was one of the three reasons that you would want to do that. I do have RTSP on a few of my V3 cameras.
My experience with the setup button on the V3 is that it is somewhat easy to not actually get the button pushed. I normally use a tool rather than my finger. Something that has a fairly small tip, but is not pointed. I have a pair of needle nosed pliers that has a flat tip about 1/8 inch across that works well. So does a small hex or torx driver.


I can try that. But I definitely can hear the button click being pushed down. And I think it’s actually being actually pushed, because the camera reboots and go back to “read to connect”, which tells me it’s pushed.

Good tips already posted here. I can’t add anything to those. I sort of cheat, when adding power back to the camera. I have a way that allows me to plug the USB A end into a stationary USB B outlet. Can you do that too? Don’t try to hold down the setup button while plugging power. Try using the USB A end to plug in power. (Good luck).

I go one better than that. When I am uSD card flashing a camera, I plug the cable into a USB battery bank that has an on/off push button that is very easy to press. Turn the battery bank off, then press and hold the setup button on the camera, then turn the battery bank on.

1 Like

WOW. GENIUS. But then again, that’s the bar you have set here for yourself. And we expect nothing less. hahaha

A lot easier to do that then plugging in a cable. Although I don’t use it for Wyze stuff, I also have a foot pedal switch that plugs into a wall outlet and the foot switch controls an outlet. Very handy when you need to easily control AC power and need your hands free.

1 Like

H-o-l-y Cow, Batman. Learned another trick today. Gotta do that now.

I have not had any issue in powering it while holding the button. I’m working out of my desk, and I have a pretty good condition to manipulate the wire while holding the button down. I don’t know if Wyze may have changed anything in the program, because I have done this before with V2s and was very simple. I have a feeling they changed the boot up procedure. I will try with a tool I have to make sure it’s being pushed while powering on.

1 Like

Just tried again, couple of times, with a took, which I can’t visually and soundly confirm the button is being pressed while the power is plugged back in. Tried in different ends of the USB cable. Still nothing. Left it unpowered for 1 hour. Nothing. I just feel they must have changed the way to do that.

I don’t think they have changed it. You can google their firmware install. Only difference between V2 and V3 is the name of the file.

1 Like

I looked all over couldn’t find anything. Wyze tech support sent me a response with the same steps. I’m under the impression the brand new cam they just sent me seems to have a bug already.

Any luck in resolving this issue? I have the same problem. Tried it a gazillion times. I can also hear the click but no luck on my V3. Strange thing I noticed is that from the camera itself I told the camera to format the SD card and it said that the format is complete but when I removed the SD card from the camera and put it back in the pc the demo_wcv3.bin file is still on the SD card. So maybe it can’t read or access the card properly

Have you tried another SD card? Make sure to use a card 32 gigs or smaller for the flash.

I got the most dumb answer after several tech support tickets, where they claimed it will no start the bootloader because the firmware on the camera will not allow it to start. They will release the new firmware eventually to the camera and that will allow the bootloader to start.
My opinion it’s just a lame excuse, as I had “older” V3s running the same firmware as the new ones that went through with the bootloader and got the firmware from the SD card.
If you find out a way, please let me know. I’d really like to flash it with a different firmware.