V3 RTSP Firmware Update

I tried to update to the RTSP firmware but I think the instructions are wrong. I added demo.bin to the sd card, I restarted the webcam while pressing the setup button. I don’t think that is right because It goes to that irritating man saying ready to connect.

Does anyone know how to properly update the firmware?

It is important that the name of the file is correct. Here is a link provided by a Wyze employee:

Here is a snippet for the v3:

Download a specific version of firmware, For Windows 10: Right-click on the folder and select extract all. For Mac: Just drag and drop the folder, put it on the root directory of your microSD card. For both Mac and Windows, rename the file to demo_wcv3.bin

WIll try to see if I can find the RTSP Steps as well


Here is a link for the RTSP, it is similar to what I mentioned above.


Thanks for the help! The naming is where I went wrong. I figure the instruction page needs updating. I had to revert to a stock firmware then re-try the RTSP and with the correct naming it worked. I guess it tried when it was named demo and got hosed because all connections to the cam went away.

Again many thansk for the pointers. :slight_smile:


Glad that I found this post! Just want to add my two cents in case anyone else encountered similar issues: the Micro SD card needs to be formatted as MS-DOS (FAT32) rather than exFAT. Otherwise, it does not recognize the bin and will just go to the regular setup.

1 Like

Created an account to add to this - I had to try multiple Micro SD cards for my V2 and V3 cameras, ultimately here’s what worked:
64GB Lexar 300x Micro SD XC I U1
Formatted MS-DOS(FAT-32)

What didn’t work:
16GB Blackvue Micro SD Class 10
64GB Samsung EVO Select Micro SD XC I U1
both also formatted. MS-DOS(FAT-32)

I have a cheap microcenter 64GB ssd card and it caused issues with one v3 and then not the v2. It’s been decades since I’ve had the opportunity to use msdos so I recommend against using diskpart and favor use of the formatting option in the right click dialog. Better yet, try a 32GB sd card and you will probably get more positive results. Also try formatting from within the app.

Make sure to check the version of firmware you are currently using.

This may not be the right place for this but does anyone know if any changes were made to the rtsp firmware for the version 2 cameras? I wasn’t sure if it was the same that has been out for a year or so or if it was new. I was hoping for some performance improvements with the version 2 cameras for rtsp.


You would need to read the notes for the latest changes and fixes before you upgrade. I assume that if there is a firmware update there would be changes. I haven’t looked recently since I don’t have any issues with the rtsp on Tinycam pro

I have tried formatting a 2 GB card with FAT, FAT32, and exFAT. my V3 camera ‘fresh out of the box’ or updated to the latest firmware does not want to do the update that enables the RTSP firmware. When the card is in and I press the button while powering the device, it always goes to ‘ready to connect’ instead of the purple light.

I have used MS Windows 10 command prompt: format K: /FS:FAT
to format the 2 GB card for the different file systems, is there another flag I need to set?

I copy the demo_wcv3.bin file to the root directory, software eject the card before removing it from the computer, put the card in the camera and power up… am I missing something?

I only have the one old 2GB card and some new 128 GB cards (which cannot be formatted for FAT32 due to the size limitation of 32 bit file systems).
I got these cameras specifically for RTSP - and would rather not have to buy more cards just to flash the firmware. any other suggestions?

I have also formatted the 2 GB card from the Wyze app with the card plugged into the camera, ejected the card from the camera, removed it, using my windows PC copied the file to the root directory, and this also does not work (goes to ‘ready to connect’ rather than doing the firmware update). I had assumed this would use the ‘ideal’ file system to enable the firmware update?
I have tried all of the above permutations on a V3 camera running firmware, and on a different V3 camera running the firmware.

I too am having trouble getting my newly purchased camera from Amazon from picking up on the V3 RTSP. It came out of the box with non RTSP firmware. I sequentially updated it via the app to, then, and finally

It appears that camera completely ignores any firmware update files on the SD during boot. I have found that neither the RTSP version nor the latest non-RTSP version are recognized during camera startup with the setup button pressed

The FCC ID on the bottom of the v3 camera that refuses to recognize any firmware placed onto the microSD card is: 2AUIUWYZEC3B It is possible that there is a hardware version of the v3 camera that doesn’t accept firmware updates via the SD card

– Update, got it working
The 8 GB card I was using was the issue. I switched to a 16GB card and it worked.

1 Like

I have also had the same problem and solved my problem using a 10 year old SD card i found.

I had two new cam v3 and 3pc of 32gb sandisk ultra SDHC and the first camera worked fine when i upgraded firmware with this SD card but the other camera did never work until i picked up my old 2gb.

The weird thing is that the first cam accepted the new SD card but the other cam didn´t work with any of the 3 new sd cards…

Wyze got some work to do.