Troubleshooting Recommendations for Pan Cam v2 with Solid Red LIght

One of my Wyze Pan Cam v2’s seemingly died recently as it was no longer available in the app. Thinking it might have lost WiFi connectivity, I pulled the power cable and let it sit before trying to in the app again but no go. Turns out when the cable is plugged in, I get a solid red light that remains indefinitely.

  • Pushing the Setup button does nothing
  • Pressing & holding the Setup button for an extended period of time does nothing.
  • Roving the power cable, pressing & holding the setup button then reconnecting the power cable (all while still holding the setup button) does nothing either
  • I’ve done the above tests with & without the microSD card plugged in - no change
  • I’ve tried powering the unit with a different cable & power adapter - no change

I’ve had the camera for I nearly 2 years and while WiFi connectivity was an issue here & there, usually a reboot solved it for a few weeks.

Before I ewaste/ecycle this device, are there any other official or unofficial things I should try?

The only thing you haven’t listed is an attempt to manually flash the firmware.

When you do the factory reset, holding the setup button for 10s without an SD Card, does the light flash at all or does it stay solid red the entire time with no change?

1 Like

Thank you for taking the time to reply.

The light stay solid red the entire time with no change.
I can try th firmware update, was sort of on my list but given the response (or lack thereof) so far I wasn’t sure of it was worth trying.

1 Like

I wouldn’t give much hope to a firmware flash then. But if you do try, I would go back at least one or two versions, perhaps something 4.49.1 ish.

1 Like

I gave it a go but no dice. Oh well. The other 2 are working just fine so I’ll replace this with a Pan Cam v3 and probably get a warranty.
Thanks for your help and time @SlabSlayer!

1 Like