Flashing your WyzeCam Pan firmware

My card is a 64GB one.
Today I tried roommate’s 32GB.
it worked!!!
Downgrading. Will see if it can solve the problem.

1 Like

Great! Thanks for reporting back!

It’s done.
Wow. I see the green tagging and it tracking if i turn it on.
And motion events start working too.
But amazon replaced another one on the way arriving tomorrow. :frowning:
Don’t know what to do.

You can make Windows not add a file extension automatically when renaming a file by putting the entire filename you want in quotes when, EX: “demo.bin”.

I have similar problem with @Joe_Z. The motion detection of my Wyze Cam Pan doesn’t work. I try to downgrade the firmware follow the instruction. However, after step 2 and 3, it never show solid blue lights, and enter ‘ready to connect’ mode. Any idea about that?

I did place ‘demo.bin’ file (with correct extension file name) on the 32GB sd card. The sd card works well and Cam Pan can record video on it. But I can never flash the firmware successfully :frowning:

Since no one else has responded (on Android, don’t know iOS)
There should be a new upgrade available. But if you can’t find it (I think it’s xxx.60)
Try going to
Settings–>Device Info–>Firmware Upgrade–>Have problem–>Revert Firmware

I used use a 64GB card. It didn’t work.
Then I used another 32GB one put the demo.bin in and it worked.
Make sure you unplug it put card in and then hold the reset button and plug power back, still hold the button till there’s a blue light up.

Anyway the new firmware .60 is out.
I just upgraded. No problem. The description is fixing this problem.
Try the new one first.

Thanks! I tried another sd card, and it works. The new .60 firmware also works well.

How-To Articles 101: If you’re posting an article on how to flash your firmware, you MUST link to a page that has the actual firmware downloads. Stating “download a specific version of firmware” is NOT helpful.

Welcome to the Wyze Way (sarcasm).
Things are often buried.
There are Beta FW’s and Public FW’s.
Public are here:
I don’t know where Beta are kept.
But since you are in Beta - here we can usually just go to:
Device info–>Firmware Upgrade–>Have Problem> and see a selection of firmwares to revert to.

1 Like

Were you able to resolve this issue? I am experiencing the exact same issue and I would prefer to keep the camera, I don’t want to go through the trouble of returning it.

Any tip for the step 3? I hold the button until the camera start moving, No blue light appear. I dismount the SD card and I see 2 new folders Record and Time_lapse .

  1. Press down on the setup button and keep it held down while you insert the usb/power cable.

  2. Keep pressing down on the setup button until the light on the front of the camera turns blue(ish)… shouldn’t take that long… 5-10 seconds tops.

  3. After the light turns blue(ish)… release the setup button.

After a few minutes… your updated camera should be good to go. If not… make sure that you renamed the firmware download to demo.bin… and copied it to the root directory of the SD card.


The bluish looked to me to be a mix of a yellow light and a blue light.

Thanks, But I tried 10 times already and I can not make the light go blueish. I’m using a simple sd of 16 gb.

I had a similar problem. Formatting the card inside the Pan Cam before copying over the file solved it.

I also had the same problem. Out of desperation i just proceeded like the lights acted as they were supposed to, power cycled the cam and reinstalled it. Worked fine.

Been trying to do a manual firmware update for a while now and could not get it to work. The original steps where/are leaving out some confusing details. This is what I did, and it finally worked.

Windows installation:

  1. Use a 32gb MicroSD or smaller. (I was originally using a 128gb and it wouldn’t work.)
  2. Download the firmware from the website to your computer.
  3. Locate the ZIP file that you just downloaded and Extract All to somewhere on your computer.
  4. Go into the newly extracted folder and locate the “demo_v*******.bin” file.
  5. Copy this file to the root directory of the MicroSD Card
  6. Rename this file that is now on the root of the MicroSD Card to “demo.bin” Without the quotes.
  7. Safely eject the card from your computer and install it into the V2 Camera
  8. Press and hold the Settings Button and plug the camera into power
  9. When you see the light turn solid blueish, let go and wait for it to complete the update
  10. It’s done in a couple of minutes and the light will flash rapid orange
  11. Reconnect to the camera by pressing the Settings Button and go through the setup process with the Wifi QR Code in the app.

The biggest difference here, is that a lot of the earlier posts don’t specifically mention what you need to rename to demo.bin. It’s elusive to either the Folder or the actual file.

1 Like

Sounds like you are actually doing a Factory Reset followed by a manual reflash of the firmware, Good procedure! Congrats on getting it to work!