Wyze Robot Vacuum Setup Issue - 1/25/21

1/28/21 10:50 AM PT - We have identified a timing issue that could cause devices to fail the setup starting when the issue was first reported. We deployed a fix that will prevent it from happening again and are waiting for verification that this fully addressed the problem.

However, devices that failed setup between 1/21 and 1/27 will not be able to be recovered by customers. If you have been impacted by this issue, please reach out to Wyze Customer Support for a replacement.

1/26/21 2:15 PM PT - We are continuing to isolate the cause behind some folks not being able to complete Wyze Robot Vacuum setup. While this is related to a separate issue, all customers using Wyze Robot Vacuum should make sure they are using at least the 2.16.55 Android app or the 2.16.48 iOS app due to the recent certificate update.

Further, we’ve found some success for some people with restarting their vacuums. If you cannot see the Wyze Robot Vacuum WiFi broadcast during setup, please remove the Wyze Robot Vacuum from the charging station and then press and hold the power button on the vacuum for 5 seconds. This should restart the vacuum and the WiFi broadcast should appear again during the setup process.

Thank you for your patience.

1/25/21 10:00 AM PT - We are looking into an issue that is preventing Wyze Robot Vacuum setup for some customers. We apologize for the difficulty and will post updates here when we have them.


Thanks god. I have tried a 100 times and on 3 different phones to connect and cannot get it to connect. Please help. I am using the latest version of the android app. I opened my box 2 days ago. and these are the steps I been taking:

Reset all the devices.

Turn off mobile data

Open the app and click on add device

Put the robot in Wi-Fi reset mode

Connect to my Wi-Fi within the app

put in the Wi-Fi password

Apps asks me to connect to robot’s Wi-Fi

I connect

Phone drops the connection and it disappears from the list of available Wi-Fi(s)

App fails to connect


Same result.


I’m glad for your sake that they found out this is something they need to resolve.

For now, rather than continue to increase your frustration, I’d probably just recommend to wait until they post an update for you here, then it should hopefully run setup smoothly again without further aggravating your emotions. I know I would be really frustrated too and feeling relieved to learn they know there is an issue they can resolve to make it work.


Yeah thank you. I am a little frustrated because I had a working robot that I bought on BF and just returned because I got my Wyze. I was so excited to see it in action. I am not losing my mind or anything but it is odd because Wyze is known for smart devices and been doing this for a long time. I just expected better. That’s all. I will definitely wait for a solution. The robot looks so solid so I hope everything works out!


It is strange that the issue is only affecting some people and not others. I am also using Android and mine set up completely fine.

I know some people have reported some issues depending on what their WiFi credentials are, and when they changed them it fixed their set up issues. For example, a while ago, someone had issues with symbols in parts of their WiFi passcode and so when they removed those and tried again, it finally connected. I am guessing right now Wyze is simply looking at the firmware and running tests to now make sure the vacuum will accept all the possible WiFi credential variations (lengths, symbol locations, protocols, and all of that kind of stuff). When I was setting up my Wyze Bulbs and Plugs a year or so ago, I discovered that my Router had a weird setting called WMM that was causing issues with IOT device setup…but it was only some devices, and not others (it wasn’t Wyze’s fault exactly…LOTS of IOT device brands had this issue), and I had to find a way to disable the WMM in my router (which was actually really complicated since there wasn’t a setting I could switch, I had to modify the firmware), and once I did that, it allowed me to set everything up finally. Such a pain. But since some devices would connect without the WMM interfering, you’d think manufacturers would just start making devices that could bypass that stupid setting.

Point is, hang in there, worst case scenario there are some things you can try to get it to work even without Wyze’s coming update/solution…but I’d hate to have you go through all that crazy hassle I had to do a year ago when it’s very likely they will figure things out and make it really simple for you relatively soon, ya know? But I almost guarantee you can get it working one way or another, even if they just have to send you a replacement for one with updated firmware that isn’t having that issue. Wyze has always done right by me (more than reasonable actually) whenever I’ve had any issues.

1 Like

Thanks for giving me such detailed explanation and insight. Yeah I actually really like the built quality of this robot. I am more hopeful since you stand by their support.

My issue seems to be the robot WiFi dropping immediately after the phone initiates connection. I will change my WiFi password since I do have symbols in them and give it a try. great advise. I will wait it out and hope for the best.

1 Like

It’s not that we can’t get the vacuum on our networks,( Fresh install, Never added to the app before a certain date. ) I can see the vacuum attached to my network. Just won’t connect in the app.


Seeing the same thing on my end. Vacuum connects to my network but never shows up in the app.

Received on 1/23, so I wasn’t able to do a firmware update before the 1/20 cutoff. I really hope this is an issue they can fix server side, and it’s not bricked firmware… I’d hate to wait another 2-3 weeks for them to ship another one.

Would be nice if Wyze would clarify what’s going on here.


I saw via TestFlight they have a new software update that states it will correct the issue. Anyone confirm? Will be a bit before I’m back at the unit.

1 Like

Currently they are not sure what is going on, they are looking into it.


Let me know if you want me to record a demo, showcasing what I am doing exactly and how the app responds. That may help them as well.


Easy and quick solution is one of the two:

  1. Make sure your app is updated.
  2. Delete and reinstall your app.

Tried both of those. Even switched from the Beta to the regular app and back - no dice.

So that’s not the solution, for some of us at least.


Duh thats like the most overdone route anyone can take with any IT issue, Update and make sure uninstall install. obviously this is a much bigger issue. I have tried any combination of solutions on 3 different phones. multiple times. If you are installing the app from the Google App Store it is always the latest version. This is happening to people installing for the first time.


Thanks for letting me know. I assume you reset its WiFi AGAIN when you did that?

1 Like

Just an update: TestFlight app 2.17.21 did not work for me on iOS, iPhone 11. Vacuum did connect to Eero again, but just won’t show up in the Wyze app.

Same here.

Sounds like their app update was a little underwhelming for then “fix”. I was prepared to wait and now I’m aggravated all over again.

I was let down again.