Robot Vac will not connect

Is this update still valid??
I just got my vacuum today, and cannot set it up. Tried 2 routers, 3 phones. Countless different configurations. A vacuum did show up but the name was that of something that belonged in the backend of the app. I tried using it but says the device was offline.

Held on hold for 30 minutes with Wyze today before I had to go… Not totally Wyze’s fault though. Fedex was a good 3 days late or more.

There is a micro usb in the bottom of the robot!!! Can we not just update ourselves??? Give us technically inclined guys an option and save some money on shipping these units!


Hi @christianolson292 and welcome to the community forum! :slightly_smiling_face:

Call Wyze back or set up a Support ticket on-line. They are working on solution but may have to ship back.

1 Like

I’m going to call them Monday when their open. This is crazy… I just got mine yesterday. I’m in Canada so I’m not sure how that’s going to work…

I just received mine yesterday, although I ordered it on the first day they opened pre-orders. So much for shipping based on when orders were received, Anyway, it won’t connect. I tried to connect using IOS and android, resetting the router multiple times, turning off 5G, resetting to factory settings, etc. Spent about an hour on a support call. Does anyone know how to turn off the annoying blinking white lights? This vacuum must have a problem connecting as they have some sort of survey about connection issues.

Received mine this weekend. Will not connect. Opened support ticket, no response.
App is the latest Android version.

I contacted support by phone yesterday. Tried a factory reset to no avail. They asked me some questions, asked me to send a screen shot on the connecting screen, and they said I’d hopefully hear something Monday.

I too wonder about using micro USB port on bottom…

I have had the vacuum 2 weeks. Setup went as instructed with no problems. It mapped and docked with no problems. There is needed updates to the editing “blocking” on the map.
Couple days ago I lost the internet connection due to a power outage. It did not reconnect like cams and other units. Took several attempts to regain the connection. Factory resets, deleting device, and resetting connections. Ensure you are completing the factory reset. Hold home button for 5 seconds until its says it is resetting and press the home button again till it says factory reset complete. then press both for 3 seconds to enter the wifi config. and finish as instructed. It remapped and is working great.

1 Like

Wyze currently only sells in the U.S. Products outside of the U.S. will be limited to online support at Unfortunately, it’s unlikely that you’ll be able to get a replacement unless you have a Us.S address to ship to.
This is stated in Wyze’s terms of service.

  • Products returned from outside countries where Wyze ships Products

Got a ticket in and responded to their canned first response. I’ll let yall know where it goes from here

Opening a ticket and responding to the Support eMail stacks the trouble in a good place. :+1:

Anyone experiencing this issue can you let me know if this is the first time you are setting up the vacuum or if it was previously installed. Are you using Android or iOS and what is the app version number you are using.

If you are using iOS please make sure you are updated to v2.16.48

1 Like

This is the first time I have tried to set up the vacuum. I received it on January 22. I have tried both IOS and Android. I tried it on an iPhone 6s and an ipad pro. On the android side, I tried it with a Samsung Galaxy Note 20 Ultra and a Samsung S4 tablet. The IOS version was v2.16.48. The android version was 2.16.55. I disabled 5G on the router. I have reset the vacuum multiple times.

1 Like

First time setup. Android 2.16.55
Received the vacuum 1-22-21

1 Like

I have tried both android and iPhone. I am on the latest android and iOS version of Wyze. First time I tried to set it up was last night Jan 23.

1 Like

problem i had was losing wifi connection after a power outage. That said it took several attempts to recover. Basically i did a factory reset and then did a wifi config. When wifi connections shows WVCR I selected and was good to go. This took 3 attempts before wvcr showed.

Hi all – I am having the same issues with my new Wyze robot vac which arrived three days ago. First had to wait for the new Wyze app update to be released so I could properly pair the vac to wifi. Then after that was successful I also updated the vac to latest firmware too…so now running the latest code on both the vac and the app. It has yet to store a full and proper map of our main floor…which of course makes it difficult for it to get the place clean. In two attempts to clean thus far, (yesterday and today), both times it lost connection with wifi and I could see it drop off. The wifi signal is very strong and we have full coverage across this floor and two others, one above and one below this floor…so the vac was within 20-30 feet of the router both times it failed. And we have an Eero wifi mesh network with Eero devices on each floor to extend the range, so we don’t lose wifi coverage on anything else in the home. When I got the notice that it dropped, I could still look (live video) at what was happening on that floor via my Wyze cams… Anyway, once the vac looses wifi it just stops and shuts off wherever it is and that’s where I find it when I return. It also mapped the floor differently both times…it looked like it “added” a room on the side of the house the second time – that it also cleaned! Thankfully it’s not charging me “by the room” for the vacuuming. :wink:. Anyway…first impressions are not good. I think I need help from Wyze support to get this resolved and working properly…or I’ll end up returning it. I’d love for it to WORK…But thus far, dissappointed in the performance. Hope someone from Wyze can call me or email me with recommendations on what to do next, When I try to submit a support ticket the auto-reply system just tries to point me to the answers to the question it thinks I’m asking. Nope…that’s not working. Wyze,I hope your support folks are monitoring this community! – Jim Bartlett, Littleton CO. You just shipped me my unit so you should have my full contact info, Thanks in advance for your assistance!

Hi Jason – I’ve had my Wyze vac unit several days now…see detailed post further below with summary of issues, I was able to successfully connect the vac to wifi (2.4 GHz) after first updating the Wyze app to latest version once it was released,…then updated the vac to latest firmware also. iOS user here on an iPhone X, and iPad Air. The vac has yet to work properly…details in my longer post. Hope y’all can help me get it working. Thanks!

1 Like

Hi @jim.bartlett and welcome to the Community foum! :slightly_smiling_face:

We are volunteers and help where we can. Regarding "When I try to submit a support ticket the auto-reply system. . . "

  • Continue with NO answers until you finish the suggestions.
  • Eventually get to “Contact Support” & “EMAIL” prompt where you’ll be able to enter an acutal problem statement and your contact info.

Hope this helps. :+1:

Same I’ve spent hours never being able to set up for the first time, multiple phones (Samsung Galaxy S9+ and Google Pixel 4a), multiple routers (erro and Zyxel), all the same result. Support just sends typical troubleshooting steps… I’m done trying for now.

I actually had someone with Wyze reach out to me today. It was a pointless contact, but at least I’ve heard directly from them that they are working on it. I’m optimistic.