Robot Vac will not connect

Thanks Hill… hope they get it figured out soon. :crossed_fingers::crossed_fingers:

Thanks for sharing that David. Hope we get resolution soon!

My email: the application (ver 2.16.55) will eventually timeout trying to connect.

Support Response: Please make sure that your Wyze App is up to date. For iOS, 2.16.48 and for Android, 2.16.55.


1 Like

My 2¢ on this…

Having the same problem here. Pairing stalls out on the “Connecting… This could take a minute.” page.

I’ve tried everything - factory resetting, different devices running the latest Android app (v2.16.55), different routers broadcasting dedicated 2.4ghz networks with “simple” names and passwords, nothing works.

If I run a Wi-Fi scanner program I can see the Vacuum stop broadcasting its network a few seconds after the app starts to connect, so I know the app told the vacuum to do something.

My vacuum was shipped out on 1/16 and arrived on 1/23.

Wyze tech support chat wasn’t very helpful, and insisted that I just do another factory reset (which I’ve tried about 3 times now). I’ll try a few more resets when I get home later today, but I don’t have high hopes for it to work at this point.

It would be really nice if someone at Wyze would actually acknowledge this issue and let us know if there is fix on the way.


I had the Vac installed and operating correctly for about a week before I took a vacation and came back to the notice about updating app and vac firmware. Vac offline - updated app, Cannot get vac online - it is connected to my router as I can see it with an ip there but it still cannot contact the server.

I haven’t resorted to factory reset yet as that only seems to have worked for a couple of people and I am still using it with a manual push of the power button and I don’t want to lose the virtual walls I have set up as that would make it completely useless to me the because it would drive into the floor level fireplaces and make a huge mess - ask me how I know from Roomba days…

I tried contacting support via email in the app last week but have not had any response - the app just spins after hitting the send email button so I’m hoping their lack of response is because the app never sent the email. Tried again this morning from chrome on mac and it went.

Iphone XS Max, latest software all around. Google wifi mesh.

Received Vacuum Friday. It will not connect to Android version 10 app. I have app version 2.16.55

Same experience for me. I called support and mostly canned responses and i have probably 50+ wyze devices already connected to my nertwork with no issues and can’t get this working. Hopefully they will come up with a solution soon. This is the most money i have spent on a wyze product, and so far the most issues and haven’t even gotten it connected yet :frowning:

Hi @circ and welcome to the Community Forum! :slightly_smiling_face:

Wyze probably never received your message. After successfully opening a Service Request you’ll received an automated reply with the Support Ticket number.

You can try sending message from the web at:

-or- by phone:
Live support is available: +1-206.339.9646
Monday - Friday 5 am - 6 pm PT | Saturday 8 am - 4 pm PT

Update - I called support and was instructed to perform the factory reset - did it, and the setup went fine. Apparently my “failed” firmware update did actually take place as the vac came online with the current firmware.

I had deleted the vac from the app and when I set it up again it came back up with my map and virtual walls, but once I started a clean, the map disappeared and it started fresh. Re-mapping not that big of deal considering its working now.

One thing to note. When I did the factory reset, it took several tries to get the timing for the second home button press correct. First long press you will get the audio message “factory reset will begin”. You have to press and hold the home button again IMMEDIATELY after that message - maybe even during - and then you’ll get a different message that the reset happened. If you get “factory reset will begin” again then you haven’t done it right yet.

Good luck everyone.

1 Like

So you were able to connect before and it was working? Most of us can’t connect for the first time and so we can’t trigger the firmware update. Good to know that the reset fixed your issue though. Resetting hasn’t worked for me for my first setup so far…

yes, my vac set up and worked fine for several days before the updates and the problem.

I’m with you @shane.ppikelin . Never got it connected the first time. Tried Factory reset also but no luck.

recieved mine on the 22nd. i spent several hours trying to connect it for the first time to my android phone (latest app, also tried beta app) and i tried on my ipad. Neither was able to get it online. i tell the app my wifi password, connect to the wifi of the vacuum, i see it drops away. i go back to my wifi and it times out and the vac continues to blink blink blink. I have checked clients in my router and see a device from wyze i assume is the vacuum.

Got on the phone today, they should be sending a return label to replace soon. I asked about the micro usb option to update the vac and they said its not an option at this time…

(Wyze Robot Vacuum Setup Issue - 1/25/21)
1/25/21 10:00 AM PT - We are looking into an issue that is preventing Wyze Robot Vacuum setup for some customers. We apologize for the difficulty and will post updates here when we have them.



Ticket 1012357

I put in a support request and got a very similar reply along with directions on how to request a return/refund. I’m going to hold off a few days to see if there’s a resolution before I think about returning the vacuum. Fingers crossed!

Has anyone tried the app update pushed today via the Beta channel for IOS? States it fixed the issue with connecting.

And when will the android beta roll out for test with this fix?

just installed the beta on ios, but it didnt fix anything for me.