SOLVED: Robot vacuum does not connect to wifi

Hi Wyze Fam,

For the love of our Lord Jesus Christ, why doesn’t my robot vac connect to my wifi (2.4/5.0)?

I consider myself very tech savvy and I’m losing sleep over this.

Turned off cellular - check

2.4 GHz wifi only - check

Finds and connects phone to robot vac wifi - check

Returns to Wyze app (as instructed) and NOTHING happens. It just sits there…

Any help is appreciated.

Thanks

You may need to contact Wyze for a walk-thru with Support. They should be able to remedy one way or another:

Customer Support

There are many ways to contact Wyze. Their phone number is (206) 339-9646, or you can chat with an agent or create a ticket on the support site.

They’re open for support between 4 am-8 pm PT Monday through Friday, and 8 am-4 pm PT Saturday.

1 Like

With the help of Wyze Support, I got it to work. Thanks, Gene! In following his direction, the only thing I changed was turn on Precision Location on Wyze app and have vac attached to the charging station.

I’ll post his directions here for others to ref.

=====================================

Before troubleshooting, please make sure your Wyze app is up to date.

  1. Confirm the customer is following the steps outlined in the Wyze Robot Vacuum Setup Guide, here.

  2. Ensure the Wyze app is updated to version 2.26.36 (December 8, 2021) Android & 2.26.21 (November 11, 2021) iOS.

  3. If using iOS 14 or later, ensure that Precise Location is ON.

  4. Setting > Privacy > Location Services > Precise Location.

  5. Ensure Local Network permissions are on.

  6. Setting > Privacy > Local Network

  7. Before set up, turn off the cellular data on your mobile device.

  • Some devices may try to automatically connect to cellular data while not connected to WiFi. This can prevent successful setup.
  1. Connect your vacuum to the charging station by making sure the slices touch.
  • The status lights should be lit up, with the vacuum connected to power and charged enough to turn on.
  1. Confirm the status lights are blinking white while attempting setup.
  2. If the status light is pulsing slowly, is solid, or another color, then it’s not in WiFi configuration mode.
  3. Ensure you are connected to a 2.4GHz WiFi network.
  4. Confirm the Wyze Robot Vacuum is within 10 feet of the router for set up.
  5. Try forgetting the Wyze Robot Vacuum WiFi.
  6. While trying to connect to WiFi, the status lights should be blinking white.
  7. If the status light is pulsing slowly, is solid, or another color, then it’s not in WiFi configuration mode.
  8. Still can’t connect to WiFi / complete set up? start setup again, ensuring you have cellular data turned off. If you’re still experiencing issues, go ahead and try rebooting your device and your router.
  9. If you have special characters in the WiFi network name and/or password, try changing it to just letters and numbers.
  10. Check to see if you have the MAC address binding feature on their home router WiFi router disabled.
  11. If you are not sure, try rebooting the router and trying to set it up again.
  12. Factory reset the Wyze Robot Vacuum.
  13. Press and hold the home button for 5 seconds.
  14. You will hear “factory reset will begin.”
  15. Release and hold the home button again for 5 seconds.
  16. You will hear “Factory reset was successful.”
  17. Go through setup.
  18. If the issue persists, please run a RouteThis Helps scan and reply back with the scan key
3 Likes

The instructions you posted say Precise Location in iOS, not in the Wyze app?

I finally figured out that my network password and Wi-Fi password both had special characters in them. Once I changed my network and Wi-Fi passwords using only letters and numbers, mine connected the 1st try.
Hope it works for you

1 Like

Thanks for this post, I was getting a little frustrated, but these instructions saved the day. Thanks.

This resolved my issues. Thank you. Should be noted on the App as it could have saved me a lot of time.

a bit strange when I first got the first one everything worked fine until 01/24/2022. Now try to set up the replacement one It’s acting the same way not connecting to the Wi-Fi I tried all the steps except for the one stating password with special characters issue. again this is strange because the first one was set up with the special characters in the password of the Wi-Fi. I just found it very strange that this could be the problem unless there was a update in the firmware that make this an issue.
I’ll try changing the Wi-Fi password tonight if it doesn’t connect vacuum cleaner number two will go back And I will ask for a refund. pretty sad because this was a gift.

This just happened If the wyze app doesn’t pick up this vacuum cleaner why did Alexa pickup?

3 things that worked for me when I had difficulty connecting to wi-fi

  1. Enabled precise location on location services
  2. Moved the charging station closer to the router for the initial setup
  3. Turned off cellular on the app as well as on my phone for the initial setup

This also happened to me (aug 29 2022) on android.

Steps to fix:
connect to 2G network
get vacuum to be in pairing mode when both lights are blinking white
on the app, attempt to pair and give credentials for your 2g network
when the white lights are both solid, manually reconnect to the 2g wifi you gave to the robot
you will then be connected.

Problems i encountered:
phone was set to auto reconnect to the 5g network
on the wyze app, my phone never reconnected to the 2G network and was stuck waiting on the app.

I had to move and didn’t update the vacuum for 3 months, current version 1.6.73 and latest is 1.6.202 but i was still able to connect after manually choosing a 2g network and manually reconnecting to 2g wifi on my phone when the wyze vacuum lights were both solid white.

hope this helps someone

Another problem, robot vacuum would not connect again. Turns out I had to update the firmware of my netgear nighthawk m6 pro and the vacuum would finally connect to the app.

This was after resetting vacuum to factory settings, power cycling the nighthawk m6 AND tp-link RE550.

Took like 10 days to figure out on and off, hope this helps someone.

1 Like