Wyze Vacuum WiFi Connection Drops Out

Just starting with the Wyze Vacuum. After initial setup (challenging until you get used to it), my vac seems to drop its connection to the internet quite readily. That’s problem one. Problem 2 is, once dropped, the only way I have found to restore the WiFi connection is to delete the device and add again, which is painful.

Anyone having similar issues, or a quick way to restore the WiFi connection?


I am having same issue. Have not found a solution. Emailed Wyze and waiting for response

I have found a way….a very cumbersome way. Waiting to see if allowing it to “complete” will make a difference (all runs have been aborted for various reasons so far).

The way that seems to work is to delete the vacuum, start over as follows:

  1. Factory reset
  2. Follow app instructions to add new vac (reset wife)
  3. Attach to your home network first
  4. On its command, link to Wyze vac network via app (the one that starts with VCR)
  5. Then go back, the app tries to connect to home Wi-Fi___33. Will say “Connecting”. Might take more than one try. If it takes over a couple of minutes, cancel & try again from the start

It can’t be this hard…can it?


Update: it finished its mission, and got back to the charging station. It was on the network for a short time after that, but now it says “The robot is disconnected from the internet”. Unless a miracle happens, the only way to get it back on it do delete and start over. Ugh.


For me, the first day was troublesome. But since then, I haven’t noticed it dropping the connection.

But one thing that worked for me to get it connected back was to turn the vacuum off and then back on. That forces it to try reconnecting, and that worked every time for me.

1 Like

This worked for me. I have mesh router, will not connect to WiFi network. It will connect to guest network but would lose connection after a few hours. Factory reset didn’t fix. Rebooted router, factory reset vacuum, connected to guest network, and it has not lost connection so far. It’s been over 12 hours. Hoping that fixed it.

I also have a mesh wifi system. My Wyze robot vacuum was docked overnight. When I got up in the morning I noticed no lights were showing on the vac. Also my app showed that there was no internet connection to the vac. I started pressing the buttons on the vac (I don’t remember in what order) and finally the vac came on. At that point the internet connection to the vac was restored and I could see the saved map.

I’m having the same problem. 1 hr into use while vac was mapping it dropped the internet and hasn’t reconnected. still cleaning the house and I don’t want to interrupt it’s mapping so haven’t troubleshooted yet, but shouldn’t have to on a new device! no problems with other devices. no problems ever. clearly an issue with the device. Wyze, what is being done to address this? This is more than a minor bug it is clear.


Update after the recent update caused by the “server-side changes”.

I can now readily add a new vac and have it connect to the internet. However, after having it sit there for an hour or two, right in the same room as the access point, it lost its internet connection.

Seems like Wyze has more work to do. I’ve quit beating myself up for being a dense user.


Mine just started doing this. After a week of no problems at all, now the app is saying the robot is not connected to the internet. However, it IS connected to my wifi network, has a valid local IP address and responds to ping. So I am guessing it is trying to phone home to some remote server and can’t reach it. All my other devices are having no problem at all reaching the Internet, so I am guessing maybe the remote server is down. I am on the 1.6.97 firmware and I am using the latest Android beta app.


Same here. Mine has been fine, but it just recently disconnected. Someone else just started on thread on this too. Android app. Firmware 1.6.97

Same problem here. Just upgraded to firmware 1.6.97 evening of Jan 19. Now I get a message “robot is disconnected from the internet” message. I tried cycling the power with no success.

Same here. Firmware 1.6.97 which fixed other things, that no longer matter since it’s not connected anymore.

Also having this issue now. Started about 20-30 mins ago. I’ve had no issues up to this point.

My robot is suddenly having connection issues as well. It’s been fine since I received it on Dec 26, but a moment ago I noticed the lights on the bot are flashing white and the app says “The robot is disconnected from the internet”.

WiFi connection is solid (-56 dBm), has a valid IP and responds to pings. It appears to be communicating with an IoT AWS endpoint just fine.

iOS: 14.3
App: 2.17.11 (6)
Firmware: 1.6.97

Mine is flashing white. Latest firmware 1.6.97

Same wife just noticed that the app is showing not connected to the internet. Vacuum has a valid IP address, and all my other wyze cams are working fine. I have it doing its 3rd run right now with no issue but do think it might be a wyze server issue. Ill report back once i see it has regained “internet”.

IOS Wyze APP 2.16.46
Vacuum firmware 1.6.97
Plugin version 1.6.3

Has worked flawless to this point to include setup and the mapping staying static.

Same issue with my robot vacuum. Had it 3 days and it’s been working flawlessly. An hour ago or so the app started showing ‘not connected to the internet’. All my other Wyze products are responding normally (v2/v3 cameras, scale).

iOS Wyze app 2.16.46
Vacuum Firmware 1.6.97

Looks like Wyze is aware of the issue:

1/20/21 3:40 PM PT - Some Wyze Robot Vacuums are having difficulty connecting to the internet. We are working with AWS to resolve this issue and apologize for the inconvenience.

Thanks for sharing :+1: also “some” more like all.