Unable to perform network setup of Wyze Robot Vacuum

I just received my robot vacuum today! I followed the instructions for setup. I ensured that only a 2.4GHz network was used. I have disabled cell data, rebooted the modem and router, no matter what I do, the app indicates the connection failed. I successfully enabled the wifi reset on the robot. I was able to select the robot network when prompted. I see the phone temporarily connect to the robot and then switch back to the 2.4GHz network that I previously input credentials for my 2.4Ghz network in the App. I confirmed that the robot’s private network was no longer advertising the SSID by using a second phone. My network is configured for WPA2-PSK and AES. Please advise… I don’t want to return the unit. Rich

PS: my network SSID has a underscore (‘_’) in it if that makes a difference.

1 Like

I doubt this will be the issue but do you have your wifi limited to a certain version. For example 802.11 n,ac,ax only.

1 Like

These are my router settings. I am using a WRT3200ACM router running ddwrt-linksys-wrt3200acm-webflash build 37305.bin. I am setting up the robot on the guest network. That is the same one all my other home automation devices are on. What are the WiFi standards the robot supports?

Hmm I can’t seem to see anny issue. You did say the SSID wasn’t broadcasting from the Robot? I would try an app reinstall as a last resort. Other than that, the wifi settings look as default as possible. That honestly may be a hardware issue. If you really wanna confirm, if its possible try setting it up at someones house.

During the installation, I connected to the robot’s SSID. after a few seconds the phone phone reconnected to the original XYZZY-guest network. I did this process on two different phones. One phone already had the WYZE app installed for the camera. I used a different phone to try the fresh install that I already tried.

So in order for the robot to disable it’s network, it must have received a command from the APP with the credentials of my guest network and then tried to connect to it. I am not sure what the APP is doing, but it does not see the robot during this process.
I spent most of the day trouble shooting this by trying different routers and varying network settings. I was able to get the unit to connect when I forced the router to 802.11ac with wireless network mode of ‘B’. It offered to update the device firmware. I updated it with the whatever is on the server as of 1/1/2021. I reverted back to ‘MIXED’ wireless mode. The robot cannot connect to the network in this mode. I click on the robot ICON in the APP and it reports the robot is not connected to the internet.

The WYZE robot has a network issue that prevents it from connecting to my WRT3200ACM which I paid a lot more for than the Robot. The only way I can get it to work is forcing ‘B’ networking mode. I have a lot of video devices on that network and I don’t want to slow the whole network down just for a vacuum.

Please advise if there is any firmware change that could allow my network to operate at full speed and talk to the robot, otherwise I need to send it back.

Well, today, I set up an old LinkSys router as a subnet that I can have exclusively 802.11 ‘B’ (11 MBPS) for the vacuum. This is a work around. If you haven’t guessed, I am an engineer and I would imagine not a lot of your customers would go to this extent to get a product to work. Happy new year and keep me posted on long term fixes for this networking issue.


I ran into what I think is the same problem. I was using my iPad to set up the vacuum and got to the point where the robot set up its own network and I connected the iPad to it, but the app never seemed to connect to the robot. It just kept telling me it was connecting and that it could take a minute. Well, turns out my iPad had reconnected to my home network,

I tried it with my Android phone, and it, too, went into the “Connecting…” loop.

Then I found this thread, My router happens to be the WRT3200ACM as well.

I was just about go to the garage and get an old spare router, but decided to give it one more try. Instead of going back to the Wyze app, I hung out in the Network Settings page of Android a bit longer to observe what network changes were happening. Android then prompted me if I wanted to stay connected to the robot network even though it didn’t have internet access. I confirmed, and then went back to the Wyze app. It connected and I was able to complete the setup, download the new firmware, and now the robot is happily vacuuming my home while I run around and pick up stuff he might get entangled in.


I am having this same issue and have tried all of the above without success. I had a similar problem when I tried connecting a Wyze plug one time and it just eventually decided to connect. I am unsure what is wrong. But I need help. I am so ready to return this because I cannot get it to work. I have tried on multiple devices and read the manual cover to cover multiple times. Any other suggestions?

Does anyone use Google WiFi Router/Mesh network? I am having the same issues as others above.

I am experiencing same exact issue. Trying to setup from iPhone.

I have a Google WiFi mesh network, but my vacuum isn’t here yet. Should be here Friday… will let you know if I get it connected up.

I’m having the exact problem as described in the original msg. But I’m using the router./modem that Comcast/Xfinity provided.

One additional piece of info: when I select the WVCR-xxxx network it asks for a password. I don’t have this. Entering my network pw doesn’t work. But just backing out, it seems to momentarily connect and says it will “take a minute”. After about 3-4 minutes it says the connection failed.

Please advise.

I am having the same issues, but am not as tecnically savvy as some earlier posters. My set up is an xfinity compatible Motorola router connected via coax and ethernet. Router info says it is e-dual, running 2.4 ghz. Wyze app hangs up after finding the WVCR*** network. Asks for a password (?), so I enter the router password, hit next and am told the binding failed. About to send this vaccum back. Am I doing something wrong? Thanks

Same problem, a lot of frustration and a total waste of time.
I have Orbi Mesh setup, android app on Samsung S20.

I think the issue is this: Google and Xfinity routers don’t let you pick if you run 2.4 or 5.0. It picks what it thinks is best for the current network state. So the vacuum is never connecting to your wife network because the router is picking 5.0, not 2.4. I have a small portable travel router I use for hotels. I am going to turn that on, as it only uses 2.4, and try to setup the vacuum that way.

I have no clue why Wyze only uses 2.4 and not 2.4 and 5.0.

Similar issues. For my troubleshooting I found that once I connected to the network the Wyze Vacuum was using for setup it was passed my home’s network and passcode. I observed it connect to my eeros mesh using the 2.4 ghz side. I assume the vacuum then shuts down the setup WiFi SSID expecting to connect within the app on the network it was passed (home’s network).

When I went back to the Wyze app, also now on my home’s network, the connection failed. 6 attempts thus far.

I have tried hard restarting my router, modem and phone. I’ve restarted the Wyze app. Sounds like there is a magic combination that may work. I’ll keep trying.

The last app update was a few weeks ago. I hope a new update will solve the problem if I can’t get lucky.

Christmas gift for my wife. Wife rule number 1: “I don’t want to have to troubleshoot the tech you buy me”. I like for my wife to be happy with me. See above for reference to lucky.

In my case I use Synology Router and iPhone. I clearly see that device connects to Wi-Fi successfully and uses network. But I still see timeout in the app. I have 2.4/5 WiFi which automatically selects proper frequency

1 Like

Has anyone received support from WYZE? It’s been crickets on my support ticket.

1 Like

I called and got a support ticket. Agent confirmed my set up should work, not her first call on this problem and acknowleged the issue seems to be at Wyze’s end. But, had no cure yet.

This is what I suspect, because I clearly see that robot is connected to network and uses network. I guess it can’t register in the Wyze cloud…