Wyze Robot Vacuum connection issues

Hey guys! So, I bought the robot vacuum when it first came out and I set it up and it worked great! I haven’t used it as frequently as I thought I would because I wanted to clean up my room before really using it regularly.

Today, I tried to use it and the app said it was not connected to the network. It also said there was a firmware update, but that the vacuum wasn’t on the network so couldn’t update.

I looked online and found some folks with similar issues, but none of their solutions seem to work. I got as far as showing the screen “updating” after deleting the device and reinstalling it, but it was frozen on that screen for forever and then failed.

Now, I can’t even delete the device and reinstall, because even though the device says it has entered wifi network connection mode or whatever, I can’t see the device as an available network on my phone?!



The following causes may cause network disconnection:

-Device not in distribution network state

-User checks home Wi Fi non 2.4G network

-Wi Fi network signal weak

-Wi Fi has a SSID or password of more than 64 bits

-The user router opens MAC address binding, and only the specified device is allowed to connect to the network

It will work great for a while and then go offline again. Extremely frustrating. I delete the device and then try and reinstall but it gets stalled at “Connecting…” on the set up. Then says “Connection failed”.

I’ve followed all of the advice on this forum and others.

It appears to me that the wifi signal from the vacuum does not stay on long enough for the set up, flickers on and off and won’t be persistently on long enough for the set up to complete?