Robot vacuum setup fail

Just received my robot vacuum, but the setup fails. It is having the same issue that is noted on here and reddit, regarding the unit will not connect to the app.

Reading the forums indicates this issue was resolved a couple months ago so I am am wondering if my unit was not updated. Is there a way to update the firmware without connecting to the app? I have not contacted support yet.

If the device does not bind successfully, there are several possible reasons:

1、The equipment does not enter the state of distribution network
2、Users check home Wi-Fi for non-2.4G networks
3、Weak Wi-Fi network signal
4、Wi-Fi with SSID or password greater than 64 digits
5、The user router enables MAC address binding, allowing only specified devices to connect to the network

Thanks for the answer, however I am not smart enough to understand most of that. My wi-fi signal says excellent

My original WRV connected to my network without an issue. The firmware and app was updated regularly, After the Wyze announcement back in Jan/Feb to update firmware or there will be operational issues, I did that. In March I dropped the device from my network to do a factory reset in hopes of resolving a mapping issue. Afterwards, I could not bind it to my network. Dozens of attempts later I contacted “customer support.” Months later and two replacements later and maybe 100 binding attempts, I still have a paperweight. I want this thing to work!!!

Ella01 had some good suggestions, but I’m way past those. I’m a professional IT admin, so this problem is unlikely to be solved with first-level support. I have asked support many questions so that I can help myself, but they either don’t read my ticket or they are politely clueless. I give them credit for sending me two replacements (which don’t connect either). I even changed my network hardware and tried it at another location. (Note that the mfg. dates for replacements might be before that critical firmware update.)

QUESTIONS TO ALL: Perhaps we have the same problem. Help me help us.

  1. Do those having this network binding issue own ASUS routers?
  2. Do those that cannot connect to the network (no binding) own an Apple iPhone SE?
  3. Has anyone figured out why NO 2.4 GHz networks appear in the app when other Wyze products can easily list them?


1 Like

I have isolated my problem and resolved the issue. I imagine that many WRV owners could experience the same issue I had. The problem appears to be related to an iOS update from Apple in the February time frame. It may only affect certain iPhones. My model is an SE (2020). I used an old iPhone 4S to get the WRV onto my network. Hopefully, Wyze will be able to remedy this with an app update. Otherwise, getting a firmware update into the WRV without it on the network is very difficult for the average user.

The workaround is to try using another device to get the robot vac onto your network. Then, if you are using an iPhone like mine, it will work thereafter. If that’s not your issue, then I can possibly help you understand what support is telling you.

Go into your router or on your phone, etc. and try to determine if you are on a 2.4 GHz or 5 GHz wireless channel. Google for help. You will find those terms somewhere in the wireless setup. The unit only works with 2.4 GHz. If you have other Wyze products like cameras and they work, you have a 2.4 GHz network.

Unlikely, but your named network or password can’t have more than 64 characters.

I would ignore #5. If you don’t understand it, then you don’t have your system set up to work with specific MAC addresses. (Each device has a unique address and you can make your network super secure by only letting in those specific devices.)

Good luck!

If your robot vac is working, please ignore the rest of my reply.

If you are using an iPhone, please check my contributions in this thread. I might have discovered one of the issues causing the WRV not to join the network.